LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-29-2007, 07:57 PM   #1
StefanP
Member
 
Registered: Apr 2007
Distribution: Debian 4
Posts: 144

Rep: Reputation: 15
Why the sound works only when logged in as root


Why the sound works only when I'm logged in as root?
When I'm logged in as regular user the volume control is crossed out and when I'm trying to use it I get following message:

The volume control did not find any elements and/or devices to
control. This means either that you do not have the right GStreamer plugins installed, or that you do not have a sound
card configured.

But I have the sound on the motherboard and it works fine when
I'm logged in as root (Volume Control VIA 8235 (Alsa mixer)
A GNOME/GStreamer based volume control application 2.14.2) -also it shows another option Realtek ALC655 rev0 (OSS Mixer)

What should I do so I can have sound when I'm logged in as regular user also?

Thanks
 
Old 04-29-2007, 08:27 PM   #2
osor
HCL Maintainer
 
Registered: Jan 2006
Distribution: (H)LFS, Gentoo
Posts: 2,450

Rep: Reputation: 76
Perhaps there is a permission problem. Check the read and write bits and owners for such device nodes as /dev/dsp, /dev/timer, /dev/control, /dev/snd/*, etc. How this works varies from distro to distro. E.g., you might have owner root and group owner audio (with both owner and group getting read-write access) in which case you must add your user to the audio group.
 
Old 04-30-2007, 05:30 PM   #3
StefanP
Member
 
Registered: Apr 2007
Distribution: Debian 4
Posts: 144

Original Poster
Rep: Reputation: 15
Thanks, it worked by adding the users to the audio group.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wolf et needs to be logged in as root for sound (permission issue) dr_unpleasant Linux - Software 0 07-17-2004 02:26 PM
kde much slower to start when logged in as alan than logged in as root arubin Slackware 0 04-26-2004 04:27 PM
Sound works when logged in as GUI root bmike1 Linux - Hardware 11 08-19-2003 09:32 PM
mozilla works fine when logged in as a user but crashes when logged in as root jimi Linux - General 6 04-02-2003 08:34 PM
Only Sound when logged in as Root iancork01 Linux - Software 6 03-27-2003 06:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration