LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-03-2009, 09:28 PM   #1
criacuervo
Member
 
Registered: Dec 2008
Location: Herrera
Distribution: Debian GNU/Linux 5.0
Posts: 74

Rep: Reputation: 15
why rpm command is not working?


This is happenig when i try to install a package.

[root@millord Download]# ls
Molten-white.tar.gz xmms-mp3-1.2.10-16.fc7.src.rpm
[root@millord Download]# rpm -i xmms-mp3-1.2.10-16.fc7.src.rpm
warning: xmms-mp3-1.2.10-16.fc7.src.rpm: Header V3 DSA signature: NOKEY, key ID e42d547b
warning: user machbuild does not exist - using root
warning: group machbuild does not exist - using root
warning: user machbuild does not exist - using root
warning: group machbuild does not exist - using root
warning: user machbuild does not exist - using root
warning: group machbuild does not exist - using root
[root@millord Download]#

I wonder why , coz i always us the option -i to install a program in fedora and now is happening that.
 
Old 08-03-2009, 09:34 PM   #2
scottro11
Member
 
Registered: Jun 2009
Location: NYC
Posts: 260

Rep: Reputation: 58
Do you realize that you're installing src.rpm rather than plain rpm?

This means, you're installing sources with which to build the package yourself. A package withe srpm or src.rpm doesn't actually install. It goes into various predetermined directories. From there, you go into the SPECS directory and build it with rpmbuild -ba.

There's a bunch of good tutorials about building rpms around. Here's a quick version.

http://perso.b2b2c.ca/sarrazip/dev/r...sh-course.html
 
Old 08-03-2009, 10:36 PM   #3
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,295

Rep: Reputation: 2358Reputation: 2358Reputation: 2358Reputation: 2358Reputation: 2358Reputation: 2358Reputation: 2358Reputation: 2358Reputation: 2358Reputation: 2358Reputation: 2358
I note that you're profile says Fedora 8, which is no longer supported, and that src.rpm is Fedora 7
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RPM command is not working (Segmentation fault) josinjosek Linux - Newbie 4 05-12-2009 06:13 AM
RPM Command not working, throwing undefined symbol error racurtis Linux - Software 2 04-03-2007 01:19 PM
--aid switch is not working with rpm command livetoday Red Hat 1 06-15-2006 09:50 AM
java .rpm chmod command not working! barabus Linux - Software 11 06-06-2005 01:52 AM
rpm command not working sanjaya Linux - Software 7 02-20-2004 01:08 AM


All times are GMT -5. The time now is 09:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration