LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-01-2013, 12:17 AM   #1
lmohammeed
Member
 
Registered: Sep 2013
Posts: 38

Rep: Reputation: Disabled
Cool why my terminal/konsole starts with error msg?


I am using fedora 16.
I got a problem whenever I open the console, it shows this

ERROR: Unknown switch ''. Accepted values: ia32, intel64, mic
bash: /opt/intel/composerxe-2011.2.137/bin/ifortvars.csh: line 36: syntax error: unexpected end of file

ERROR: Unknown option 'PROD_DIR=/opt/intel/composerxe-2011'

Syntax:
/bin/bash <arch> [MKL_interface] [mod]

<arch> must be one of the following
ia32 : Set up for IA-32 target
intel64 : Set up for Intel(R) 64 target
mic : Set up for Intel(R) MIC target

mod (optional) - set path to MKL F95 modules

MKL_interface (optional) - MKL programming interface for intel64
Not applicable without mod
lp64 : 4 bytes integer (default)
ilp64 : 8 bytes integer

bash: setenv: command not found
bash: setenv: command not found
bash: setenv: command not found
bash: setenv: command not found
bash: setenv: command not found
bash: setenv: command not found
bash: setenv: command not found
bash: setenv: command not found
bash: /opt/intel/composerxe-2011.2.137/mkl/bin/mklvars.csh: line 140: syntax error: unexpected end of file

Is this a problem? How can I rectify it?
Thanks in advanced.
 
Old 10-01-2013, 12:36 AM   #2
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
The main problem is that your default shell is bash, but for some reasons the Intel C-shell scripts are sourced. If you're the administrator of this machine, you have to check where those scripts are sourced. I would start by looking at your $HOME/.bashrc or under /etc/profile.d/.

For example, on a 64-bit machine I have a file intel.sh under /etc/profile.d/ whose content is
Code:
#
#  Set environment for Intel(R) Composer XE 2011
#
source /opt/intel/bin/compilervars.sh intel64
 
1 members found this post helpful.
Old 10-02-2013, 11:32 AM   #3
lmohammeed
Member
 
Registered: Sep 2013
Posts: 38

Original Poster
Rep: Reputation: Disabled
Thumbs up why my terminal/konsole starts with error msg?

Thanks colucix
However, that does't help much. Actually I am a new user of linux. Can you or anybody give me detailed steps on how to solve my problems.
 
Old 10-02-2013, 12:22 PM   #4
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Ok. Open a terminal and type these commands:
Code:
$ ps -p $$
$ cat ~/.bashrc
$ cat ~/.bash_profile
$ ls /etc/profile.d
The first one tells me what shell are you using as login shell. The 2nd and 3rd commands show the content of your initialization file (assumed you're running the bash shell, which is the default in Fedora). The last one show the content of the /etc/profile.d directory, where usually administrators put the initialization files for the Intel compilers.

Please, copy/paste the output of these commands here so that we can start to understand what's going on. Thanks.

PS - When posting lines of code or output from a terminal, is a good habit to use CODE tags. To do that you can either switch to advanced mode (see the button Go Advanced below), then select the text you want to embed in CODE tags and press the # button. In alternative you can explicitly write down CODE tags around the text like these:

[CODE]$ echo this is a line from my terminal
this is a line from my terminal
$[/CODE]

that will result in
Code:
$ echo this is a line from my terminal
this is a line from my terminal
$
In this way it improves readability and will preserve indentation, spacing, TABS and any other format specifications.
 
1 members found this post helpful.
Old 10-02-2013, 01:19 PM   #5
lmohammeed
Member
 
Registered: Sep 2013
Posts: 38

Original Poster
Rep: Reputation: Disabled
Thumbs up why my terminal/konsole starts with error msg?

thank you colucix.
See below the output of those commands.
Code:
$ ps -p $$ 
  PID TTY          TIME CMD
 1984 pts/1    00:00:00 bash

$ cat .bashrc
# Source global definitions
if [ -f /etc/bashrc ]; then
        . /etc/bashrc
fi

# User specific aliases and functions

source /opt/intel/composerxe-2011.2.137/bin/ifortvars.sh
source /opt/intel/composerxe-2011.2.137/bin/ifortvars.csh

source /opt/intel/composerxe-2011.2.137/mkl/bin/mklvars.sh
source /opt/intel/composerxe-2011.2.137/mkl/bin/mklvars.csh intel64

$ cat .bash_profile
# Get the aliases and functions
if [ -f ~/.bashrc ]; then
        . ~/.bashrc
fi

# User specific environment and startup programs

PATH=$PATH:$HOME/.local/bin:$HOME/bin

export PATH

$ ls /etc/profile.d
bash_completion.sh  colorgrep.sh  colorls.sh  kde.sh    lang.sh   less.sh                    which2.csh
colorgrep.csh       colorls.csh   kde.csh     lang.csh  less.csh  udisks-bash-completion.sh  which2.sh
Thanks once more, and waiting your response.

Last edited by colucix; 10-02-2013 at 02:22 PM. Reason: Fixed CODE tags
 
Old 10-02-2013, 02:28 PM   #6
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Ok. The errors come from the lines in your .bashrc that source the wrong scripts and/or without the required argument. I would change the following lines:
Code:
source /opt/intel/composerxe-2011.2.137/bin/ifortvars.sh
source /opt/intel/composerxe-2011.2.137/bin/ifortvars.csh

source /opt/intel/composerxe-2011.2.137/mkl/bin/mklvars.sh
source /opt/intel/composerxe-2011.2.137/mkl/bin/mklvars.csh intel64
into a single one:
Code:
source /opt/intel/bin/compilervars.sh intel64
assuming your system is 64-bit. You can easily verify it with the command
Code:
$ uname -a
Give it a try and tell me if it solves your issue. Otherwise we'll dig into it further.
 
Old 10-02-2013, 11:25 PM   #7
lmohammeed
Member
 
Registered: Sep 2013
Posts: 38

Original Poster
Rep: Reputation: Disabled
Thumbs up why my terminal/konsole starts with error msg?

Ok.

It nearly solve the problem, but I got this mgs instead.
[CODE]$ bash: Source: command not found

Is this another issue?
Thanks.
 
Old 10-02-2013, 11:37 PM   #8
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Source must be source (all lowercase). In alternative bash uses a single dot, that is the following two are equivalent:
Code:
source /opt/intel/bin/compilervars.sh intel64
Code:
. /opt/intel/bin/compilervars.sh intel64
 
Old 10-03-2013, 12:03 AM   #9
lmohammeed
Member
 
Registered: Sep 2013
Posts: 38

Original Poster
Rep: Reputation: Disabled
Exclamation I mean my terminal/konsole starts with Source: command not found

I mean now my terminal/konsole starts with this msg
bash: Source: command not found
when I open it
Thanks.
 
Old 10-03-2013, 12:06 AM   #10
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Quote:
Originally Posted by lmohammeed View Post
I mean now my terminal/konsole starts with this msg
bash: Source: command not found
when I open it
Thanks.
I got it. What I see in the error message is that the source command has been erroneously written with the uppercase S. Please, can you post the content of your actual .bashrc? Thx.
Code:
$ cat ~/.bashrc
 
Old 10-03-2013, 12:15 AM   #11
lmohammeed
Member
 
Registered: Sep 2013
Posts: 38

Original Poster
Rep: Reputation: Disabled
Thumbs up I mean my terminal/konsole starts with Source: command not found

Yeah! This is the content of my .bashrc
# .bashrc

# User specific aliases and functions

alias rm='rm -i'
alias cp='cp -i'
alias mv='mv -i'

# Source global definitions
if [ -f /etc/bashrc ]; then
. /etc/bashrc
fi
# added by WIEN2k: BEGIN
# --------------------------------------------------------
alias lsi="ls -aslp *.in*"
alias lso="ls -aslp *.ou*"
alias lsd="ls -aslp *.def"
alias lsc="ls -aslp *.cl*"
alias lss="ls -aslp *.sc*"
alias lse="ls -aslp *.error"
alias pslapw="ps -ef |grep "lapw""
alias cdw="cd /root/WIEN2k"
export OMP_NUM_THREADS=1
#export LD_LIBRARY_PATH=.....
export EDITOR="emacs"
export SCRATCH=./
export WIENROOT=/home/mohammed/WIEN2K
export W2WEB_CASE_BASEDIR=/root/WIEN2k
export STRUCTEDIT_PATH=$WIENROOT/SRC_structeditor/bin
export PDFREADER=acroread
export PATH=$PATH:$WIENROOT:$STRUCTEDIT_PATH:.
export OCTAVE_EXEC_PATH=${PATH}::
export OCTAVE_PATH=${STRUCTEDIT_PATH}::

export PATH=$PATH:$WIENROOT:.
ulimit -s unlimited
alias octave="octave -p $OCTAVE_PATH"
# --------------------------------------------------------
# added by WIEN2k: END

Thanks.
 
Old 10-03-2013, 12:27 AM   #12
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Sorry but this is not the same file you did show in post #5 above. In any case, I don't see the line with the source command. Where did you put it into? Or did you remove it completely?
 
Old 10-03-2013, 04:59 AM   #13
lmohammeed
Member
 
Registered: Sep 2013
Posts: 38

Original Poster
Rep: Reputation: Disabled
Lightbulb why my terminal/konsole starts with error msg?

Sorry this is the content of my .bashrc

bash: Source: command not found
[mohammed@mohammed ~]$ cat ~/.bashrc
# .bashrc

Source global definitions
if [ -f /etc/bashrc ]; then
. /etc/bashrc
fi

# User specific aliases and functions

. /opt/intel/bin/compilervars.sh intel64

You can see the msg in the first line i.e. (bash: Source: command not found)
 
Old 10-03-2013, 05:03 AM   #14
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Quote:
Originally Posted by lmohammeed View Post
Source global definitions
if [ -f /etc/bashrc ]; then
. /etc/bashrc
fi
Ok. You erroneously deleted the comment sign # from that line. It should read
Code:
# Source global definitions
if [ -f /etc/bashrc ]; then
        . /etc/bashrc
fi
 
1 members found this post helpful.
Old 10-03-2013, 05:12 AM   #15
lmohammeed
Member
 
Registered: Sep 2013
Posts: 38

Original Poster
Rep: Reputation: Disabled
Talking why my terminal/konsole starts with error msg?

Ok.
Thanks, I got a normal working terminal now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE konsole err msg:QDBusConnection: session D-Bus conn created b4 QCoreAppliction... jimstaffer Red Hat 0 03-03-2012 10:39 PM
[SOLVED] synaptic starts from kmenu but not from root konsole (and other stuff) mediumrare Linux - Desktop 3 12-31-2011 02:03 PM
opensuse11.0: konsole only starts in root mode Sjonnie48 SUSE / openSUSE 3 12-07-2008 01:50 AM
Alternative terminal to konsole & gnome-terminal Adony Linux - Software 3 10-08-2004 04:59 AM
slooze error: validateInputs(); $msg = $mySlooze->renderPage($vars); echo $msg; ?> rioguia Linux - Software 0 01-26-2003 09:59 PM


All times are GMT -5. The time now is 03:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration