LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-25-2013, 02:06 PM   #1
intmail01
Member
 
Registered: May 2013
Posts: 31

Rep: Reputation: Disabled
Why kernel doesnt run /sbin/hotplug ?


Hello,

Issues are simple, when I insert usb memory stick the kernel didnt launch /sbin/hotplug program.
I set it as executable binary and one time as just a simple text file containing some bash command but nothing happens.

I checked the file /proc/sys/kernel/hotplug, it contains the string path "/sbin/hotplug"

thank you.

Last edited by intmail01; 05-26-2013 at 02:20 PM.
 
Old 05-26-2013, 11:07 AM   #2
bloodstreetboy
Member
 
Registered: May 2012
Posts: 198
Blog Entries: 3

Rep: Reputation: 37
The kernel calls hotplug agents using the /sbin/hotplug program. That's the name we'll assume here, but the actual name is gotten from the /proc/sys/kernel/hotplug file. Like all this functionality, it isn't available unless the kernel is compiled with the HOTPLUG kernel configuration option.

A USB policy agent should be installed into /etc/hotplug/usb.agent where it will be invoked by /sbin/hotplug as appropriate.
 
Old 05-26-2013, 02:24 PM   #3
intmail01
Member
 
Registered: May 2013
Posts: 31

Original Poster
Rep: Reputation: Disabled
Config is already OK for me

CONFIG_HOTPLUG=y

I use slackware 13.1 with kernel 2.6.35.4
 
Old 11-11-2014, 06:34 AM   #4
intmail01
Member
 
Registered: May 2013
Posts: 31

Original Poster
Rep: Reputation: Disabled
/sbin/hotplug is deprecated, udev is the new feature
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] mounting pendrive (USB) via /sbin/hotplug NevemTeve Linux - Hardware 1 02-15-2012 04:36 PM
target filesystem doesnt have /sbin/init. mnconny Linux - Newbie 3 10-02-2010 05:42 PM
/sbin/hotplug not being executed when hotplugging usb stick monk576 Linux - Hardware 1 11-26-2008 02:30 AM
DHCP doesnt renew lease on hotplug sm1else Linux - Wireless Networking 2 04-05-2005 04:10 AM
Upgraded kernel, lilo.conf, didn't run /sbin/lilo dtashima Linux - Newbie 4 10-18-2004 12:21 PM


All times are GMT -5. The time now is 03:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration