LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-14-2009, 04:32 PM   #1
Gwilliams1205
LQ Newbie
 
Registered: May 2008
Posts: 8

Rep: Reputation: 0
Why is web browsing so slow? Fedora 10


I am using Fedora 10 x86_64 KDE and by internet browsing is significantly slower that my windows box. I have read about disabling ipv6, I have done that it did not seem to improve. Is there something that I am missing? any help here would be greatly appreciated. Thank you
 
Old 04-14-2009, 04:52 PM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
which DNS servers are you using ?
 
Old 04-14-2009, 05:14 PM   #3
arckane
Member
 
Registered: Sep 2005
Location: UK
Distribution: Gentoo/Debian/Ubuntu
Posts: 307

Rep: Reputation: 38
I hate link posting to things on another forum, but a regular guy posted a fantastic "speed up firefox" guide. If you don't mind playing with firefox about:config, give this a whirl:

http://geekphreek.com/viewtopic.php?f=2&t=36


(Moderator: If you wish, just copy and post the content and delete the link )

Last edited by arckane; 04-14-2009 at 05:15 PM. Reason: Added mod comment
 
Old 04-14-2009, 06:11 PM   #4
pppaaarrrkkk
Member
 
Registered: Jun 2005
Location: Aylesbury UK
Distribution: Red Hat enterprise linux 6
Posts: 101

Rep: Reputation: 15
I use Fedora 9. I used to use Firefox, but now use Epiphany. I find it to be better in my experience.
 
Old 04-14-2009, 06:20 PM   #5
Gwilliams1205
LQ Newbie
 
Registered: May 2008
Posts: 8

Original Poster
Rep: Reputation: 0
I'm Curious is it possible to get flash player to work for epiphany 64bit like I can with fire fox?
 
Old 04-14-2009, 06:43 PM   #6
pppaaarrrkkk
Member
 
Registered: Jun 2005
Location: Aylesbury UK
Distribution: Red Hat enterprise linux 6
Posts: 101

Rep: Reputation: 15
Sorry, I don't know.
 
Old 04-14-2009, 07:38 PM   #7
Gwilliams1205
LQ Newbie
 
Registered: May 2008
Posts: 8

Original Poster
Rep: Reputation: 0
repo, I will post my DNS when I get home. thank you guys for all of your help
 
Old 05-10-2009, 04:34 PM   #8
Gwilliams1205
LQ Newbie
 
Registered: May 2008
Posts: 8

Original Poster
Rep: Reputation: 0
I do not know how to find out what DNS servers I am using. but this is becoming quite unbearable. my windows laptop is easily 10 times faster surfing the net than my much more powerful linux desktop connected via 1G ethernet vs wireless on the laptop. can someone please help. I remember having Fedora 7-8 and it smoked through the internet. What changed?
 
Old 05-10-2009, 07:29 PM   #9
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
it might be fedora 10 use of ipv6 as default . that your isp is having trouble with it
or just your isp's dns

have you looked into "openDNS"
http://www.opendns.com/
 
Old 05-11-2009, 10:56 PM   #10
Gwilliams1205
LQ Newbie
 
Registered: May 2008
Posts: 8

Original Poster
Rep: Reputation: 0
So do I have to disable NetworkManager to use that opendns because when I try to set it up my options are greyed out for eth0?
 
Old 05-12-2009, 12:05 AM   #11
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
Quote:
my options are greyed out for eth0?
you need to be root to change the settings
System / Administration / network
--photo--
http://www.imagebam.com/image/2c4b4435520344

"Network Manager" only uses the DNS service there is no need to shut it down ( unless you want to use "Network" )
to use opendns all you need to do is point it ("Network Manager" )to there web address .
there is even a "how to" on the site( well Ubuntu but the same) .
https://www.opendns.com/start/device/ubuntu

also if you ARE NOT using a wireless connection you might want to turn off "Network Manager"
and turn on "Network" in the services .
 
Old 05-12-2009, 04:10 PM   #12
salasi
Senior Member
 
Registered: Jul 2007
Location: Directly above centre of the earth, UK
Distribution: SuSE, plus some hopping
Posts: 4,052

Rep: Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881
This happens a lot, and it is almost always due to something badly set up in the networking area, usually a problem with DNS and/or IPV6.

Quote:
Originally Posted by Gwilliams1205 View Post
...I have read about disabling ipv6...
That's certainly a good idea, but you may have to disable it in more than one place. You have probably disabled the use of v6 for 'normal' networking, but, if you have an ipv6 address for your first nameserver, you will still have the problem.

Check /etc/resolv.conf; there should be at least one nameserver there. you should also try pinging that nameserver; any ping time above 200 mS would be a worry. (It might also be set to a local address, eg, your modem/router, which should give a sub-10mS ping time, but raises the question as to whether the nameserver it connects to is fast or not).

Have a quick look at /etc/nsswitch.conf; ensure that the line 'hosts' seems sensible. Whatever is in there, the various sources for look ups will be evaluated one by one. If the first is slow or non-existant, look ups will proceed by trying the first, waiting until it seems clear that this service will not answer, and then trying the subsequent one.

The obvious upshot of this is that everything can get slow if the early services in the list are slow and its not always obvious that its a long delay and then data transfer at a reasonable rate, rather than a slow rate of data transfer from the start.

You should also try dig. So, if you type
Quote:
dig www.google.com
you'll get the time that it took to resolve that name. Now google is probably a bad example, because you've probably used it recently and so it may be cached. So try something more obscure, that you haven't used recently, twice, and check whether the first lookup is slower than the second, as it will be if there is caching involved.
 
Old 05-13-2009, 12:12 PM   #13
Gwilliams1205
LQ Newbie
 
Registered: May 2008
Posts: 8

Original Poster
Rep: Reputation: 0
pinging google.com it was about a 65ms average. the of cnn.com was about 100ms the first time and 84ms the second time. I also noticed that there is quite a lag time when I put in the ping command and when the first ping goes through, though the time says it was only 64ms. I did the open dns thing and I disabled networkManager to use Network. nothing seems to be helping. Though I know that my internet connection is faster at my office my fedora machine there works so much faster and it is really not even half the machine as my one at home. when I run a YUM command it takes forever to update the repos, and more than half the time it fails on one or more mirrors. I also looked at my resolve.conf and the name server was my router. I also looked at the nsswitch.conf and I couldn't understand what it was saying about the hosts. But I really do appreciate everyone helping me out with this issue.
 
Old 05-13-2009, 08:50 PM   #14
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
See my post #3 at http://www.linuxquestions.org/questi...etwork-724494/
Seemed to work for the OP there (to ensure ipv6 is really removed).
 
Old 05-13-2009, 08:54 PM   #15
Gwilliams1205
LQ Newbie
 
Registered: May 2008
Posts: 8

Original Poster
Rep: Reputation: 0
when I use the command yum update it takes about 5-7 minutes to update all of the repos to even do the update. there is a lag time before a repo even shows up on the terminal. once it comes up it updates as fast as it should but it is taking a long time to start it seems. Is this because of the ipv6 or am I having some other issue?

Thank you again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Why is web browsing under Linux so slow mrdover Red Hat 3 12-19-2005 07:58 PM
Slow localhost web browsing von Linux - Networking 1 01-08-2005 03:02 AM
Web browsing very slow (on 1.5M ADSL...) soofsoof Linux - Newbie 2 12-22-2004 02:33 AM
Slow web browsing problem Corallis Linux - Newbie 8 04-03-2004 01:01 PM
web browsing considerably slow sanjaya Linux - Software 0 02-15-2004 09:21 PM


All times are GMT -5. The time now is 12:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration