LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Why is the GUI of gedit in Kubuntu ugly? (http://www.linuxquestions.org/questions/linux-newbie-8/why-is-the-gui-of-gedit-in-kubuntu-ugly-909917/)

Ornithological Ornod 10-24-2011 06:04 PM

Why is the GUI of gedit in Kubuntu ugly?
 
1 Attachment(s)
I have just installed Kubuntu on my laptop and when I run gedit, the GUI looks ancient and ugly. It should be beautiful. This has happened to me before, but I do not how to undo it. Check the picture.

alienDog 10-24-2011 06:27 PM

You're running GTK/GNOME based application (GEdit) under QT based environment (KDE). It seems that your GTK theme doesn't get set, and that the GTK uses the default theme with some really weird font. You could try installing gtk-chtheme (http://plasmasturm.org/code/gtk-chtheme/) and setting your preferred theme with that, but my suggestion would be to use a QT based editor instead of GEdit. Kate is what I think KDE folks often use (you probably have it installed in your system by default), but there are other choices too.

Ornithological Ornod 10-24-2011 06:39 PM

I know about Kate and lots other duplicate KDE tools.

I think that KDE makes trouble if you open gedit after installation without having first rebooted. That is what my memory tells me (a bit unsure). There must be text file with settings somewhere that can be edited.

alienDog 10-24-2011 06:55 PM

Quote:

Originally Posted by Ornithological Ornod (Post 4507086)
I know about Kate and lots other duplicate KDE tools.

I think that KDE makes trouble if you open gedit after installation without having first rebooted. That is what my memory tells me (a bit unsure). There must be text file with settings somewhere that can be edited.

~/.gtkrc? That's what gtk-chtheme would end up editing, I think. I could be wrong about this, though. It could be something to do with KDE, I'm not really a KDE man.

Ornithological Ornod 10-24-2011 07:15 PM

1 Attachment(s)
Quote:

Originally Posted by alienDog (Post 4507096)
~/.gtkrc? That's what gtk-chtheme would end up editing, I think. I could be wrong about this, though. It could be something to do with KDE, I'm not really a KDE man.

Nope! Check the picture. Those are my folders in the home directory.

Daedra 10-24-2011 08:59 PM

You could install QT-Curve, its a matching gtk/qt. It will make all your applications look the same. After you've installed it You can use "gtk-chtheme" to change your gtk theme, then just go into your kde settings to change your qt theme to qt-curve.

http://kde-look.org/content/show.php?content=40492

MTK358 10-24-2011 09:36 PM

Quote:

Originally Posted by Daedra (Post 4507155)
You could install QT-Curve, its a matching gtk/qt. It will make all your applications look the same. After you've installed it You can use "gtk-chtheme" to change your gtk theme, then just go into your kde settings to change your qt theme to qt-curve.

http://kde-look.org/content/show.php?content=40492

Just note that it will look different than the default KDE theme.

Another choice is to use the gtk-qt theme, that actually uses Qt to draw GTK widgets.

Daedra 10-24-2011 10:20 PM

There is also oxygen-gtk http://kde-look.org/content/show.php/?content=136216

Ornithological Ornod 10-25-2011 04:30 PM

1 Attachment(s)
Quote:

Originally Posted by Daedra (Post 4507155)
You could install QT-Curve, its a matching gtk/qt. It will make all your applications look the same. After you've installed it You can use "gtk-chtheme" to change your gtk theme, then just go into your kde settings to change your qt theme to qt-curve.

http://kde-look.org/content/show.php?content=40492

I did install the QT-curve package (kde-style-qtcurve) and enable it in "Windows decorations". But when I run gedit, it looks weird (attached picture). It does not solve my problem.

Another strange phenomenon is that gedit always opens an empty document whenever I open a text file from Dolphin. That is "Untitled Document 1" in the picture. That never happens otherwise (= it is related to the GUI problem.).

A third strange thing is that other Gnome programs are being affected (e.g., Document Viewer) too.

If I get rid of my current Kubuntu installation, reinstall Kubuntu, install gedit into the new installation and reboot my computer, then these problems are no more. But it is too time-consuming to do that. There is some setting phenomenon that is affecting some Gnome programs in KDE and I want to know what that is.

Ornithological Ornod 10-25-2011 04:32 PM

Quote:

Originally Posted by Daedra (Post 4507200)

I have Oxygen enabled, but it is not working for non-KDE programs.

Daedra 10-25-2011 04:49 PM

did you use the gtk-chtheme program to change your gtk theme?

Ornithological Ornod 10-25-2011 05:44 PM

Quote:

Originally Posted by Daedra (Post 4508176)
did you use the gtk-chtheme program to change your gtk theme?

I installed gtk-chtheme and it does not seem to make any change anywhere. When picking a different window decoration, I get new frames of gedit and other programs, but the interior of all programs and windows seems to be unchanged.

alienDog 10-25-2011 10:38 PM

Quote:

Originally Posted by Ornithological Ornod (Post 4508223)
I installed gtk-chtheme and it does not seem to make any change anywhere. When picking a different window decoration, I get new frames of gedit and other programs, but the interior of all programs and windows seems to be unchanged.

Isn't this what's supposed to happen when you change the window decorations? You need to change the toolkit theme, not the window decorations.

One thing you could try is renaming .gonf, .gnome2 and .gnome2_private directories to some other name. Maybe something's wrong there. You will lose the settings of your GNOME apps is you decide to try this, but you can always set them again (or simply rename the directories back).

Does gedit act up with every user account on your machine or just with the one that you generally use?

Ps. .gtkrc is a regular file, it's not a directory. The user interface settings of GTK (fonts, theme etc.) are usually in this file.

brianL 10-26-2011 03:52 AM

To get the oxygen-gtk theme working properly, you have to copy the gtkrc file to your home directory as .gtkrc-2.0. Don't know if it's the same in Kubuntu, but in Slackware it means doing this:
Code:

cp /usr/share/themes/oxygen-gtk/gtk-2.0/gtkrc ~/.gtkrc-2.0

Ornithological Ornod 10-29-2011 02:19 PM

Quote:

Originally Posted by alienDog (Post 4508403)
Isn't this what's supposed to happen when you change the window decorations? You need to change the toolkit theme, not the window decorations.

Changing widget style in system settings -> application appearance -> style makes wonders in Kate but not in Gedit, i.e. it does not seem to work for non-KDE applications.

Quote:

Originally Posted by alienDog (Post 4508403)
One thing you could try is renaming .gonf, .gnome2 and .gnome2_private directories to some other name. Maybe something's wrong there. You will lose the settings of your GNOME apps is you decide to try this, but you can always set them again (or simply rename the directories back).

I tried deleting .gconf, .gnome2 and .gnome2_private and then reboot my computer. It makes no difference.

Quote:

Originally Posted by alienDog (Post 4508403)
Does gedit act up with every user account on your machine or just with the one that you generally use?

I tried creating a new account and gedit looks weird there too.

Quote:

Originally Posted by alienDog (Post 4508403)
Ps. .gtkrc is a regular file, it's not a directory. The user interface settings of GTK (fonts, theme etc.) are usually in this file.

In my home folder, I can find .gtkrc-2.0-kde4. It contains one line of code:

Code:

include "/usr/share/themes/oxygen-gtk/gtk-2.0/gtkrc"


All times are GMT -5. The time now is 12:06 AM.