LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-25-2003, 01:44 AM   #31
quest4knowledge
Member
 
Registered: Aug 2003
Distribution: gentoo
Posts: 62

Rep: Reputation: 15

If for some reason you think that apps load slow then you could learn about the prelink command. Here's a good tutorial(even though its for gentoo it should be about the same):

http://www.gentoo.org/doc/en/prelink-howto.xml

Ive never tried this cuz linux is fast as hell on every machine that Ive ever run it on.

Good luck.
 
Old 08-25-2003, 03:19 PM   #32
rmaynard
LQ Newbie
 
Registered: Aug 2003
Distribution: MDK 9.1
Posts: 22

Rep: Reputation: 15
I did not set a hostname on install. Maybe this is the problem. What is the best solution for setting a hostname? I searched some other threads and saw how to set a hostname, but I do not understand exactly why this would make the system run faster. This is a standalone machine right now. Is the computer going off "looking" for my hostname. Thanks for an explanation.
 
Old 08-25-2003, 03:21 PM   #33
rmaynard
LQ Newbie
 
Registered: Aug 2003
Distribution: MDK 9.1
Posts: 22

Rep: Reputation: 15
In response to the post by engnyr, I tried icewm and it runs at virtually the same speed as gnome or kde. This does not seem to be the problem.
 
Old 08-25-2003, 08:24 PM   #34
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Quote:
Originally posted by rmaynard
I did not set a hostname on install. Maybe this is the problem. What is the best solution for setting a hostname? I searched some other threads and saw how to set a hostname, but I do not understand exactly why this would make the system run faster. This is a standalone machine right now. Is the computer going off "looking" for my hostname. Thanks for an explanation.
Setting a hostname will definitely improve the performance of Linux. Why? Because Linux is a NOS (Network Operating System). Therefore, hostname is an integral part on ensuring Linux to be working smoothly.

A simple way to do this via command line (as root) is to type the following:

echo whathostnameyouwant > /etc/hostname
 
Old 08-25-2003, 08:36 PM   #35
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Many LINUX distributions default on using ext3. ext3 has limits on how many files it can have in a directory until it penatlizes your system's performance. You can put another hard drive in your system then copy the partition that has your /usr or /usr/lib directory. To do this you have to be in a mode when there are no processes running and nothing is using the partition or use a LINUX based CD distribution like Knoppix and mount the partitions. Then format the partition as either Reiserfs, XFS, or JFS.

Before formatting as either Reiserfs, XFS, or JFS, you have to have them built in to the kernel. You can have them as modules but its a little harder to setup. You will also need to edit your fstab and bootloader before you reboot the computer. While you at it make most of the kernel modulied

Buying better mechanical IDE hard drives may not improve performance. Solid state hard drives will improve performance on loading but like I said in earlier post they are costly. 80486DX-66 processors or better are fast enough to process several gigabytes of data in one second so its not the processor. Look into buying SCSI hard drives with an accessing time of 5 ms or less. This should give you two times faster on loading programs up.
 
Old 08-26-2003, 11:22 AM   #36
rmaynard
LQ Newbie
 
Registered: Aug 2003
Distribution: MDK 9.1
Posts: 22

Rep: Reputation: 15
OK. Setting a hostname did not really seem to make much of a difference. I think enabling DMA (and using some other hdparm tweaks) made a difference. The original performance using -t was 9 MB/sec. After tweaking it was 13 MB/sec. It seemed to run faster, but then I rebooted. I did not realize that the settings were lost on reboot (until I reread the article this morning). I will attempt to do some more testing this evening. Thanks again for the tips.
 
Old 08-27-2003, 11:19 AM   #37
rmaynard
LQ Newbie
 
Registered: Aug 2003
Distribution: MDK 9.1
Posts: 22

Rep: Reputation: 15
I finally got frustrated and installed Red Hat instead of Mandrake thinking it might fix the problem. 1.5 hours later... no fix. It did however fail to recognize my monitor. Could this be the problem? The display looks fine. Is there a setting that bypasses the ATI Rage Mobility card?
 
Old 08-27-2003, 11:32 AM   #38
rahulsundaram
Member
 
Registered: May 2003
Location: India
Distribution: Knoppix, RedHat
Posts: 246

Rep: Reputation: 30
hi

take out that card physically and check out

regards
rahul sundaram
 
Old 08-27-2003, 03:03 PM   #39
quest4knowledge
Member
 
Registered: Aug 2003
Distribution: gentoo
Posts: 62

Rep: Reputation: 15
From your message Im unclear as to which is not being recognized. Monitor or video card?

For your monitor, it really doesnt matter as long as you entered the correct values for it. And you probably did since you say the display looks fine.

For the ATI card, if there isnt a driver loaded for this card then the display will look fine but anything trying to use the 3d part of the card will be VERY slow. Since it is having to use software rendering instead of the hardware card.

Look in dmesg for your ATI card. This should work if its installed in the kernel or as a module. If you dont find it there you probably need to compile a new kernel. The ATI driver is included(i think).

Ive never used ATI's cards but I recommend Nvidia. The cards are good and the drivers are even better.
 
Old 08-28-2003, 01:59 AM   #40
marcheikens
Member
 
Registered: Aug 2003
Location: Cleveland, OH
Distribution: Ubuntu 6.06
Posts: 66

Rep: Reputation: 15
Quote:
Originally posted by Azmeen
hdparm is a nice app to speed up your hard disk access speed.
That helped some issues with slowness I had, but I'm not sure if I put the command in the right place--I put it at the end of /etc/rc.d/rc.sysinit just before the final wait command. Is that an okay place, or do I need to put it somewhere that it'll get run later? If so, where?

Btw, thanks--while I haven't posted much here, I have found quite a few threads that get me looking in the right direction for help--Azneen, that link to O'Reilly was particularly appreciated.

-Marc
 
Old 08-28-2003, 03:40 AM   #41
Bebo
Member
 
Registered: Jul 2003
Location: Göteborg
Distribution: Arch Linux (current)
Posts: 553

Rep: Reputation: 30
Another place to put the hdparm options to get them set up properly at boot, is /etc/sysconfig/harddisks.
 
Old 08-28-2003, 05:08 AM   #42
davholla
Member
 
Registered: Jun 2003
Location: London
Distribution: Linux Mint 13 Maya
Posts: 711

Rep: Reputation: 32
Quote:
Originally posted by rmaynard
I am having the same problem with Mandrake 9.1. Just installed it a couple of days ago, and I am still getting used to the new OS, but it runs SO MUCH slower than windows, that I am almost ready to put win 98 back on the machine. Should OpenOffice take 53 seconds to load up? Pretty much everything is slow on the system. It seems hard to believe that linux is THAT much slower than windows. I will try some of the suggestions and report back on progress.
Go to tools memory in open office and change it from 9 to 70.
I do not have open office on the machine I am using so can not be more specifice.

I could never get mandrake to work fast so I changed to Suse 8.2
 
Old 08-28-2003, 04:01 PM   #43
rmaynard
LQ Newbie
 
Registered: Aug 2003
Distribution: MDK 9.1
Posts: 22

Rep: Reputation: 15
I am still trying to work out the kinks. I am back to thinking it is the configuration of the network here's why:

When I change the hosts file from
127.0.0.1 localhost.localdomain localhost

to
127.0.0.1 bb bb
(obviously not my hostname)

There is no change in performance

I also tried assigning a hostname (jupiter) and putting that in the hosts file as:
127.0.0.1 jupiter localhost.localdomain localhost

Are there any other configuration files for the network (especially associated with gnome, kde or X) that I need to modify?

HELP..I know I am close, but no cigar yet!
 
Old 09-05-2003, 03:36 PM   #44
rmaynard
LQ Newbie
 
Registered: Aug 2003
Distribution: MDK 9.1
Posts: 22

Rep: Reputation: 15
OK. Final resolution at last. I used the #top command to monitor the system memory. It seems that my laptop had a 64 mb chip instead of the 128 mb chip that I thought. So, I went out and put another 128 chip (for a total of 192) in and presto! We are back to running like one would expect (not rocket speed, but quite tolerable now)

Thanks for everyone's help. I certainly learned alot during this debugging process. Always look at the most obvious causes first!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.2 & SATA - Slow, Slow, Slow jess1975 SUSE / openSUSE 6 01-28-2007 01:17 PM
New Fedora Internet connection slow slow slow matrim Fedora 9 07-29-2005 02:39 PM
Linux is really slow... How come? thinhla Linux - General 11 07-03-2005 12:46 PM
Why is my linux so slow the_imax Linux - General 11 05-20-2005 10:59 PM
RH8 vs. W2k - Slow, slow, slow zerojosh Linux - Software 2 06-30-2003 08:19 PM


All times are GMT -5. The time now is 01:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration