LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-21-2004, 05:06 PM   #1
dongmin
Member
 
Registered: May 2004
Posts: 37

Rep: Reputation: 15
why is linux so slow?!


i have debian with kde running on my system.. and it's very sluggish. if i'm downloading, my computer lags quite a lot (i can't even type without "hello" becoming "heellloo").. i can't even watch a movie without it getting all choppy!!

my specs are:

P4 3.0 GHz
1 GB RAM
ATI AIW Radeon 9800

I can't even take a guess on why it would run so slowly.. could it be because i'm using my spare 20 gig-er for linux? even still, it shouldn't be that slow.. it's quite standard actually made by Maxtor.. 7200 RPM.. connected to ATA-100.

any suggestions?
 
Old 06-21-2004, 05:26 PM   #2
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
feature bloat is taking over kde and gnome. you can strip out stuff, or even run an old version of kde or gnome, compiling them yourself. i'm still running kde 1.3, for the the stuff i want drop and drap for. and that's on top of the blackbox window manager. 2.2 ghz athlon xp and 1 gig of ram.
 
Old 06-21-2004, 05:30 PM   #3
dongmin
Member
 
Registered: May 2004
Posts: 37

Original Poster
Rep: Reputation: 15
is it really the bloated kde? i mean even if it's bloated, i can't imagine it slowing down my system so that i can't even type normally.
 
Old 06-21-2004, 05:32 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Re: why is linux so slow?!

Quote:
Originally posted by dongmin

I can't even take a guess on why it would run so slowly.. could it be because i'm using my spare 20 gig-er for linux? even still, it shouldn't be that slow.. it's quite standard actually made by Maxtor.. 7200 RPM.. connected to ATA-100.

any suggestions?
Look at the output of top
check hdparm -tT /dev/hda



Cheers,
Tink
 
Old 06-21-2004, 05:34 PM   #5
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
maybe dma is disabled.
hdparm /dev/hda
hdparm /dev/hdb
hdparm /dev/hdc
hdparm /dev/hdd
will show you stuff.
 
Old 06-21-2004, 05:40 PM   #6
dongmin
Member
 
Registered: May 2004
Posts: 37

Original Poster
Rep: Reputation: 15
/dev/hda:
Timing buffer-cache reads: 2588 MB in 2.00 seconds = 1294.00 MB/sec
Timing buffered disk reads: 12 MB in 3.29 seconds = 3.65 MB/sec

is that normal or what.. ? xP

/dev/hda:
multcount = 16 (on)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 0 (off)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 39813/16/63, sectors = 40132503, start = 0

it seems dma is off? how do i enable this.. i'm using kernel 2.4.26, i'm guessing i have to recompile?
 
Old 06-21-2004, 05:43 PM   #7
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
hdparm -d 1 /dev/hda
 
Old 06-21-2004, 05:48 PM   #8
dongmin
Member
 
Registered: May 2004
Posts: 37

Original Poster
Rep: Reputation: 15
i tried that using root.. and this is what i got

/dev/hda:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)

i have hda partitioned to hda1 (/boot) hda2 (swap) and hda3 (/ ).. so i tried just enabling to one partition:

/dev/hda3:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Invalid argument
using_dma = 0 (off)



Last edited by dongmin; 06-21-2004 at 05:49 PM.
 
Old 06-21-2004, 05:56 PM   #9
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
you can't set dma on one partition. it's for a whole drive.
are you using a kernel you made yourself? anyway, that's what the speed problem is probably.

this is closer to normal
/# hdparm -Tt /dev/hda
/dev/hda:
Timing buffer-cache reads: 128 MB in 1.00 seconds =127.36 MB/sec
Timing buffered disk reads: 64 MB in 1.37 seconds = 46.61 MB/sec
/#

Last edited by whansard; 06-21-2004 at 05:59 PM.
 
Old 06-21-2004, 06:04 PM   #10
dongmin
Member
 
Registered: May 2004
Posts: 37

Original Poster
Rep: Reputation: 15
eh.. i did compile the kernel myself.. how do i go about fixing this?
 
Old 06-21-2004, 06:07 PM   #11
bruno buys
Senior Member
 
Registered: Sep 2003
Location: Rio
Distribution: Debian
Posts: 1,509

Rep: Reputation: 46
hdparm -d 1 /dev/hda will enable dma on hda. Likewise for other drives.
hdparm -X 69 /dev/hda will enable UDMA 100 for hda.

Or use 68 for udma 66.

This can speed thing up. But to benefit from udma, you must have 80pin flat cables connecting ide devices.
 
Old 06-21-2004, 06:10 PM   #12
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
Quote:
i can't even type without "hello" becoming "heellloo"
ohh cummon, thait aint KDE bloat !
my pentium 2 233mzh 128meg ram ATI Rape128 runs KDE 3.2.2 just fine.

open KDE's system guard...
maybe you have a crashed program, or somthing running an infinite loop thats taking up 99.99% of your system resources.
 
Old 06-21-2004, 06:10 PM   #13
dongmin
Member
 
Registered: May 2004
Posts: 37

Original Poster
Rep: Reputation: 15
hdparm -d 1 /dev/hda gives me an error.. and 80 pin flat cables.. isn't that the normal ide hd cable? i'm not talking about the thicker cdrom cables.. it's the same but just thinner

oh and my cpu is idling at 1%.. xP

Last edited by dongmin; 06-21-2004 at 06:16 PM.
 
Old 06-21-2004, 06:14 PM   #14
prophet621
Member
 
Registered: Feb 2003
Posts: 130

Rep: Reputation: 15
I've got the same typing problem. While I'm trying to learn Python I'll go to type 'print' and get prinnnnnnnnnnnnnn and such.

Hangs constantly, sluggish, long load times for apps. I would love to speed it up. I'm not familiar with Linux and it's processes yet so I don't know what's safe to shut down or even how to do it.

I'm running Suse 9.1 with KDE 3.2 on a p4 2.6 laptop with 333 FSB, 512 ddr sdram and 32 meg g-force 420 card.

I know KDE is a bit of a resource hog but damn, this is rediculous. Even my screensaver jumps and it's not even a complex one.


Holy sh*t. I just check KDE system guard and I'm using 507K of my 512k of ram. I only have mozilla and xmms running.

Last edited by prophet621; 06-21-2004 at 06:19 PM.
 
Old 06-21-2004, 06:22 PM   #15
stuart
Member
 
Registered: Jun 2004
Location: aussie in germany
Distribution: mandrake 10 powerpack
Posts: 104

Rep: Reputation: 15
i've recently installed mandrake 10 on my laptop using the default compiled SMP kernel (laptop is a p4 3.2ghz, 512 meg ram, 5400rpm hdd) and my linux runs totally fine

also for the above test i get

/dev/hdc5:
Timing buffer-cache reads: 1532 MB in 2.01 seconds = 763.44 MB/sec
Timing buffered disk reads: 64 MB in 3.01 seconds = 21.24 MB/sec


i know this isnt much of a help to you guys but just thought id mention my experience as a comparisson
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.2 & SATA - Slow, Slow, Slow jess1975 SUSE / openSUSE 6 01-28-2007 01:17 PM
New Fedora Internet connection slow slow slow matrim Fedora 9 07-29-2005 02:39 PM
Linux is really slow... How come? thinhla Linux - General 11 07-03-2005 12:46 PM
Why is my linux so slow the_imax Linux - General 11 05-20-2005 10:59 PM
RH8 vs. W2k - Slow, slow, slow zerojosh Linux - Software 2 06-30-2003 08:19 PM


All times are GMT -5. The time now is 06:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration