LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-17-2008, 01:07 AM   #1
justme_2008
LQ Newbie
 
Registered: Nov 2008
Posts: 2

Rep: Reputation: 0
why insmod can't load my moudle ?


Hi,
I have compiled a module, globalmem.ko, when I use insmode to load this moudle, the hint like this:
insmod: error inserting './globalmem.ko': -1 Device or resource busy
then i use lsmod | grep globalmem
and found globalmem is not loaded
why not load globalmem modules, I hope your answer.
Thank you!
 
Old 11-17-2008, 06:08 PM   #2
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213
Blog Entries: 1

Rep: Reputation: 82
I presume it's a kernel module you are talking about, and in order to install it, you need to either sudo the command or become root first.
 
Old 11-17-2008, 06:13 PM   #3
aus9
LQ Guru
 
Registered: Oct 2003
Posts: 5,124

Rep: Reputation: Disabled
also try

Code:
su
modprobe globalmem
 
Old 11-17-2008, 08:50 PM   #4
justme_2008
LQ Newbie
 
Registered: Nov 2008
Posts: 2

Original Poster
Rep: Reputation: 0
thanks for your reply
the question is resloved.
I look at the file 0f /proc/devices and found the device no. in the prigram is be used. so can't insmod.
Change the device no. , successfully insmod globalmem
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Websites load slow, but once they load, any links inside them load fast smurcoch Mandriva 3 02-06-2006 01:47 AM
need insmod to load e1000 driver on boot pyroman59 Linux - Networking 4 07-25-2005 01:50 PM
insmod pantera Programming 1 05-24-2005 12:40 PM
Help with insmod. I have a problem with insmod. RJARRRPCGP Linux - Newbie 5 08-24-2004 09:23 PM
Advansys moudle 2.6.8-pre2 athens101 Linux - Hardware 3 08-17-2004 02:32 AM


All times are GMT -5. The time now is 02:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration