LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-21-2004, 11:32 AM   #1
Ausar
Member
 
Registered: Jun 2004
Location: Mays Landing, NJ
Distribution: None right now. Will be using Mandrake 10.1 Official.
Posts: 171

Rep: Reputation: 30
No printing!?! I have added sys log info, please help!!


Why isn't my printer printing? I just installed new ink about a month ago and printing has worked fine until my 1 year old son pulled the power cord out from the back of the socket. So I plug it back in and try to print and nothing happens. Then I go to the print job viewer and everything that is going to be printed is in queued. What is wrong? I have time sensitie docments that must be printed. Any help is greatly appreciated.

http://img39.exs.cx/img39/7553/snapshot318.jpg

Last edited by Ausar; 07-23-2004 at 11:12 AM.
 
Old 07-21-2004, 12:10 PM   #2
jamuz
Member
 
Registered: Jun 2004
Location: MD USA
Distribution: SimplyMEPIS 6.0, openSuSE 10.2
Posts: 90

Rep: Reputation: 15
It would help us to know what kind of printer it is and whether it has power now.

My first guess is that the power cord is not connected properly and my second that the cord has been damaged.
 
Old 07-21-2004, 01:35 PM   #3
Ausar
Member
 
Registered: Jun 2004
Location: Mays Landing, NJ
Distribution: None right now. Will be using Mandrake 10.1 Official.
Posts: 171

Original Poster
Rep: Reputation: 30
Sorry bout that, I was in a rush to get him to the doctors to get his shots on time. It is an HP Deskjet5550 and it has power now. All the leds work properly and everything seems to be well but it just will not print. I have not any idea why this is happening. Why? In my reply above, there is a screenshot of the printer job viewer that shows I still have a job pending. Any help is greatly appreciated...
 
Old 07-21-2004, 02:29 PM   #4
jamuz
Member
 
Registered: Jun 2004
Location: MD USA
Distribution: SimplyMEPIS 6.0, openSuSE 10.2
Posts: 90

Rep: Reputation: 15
A stab in the dark: maybe that print job is hung in the queue because the printer died. Can you restart the queue? Failing that, can you clear the queue and rerun the program that created the print job?

Finally it occurs to me: if this were my problem, the first thing I would do is check that the paper is loaded properly so it can feed.
 
Old 07-21-2004, 06:12 PM   #5
Ausar
Member
 
Registered: Jun 2004
Location: Mays Landing, NJ
Distribution: None right now. Will be using Mandrake 10.1 Official.
Posts: 171

Original Poster
Rep: Reputation: 30
All that stuff is fine, i'm trying to print in OOo. The paper is loaded fine, I can't restart the queue so I just clear the reaming jobs so that there is none in queue and restarted the computer but even that didn't work. The printer is only 1.5 years old and has not undergone much use other than a few print jobs here and there.
 
Old 07-21-2004, 07:09 PM   #6
jamuz
Member
 
Registered: Jun 2004
Location: MD USA
Distribution: SimplyMEPIS 6.0, openSuSE 10.2
Posts: 90

Rep: Reputation: 15
At this point all I can suggest is substitution: see if your computer can print to a different printer or a different computer can print to your printer.

I have a gut feeling that this is a software problem, not hardware, but I can't prove it either way & (substitution aside) I'm out of ideas. Sorry.
 
Old 07-23-2004, 11:09 AM   #7
Ausar
Member
 
Registered: Jun 2004
Location: Mays Landing, NJ
Distribution: None right now. Will be using Mandrake 10.1 Official.
Posts: 171

Original Poster
Rep: Reputation: 30
These are my log entries. Can anyone help me with this problem with this info?


1st) 11:43:46 (kernal message) usb 2-1: USB disconnect, address 6 (error one image link)
2nd) (same time kernal message) drivers/usb/class/usblp.c: usblp0: removed (error 2 image link)
3rd) (3 min later kernal message) usb 2-1: new full speed USB device using address 7 (img 3)
4th) same time as last kernal message) drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 7 if 0 alt 0 proto 2 vid 0x03F0 pid 0x6004



These are screen shots of the error windows (they are very readable) can someone make any sense of this stuff? It looks like the 2nd error message says that the printer driver has been removed. Is that so?
http://img39.exs.cx/img39/358/1sterror.jpg
http://img39.exs.cx/img39/7185/2nderror.jpg
http://img39.exs.cx/img39/1743/3rderror.jpg
http://img39.exs.cx/img39/5749/4therror.jpg
 
Old 07-24-2004, 05:17 AM   #8
Ausar
Member
 
Registered: Jun 2004
Location: Mays Landing, NJ
Distribution: None right now. Will be using Mandrake 10.1 Official.
Posts: 171

Original Poster
Rep: Reputation: 30
Anyone? Jamuz?
 
Old 07-24-2004, 05:35 AM   #9
KiwiPingu
LQ Newbie
 
Registered: Jul 2004
Location: Auckland New Zealand
Distribution: Fedora Core 2
Posts: 29

Rep: Reputation: 15
I had a major prob with my printer yesterday similar to yours I just deleted the driver and then re-installed it. Sounds drastic but it worked. My printer went bung cause I fiddled with some setting that I can't remember what it was (that stuffed it up well) but I imagine this aproch would fix quite a few printer stuff ups. I think you will lose the print job you were trying to print though. Just a sugestion hope it helps.

 
Old 07-24-2004, 01:21 PM   #10
Ausar
Member
 
Registered: Jun 2004
Location: Mays Landing, NJ
Distribution: None right now. Will be using Mandrake 10.1 Official.
Posts: 171

Original Poster
Rep: Reputation: 30
How do you delete and reinstall the printer drivers? Where are they located?
 
Old 07-24-2004, 03:51 PM   #11
Ausar
Member
 
Registered: Jun 2004
Location: Mays Landing, NJ
Distribution: None right now. Will be using Mandrake 10.1 Official.
Posts: 171

Original Poster
Rep: Reputation: 30
I reinstalled the driver, but now when I try to print it says the hpdeskjet 5550 status is: not ready

Why is this?
 
Old 07-24-2004, 03:59 PM   #12
Ausar
Member
 
Registered: Jun 2004
Location: Mays Landing, NJ
Distribution: None right now. Will be using Mandrake 10.1 Official.
Posts: 171

Original Poster
Rep: Reputation: 30
I GOT IT TO WORK!!!!!!!!!!!!!! YESYESYESYESYESYESYESYESYESYESYESYESSYESYESYESYESYESYESYESYESYESYESYES!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

I followed these intructions here... http://hpinkjet.sourceforge.net/install.php#mandrake
 
Old 07-24-2004, 06:07 PM   #13
KiwiPingu
LQ Newbie
 
Registered: Jul 2004
Location: Auckland New Zealand
Distribution: Fedora Core 2
Posts: 29

Rep: Reputation: 15
Thats great!

I was asleep sorry couldn't help you.
 
Old 07-24-2004, 06:49 PM   #14
jamuz
Member
 
Registered: Jun 2004
Location: MD USA
Distribution: SimplyMEPIS 6.0, openSuSE 10.2
Posts: 90

Rep: Reputation: 15
Congratulations!
and thanks for the link.
 
Old 07-04-2006, 06:12 PM   #15
nappy501
Member
 
Registered: Mar 2004
Location: UK
Distribution: Redhat 9, then Fedora Core 2, Suse 10.0, 10.2 now 11.3
Posts: 136

Rep: Reputation: 15
Quote:
Originally Posted by Ausar
Why isn't my printer printing? I just installed new ink about a month ago and printing has worked fine until my 1 year old son pulled the power cord out from the back of the socket. So I plug it back in and try to print and nothing happens. Then I go to the print job viewer and everything that is going to be printed is in queued. What is wrong? I have time sensitie docments that must be printed. Any help is greatly appreciated.

http://img39.exs.cx/img39/7553/snapshot318.jpg
Hi
I think I have the same problem I have a dual boot machine, Suse 10.0 and Windows 98 connected to an Epson Stylus C20ux.

I leave the printer on all the time, but when I went away on holiday the power was interrupted. I turned my computer on and the first time I tried to print, I realised the printer was off. I switched it on, but have been unable to print. However, it prints fine in Windows and the jobs are been queued.

Can you be more specific about how you reinstalled the drivers. When I installed Suse 10.0 it just found the printer I didn't have to install any drivers. I have just noticed the link, but it is for HP and I'm using an Epson?

I would be really grateful for help on this.
Thank you.

Last edited by nappy501; 07-04-2006 at 06:14 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Printer just stopped working? M$ISBS Linux - Hardware 1 07-04-2005 03:07 PM
Printer stopped working Tons of Fun Debian 4 06-18-2005 05:40 AM
Printer stopped working BACTRATE Mandriva 6 02-08-2005 11:39 AM
Printer has stopped working davholla Linux - Hardware 2 11-16-2004 12:02 PM
keeping printer on at bootup keeps printer from printing (some printer modules loaded TheOneAndOnlySM Slackware 1 10-17-2003 07:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration