LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-14-2012, 05:59 AM   #1
figure20012
Member
 
Registered: Apr 2012
Posts: 75

Rep: Reputation: Disabled
why dont i see the port listening?


i have started mysql server
i can use the mysql terminal monitor
but yet i cant find out the port 3306 when i type the command netstat -ntpl
i have read the my.cnfand the port used is 3306
why dont i see the port listening?
 
Old 08-14-2012, 06:03 AM   #2
arun5002
Member
 
Registered: Aug 2011
Location: Chennai,India
Distribution: Redhat,Centos,Ubuntu,Dedian
Posts: 549
Blog Entries: 5

Rep: Reputation: Disabled
Post the Output for below command and check whether port is listening on port number 3306 (mysql)


arun@arun-desktop:~$ netstat -apn | grep "mysql"
(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
unix 2 [ ACC ] STREAM LISTENING 6921 - /var/run/mysqld/mysqld.sock

arun@arun-desktop:~$ netstat -apn | grep :3306
(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN -
arun@arun-desktop:~$
 
1 members found this post helpful.
Old 08-14-2012, 06:03 AM   #3
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Are you executing netstat -ntpl as root or as normal user? You should do this as root, running it as normal user will not show all, only those associated with that specific user.
 
1 members found this post helpful.
Old 08-14-2012, 06:10 AM   #4
figure20012
Member
 
Registered: Apr 2012
Posts: 75

Original Poster
Rep: Reputation: Disabled
is it because skip-networking is enabled in my.cnf?

---------- Post added 08-14-12 at 06:11 AM ----------

Quote:
Originally Posted by druuna View Post
Are you executing netstat -ntpl as root or as normal user? You should do this as root, running it as normal user will not show all, only those associated with that specific user.
yes i am executing metstat -ntpl as the user root
but still i cannot find the port
is it because of skip networking?
 
Old 08-14-2012, 06:12 AM   #5
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
I guess so:
Quote:
--skip-networking

Do not listen for TCP/IP connections at all. All interaction with mysqld must be made using named pipes or shared memory (on Windows) or Unix socket files (on Unix). This option is highly recommended for systems where only local clients are permitted. See Section 8.9.8, “DNS Lookup Optimization and the Host Cache”.
Source: http://dev.mysql.com/doc/refman/5.1/...r-options.html
 
1 members found this post helpful.
Old 08-14-2012, 06:18 AM   #6
figure20012
Member
 
Registered: Apr 2012
Posts: 75

Original Poster
Rep: Reputation: Disabled
thanks a lot it was because of skip networking
 
  


Reply

Tags
mysql


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tomcat6 stops listening on port 80 when i change from port 8080 to port 80 trongthect Linux - Server 1 07-27-2012 05:41 PM
Need to change listening port of rusersd service to a static port vokuro Linux - Networking 0 02-01-2012 05:25 PM
can't connect to listening port (reverse tunnel\port forwarding) YS* Linux - Networking 0 05-16-2011 01:48 PM
SFTP server port blocked on Uni network, need to change the listening port. sammyboy161 Linux - Newbie 2 10-21-2010 12:03 PM


All times are GMT -5. The time now is 01:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration