LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-07-2004, 02:16 AM   #1
cato987
LQ Newbie
 
Registered: Jun 2004
Location: it's hot here, where am i...
Distribution: red hat 9.0 pro
Posts: 13

Rep: Reputation: 0
why don't i have x??


im using redhat 9.0 and i finally got the right drivers working but why don't i have a graphical interface like this https://www.redhat.com/docs/manuals/...ARTING-DESKTOP ?? mine is just a bash box.

how do i get the gui?
 
Old 06-07-2004, 03:10 AM   #2
chakkerz
Member
 
Registered: Dec 2002
Location: Brisbane, Australia
Distribution: RedHat (RHEL, FC, CentOS), openSuSE, Mac OS X
Posts: 653

Rep: Reputation: 32
nothing happens when you type

startx

??

if something does happen, (ie the GUI starts) then you want to edit /etc/inittab and make it ... 5 on Redhat (it's oulined in the file)

if you get error messages, odds are your /etc/X11/XF86Config file is not right.

Last edited by chakkerz; 06-07-2004 at 03:13 AM.
 
Old 06-07-2004, 03:25 AM   #3
cato987
LQ Newbie
 
Registered: Jun 2004
Location: it's hot here, where am i...
Distribution: red hat 9.0 pro
Posts: 13

Original Poster
Rep: Reputation: 0
i get an error message
 
Old 06-07-2004, 03:40 AM   #4
cato987
LQ Newbie
 
Registered: Jun 2004
Location: it's hot here, where am i...
Distribution: red hat 9.0 pro
Posts: 13

Original Poster
Rep: Reputation: 0
ok it says-

fatal server error
server is already active for display 0

umm?? is it just an older version of x? because it looks nothing like the previous link. also i tried the /etc/inittab it says permission denied so i logged into root and it said the same thing. says that for a lot of commands.
 
Old 06-07-2004, 08:27 AM   #5
smokylux
Member
 
Registered: May 2004
Location: Luxemburg
Distribution: Fedora Core 2, SuSE 9.1 Pro
Posts: 43

Rep: Reputation: 15
Hmmm, try to hit Ctrl - Alt - F7 on the keyboard.... that's the primary display (0) for X.

perhaps it's already running.... if not, try typing:

startx -- :1

This opens an X on display 1 wich can be accessed via Ctrl - Alt - F8

(F1 - F6 are "text" consoles)


Don't know if this can help, but you can always give it a try


Good luck



smokylux
 
Old 06-07-2004, 08:46 PM   #6
cato987
LQ Newbie
 
Registered: Jun 2004
Location: it's hot here, where am i...
Distribution: red hat 9.0 pro
Posts: 13

Original Poster
Rep: Reputation: 0
it says it's already running. how do i get this interface? https://www.redhat.com/docs/manuals/...ARTING-DESKTOP
 
Old 06-08-2004, 12:03 AM   #7
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
log in as usual
Quote:
localhost login: USERNAME
Password:

[USERNAME@localhost]$
now hit Ctrl+Alt+F7
does it bring you to graphical interface, or another login prompt?
 
Old 06-08-2004, 12:35 AM   #8
cato987
LQ Newbie
 
Registered: Jun 2004
Location: it's hot here, where am i...
Distribution: red hat 9.0 pro
Posts: 13

Original Poster
Rep: Reputation: 0
it dosent do anything
 
Old 06-08-2004, 02:22 AM   #9
Libu
Member
 
Registered: Oct 2003
Location: Chennai
Distribution: Slackware 12.1
Posts: 165

Rep: Reputation: 36
I guess your display is already set. Maybe try Alt+F7 !
Ctrl+Atl+F7 is to move from graphical to text console..
 
Old 06-08-2004, 06:49 AM   #10
cato987
LQ Newbie
 
Registered: Jun 2004
Location: it's hot here, where am i...
Distribution: red hat 9.0 pro
Posts: 13

Original Poster
Rep: Reputation: 0
i got everything goin now i just reinstalled with all the options...thanks everybody
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 05:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration