LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-15-2010, 02:33 AM   #1
since1992trying
LQ Newbie
 
Registered: May 2010
Location: Seoul
Distribution: Debian Lenny, Ubuntu Lucid
Posts: 19

Rep: Reputation: 0
Why Dolphin makes local copy when I play a remote .avi file


I am using Dolphin 1.5 in KDE 4.5.2.

Whenever I try to access movie file from remote Samba server. Dolphin copies the movie file to somewhere in local hard disk. So, I have to wait until a big file transferring complete. I know that it happens when I open .avi using MPlayer. If I open the same remote file with KMPlayer, it will player immediately instead of making local copy first. However, KMPlayer is very slow and sounds and video stream breaking up, (I am sorry I do not know right English expression for this)

I suppose this is not related to MPlayer configuration. This seems to be Dolphin problem. Can I make Dolphin to stop copying Samba share to local disk and play instantly?

There is a video in Youtube. It is comparing how Dolphin and Nautilus act differently when I play remote samba share movies.

I had asked this question in kde forum. I couldn't find any good answer. I hope to find a help here. Thank you.
 
Old 10-15-2010, 04:41 AM   #2
MS3FGX
LQ Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 356Reputation: 356Reputation: 356Reputation: 356
Quote:
If I open the same remote file with KMPlayer, it will player immediately instead of making local copy first. However, KMPlayer is very slow and sounds and video stream breaking up
Well, that is why the file is being copied to the local system first, to prevent this exact thing from happening due to slow transfer speeds.

The easiest way to overcome this issue is to simply mount the remote directory on the system, rather than simply browsing to it with Dolphin. By mounting the Samba share, the remote filesystem will be indistinguishable from the local filesystem, which will prevent any special treatment of the files.
 
Old 10-16-2010, 07:15 AM   #3
since1992trying
LQ Newbie
 
Registered: May 2010
Location: Seoul
Distribution: Debian Lenny, Ubuntu Lucid
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by MS3FGX View Post
Well, that is why the file is being copied to the local system first, to prevent this exact thing from happening due to slow transfer speeds.

The easiest way to overcome this issue is to simply mount the remote directory on the system, rather than simply browsing to it with Dolphin. By mounting the Samba share, the remote filesystem will be indistinguishable from the local filesystem, which will prevent any special treatment of the files.
MS3FGS, thank for your help, Your suggestion solved my problem.

I know two ways to mount remote SMB shares. First, I can use /etc/fstab. This configuration file will be loaded at boot. If remote computer was not turned on while I am booting up. I have to open terminal and run `sudo mount -a`. Second method is that I use mount command in terminal.

These two solutions I have require opening terminal and putting Linux commands. And I have to come back to Dolphin to launch .AVI file. I want that Dolphin works just like Nautilus. Some of you might suggest to install Nautilus. But it looks ugly in KDE environment and the readability is not good because fonts and icons setting different from other KDE applications.

Now I need to know these,
First, whether Dolphin makes local copies when playing movie files or not?
Second, if so, is there an configuration option to force Dolphin not to make local copy for remote movie files?
Finally, if not, I am not right and do I have to configure MPlayer?

Thank you for your helps.
 
Old 10-19-2010, 01:19 AM   #4
since1992trying
LQ Newbie
 
Registered: May 2010
Location: Seoul
Distribution: Debian Lenny, Ubuntu Lucid
Posts: 19

Original Poster
Rep: Reputation: 0
I finally got this work.

After googling things online and kde.org. There was simple solution. I need to put "X-KDE-Protocols=http,ftp,smb" in a desktop entry file. So this is a MPlayer configuration issue in KDE.

In my Arch, there is mplayer.desktop under /usr/share/applications/. However, changing it never works. So I had to find where else mplayer.desktop files in my system.

Code:
$ sudo find / -name mplayer.desktop
/usr/share/applications/mplayer.desktop
/var/abs/community/mplayer-vaapi/mplayer.desktop
/var/abs/extra/mplayer/mplayer.desktop
/home/myusername/.local/share/applications/mplayer.desktop

So, it was under my home directory. /home/myusername/.local/share/applications/mplayer.desktop.
After I put "X-KDE-Protocols=http,ftp,smb" bottom of the file, things work fine.

I still get configured why VLC uses desktop entry file under /usr/share/applications and MPlayer uses one under ~/.local/share/applications. I am not sure this is related to Arch or KDE. If you know, please let us know little information about it. Thank you.

Oh! one more thing. Probably newbies do not know where to configure MPlayer launching options. It can be specified in the desktop entry file. It is also able to configured in System Setting > Common Appearance and Behavior > File Associations > Known Types > video > "pick a movie file extension" > General tab > "choose MPlayer Media Player" > "press edit button" > Application tab. I see "mplayer %U" in command box. This %U thing seems like to be there if I want to access URLs such as smb.

For more information about the option like %U thing. Visit link below.

http://standards.freedesktop.org/des...ec-latest.html

I hope these helps at least a person. Thank you.

PS> unfortunately, MPlayer cannot show subtitle from remote share when it launched Dolphin and KDE environments. One person told me that GNOME mount remote shares and KDE doesn't. It seems right. So, I cannot see subtitles.

Last edited by since1992trying; 10-19-2010 at 01:22 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how can I play file avi file with DivX6.40 1280x720 24fps nos1833 Debian 2 12-28-2007 12:45 AM
scp: copy a file from local machine to remote machine seran Linux - Newbie 8 10-30-2007 01:23 PM
I can't play .avi file Gins Linux - General 9 08-19-2007 02:56 PM
copy from local to remote yogaboy Linux - Networking 9 12-18-2006 02:49 AM
My player cant play rmvb file while avi file is ok......what's going on??!!! shuvernce Linux - General 6 03-28-2006 10:45 PM


All times are GMT -5. The time now is 04:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration