LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-12-2003, 01:49 PM   #1
pyre
Member
 
Registered: Nov 2003
Distribution: Redhat linux 9, Fedra Core 1, Gentoo, Debian (woody), Mandrake 9.2
Posts: 75

Rep: Reputation: 15
Angry why doesn't init level 3 goto text login


hello all. quick question. i have icewm installed...supposedly. i want to try to exit x to try an load it up. i read that if my init level (edited /etc/inittab) is 3--which it is, it would do a text login. I was going to try to set up icewm according to the website documentation, but as with every other part of this OS, the directions made little sense. does this make sense? all-in-all i want to have icewm but am at a COMPLETE loss as to how...
any help is much appreciated...patching up holes in the wall is costly...
thx

-pyrus


btw - Redhat 9

Last edited by pyre; 11-12-2003 at 02:40 PM.
 
Old 11-12-2003, 02:46 PM   #2
szaroubi
Member
 
Registered: Oct 2003
Location: Montreal
Distribution: All/Any
Posts: 59

Rep: Reputation: 15
Basicaly in a linux system, you have mulitple levels of booting.
Single User mode
Text mode
Graphical mode
To name a few ... think of them as "safe mode" or normal mode under windows....
Sometimes the configuration of your windowing system (X windows) might be messed up, you will need to fix it. So you boot into level 3 (text mode) and not level 5 (graphical mode).
So once you have modified your /etc/inittab file to make you boot as level 3 by default .. you have a prompt ... at the prompt .. you will need to put in your username and password....
and that point you have to make icewm your default window manager and them type the following commange.
%>startx

By The Way startx will launch xwindows with your default window manager (gnome, kde, enlightenment, window maker .....)

And another point .. you can dynamicaly switch runtime levels (booting levels) with the following commange
%>telinit 3
or
%>telinit 5
 
Old 11-12-2003, 02:50 PM   #3
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Re: why doesn't init level 3 goto text login

Quote:
Originally posted by pyre
hello all. quick question. i have icewm installed...supposedly. i want to try to exit x to try an load it up. i read that if my init level (edited /etc/inittab) is 3--which it is, it would do a text login. I was going to try to set up icewm according to the website documentation, but as with every other part of this OS, the directions made little sense. does this make sense? all-in-all i want to have icewm but am at a COMPLETE loss as to how...
any help is much appreciated...patching up holes in the wall is costly... ;)
thx

-pyrus


btw - Redhat 9
Modifiying inittab won't take you
to a text mode login right away.

It will present you with one on reboot.

However, if you did a

su -c "init 3"
you should get a text mode only
system right away.

Cheers,
Tink
 
Old 11-13-2003, 05:33 PM   #4
pyre
Member
 
Registered: Nov 2003
Distribution: Redhat linux 9, Fedra Core 1, Gentoo, Debian (woody), Mandrake 9.2
Posts: 75

Original Poster
Rep: Reputation: 15
thanks a lot for the quick feedback! I'm at school so I can't test this yet. I will edit this post with success/failure...hopefully NOT the latter!
thanks again.

Last edited by pyre; 11-14-2003 at 01:03 AM.
 
Old 11-14-2003, 01:04 AM   #5
pyre
Member
 
Registered: Nov 2003
Distribution: Redhat linux 9, Fedra Core 1, Gentoo, Debian (woody), Mandrake 9.2
Posts: 75

Original Poster
Rep: Reputation: 15
unfortunatly, telinit 3 isnt a recognized bash command
also, su -c "init 3" spits out: "bash: line 1: init: command not found"

if i edited the two lines in etc/inittab to runlevel 3 why does this not work? this is amazing....
 
Old 11-14-2003, 08:26 AM   #6
szaroubi
Member
 
Registered: Oct 2003
Location: Montreal
Distribution: All/Any
Posts: 59

Rep: Reputation: 15
Did you try running the command as root?
sudo telinit 3
or
su -c "telinit 3"
?

As for the 2 lines you edited ... what are these 2 line ?
 
Old 11-14-2003, 09:51 AM   #7
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
how to you loggin ???
if you loggin via a console (NOT graphical loggin)
and type startx to load the GUI, then
you are still in run-level 3 as far as Redhat is concerned.

in this situation.

hit logout, and you weill be back to command line....
 
Old 11-14-2003, 11:30 AM   #8
pyre
Member
 
Registered: Nov 2003
Distribution: Redhat linux 9, Fedra Core 1, Gentoo, Debian (woody), Mandrake 9.2
Posts: 75

Original Poster
Rep: Reputation: 15
Yes i did try this as root. i will try the sudo telinit 3 command, hopefully this will accomplish the task. thanks again for the feed back, i will post back.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
changing init level h3htimo Linux - Newbie 5 10-25-2005 12:05 AM
Different Resolution init level 3 ? utw-mephisto Red Hat 4 06-19-2005 07:38 AM
init level 5 for remote X but not local gw1500se Mandriva 0 05-31-2004 03:54 PM
Where can I find the logs for the various init level? davidas Debian 2 04-18-2004 03:26 AM
init level settings rufius Linux - General 1 04-29-2003 07:57 PM


All times are GMT -5. The time now is 03:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration