LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-25-2004, 01:05 PM   #1
EThitop
Member
 
Registered: May 2004
Distribution: Slackware 10
Posts: 146

Rep: Reputation: 15
Why does Gnome takes over my KDE desktop?


I have my desktop set to KDE for my username, and it used to work fine, but now when I log into my username I'll see KDE and then a second or two later Gnome will take over for the wallpaper desktop area. Why is this happening???

If I log into "root" this doesn't happen.

Please help,
Erik
 
Old 05-25-2004, 01:18 PM   #2
Nis
Member
 
Registered: Jul 2003
Location: Virginia
Distribution: Ubuntu Hoary (5.04)
Posts: 550

Rep: Reputation: 31
Did you ever startup Nautilus? If so, then Nautilus has placed itself into your session file (which I don't know where that is on KDE). Look around for that and see if you can delete it. If you ever need to use Nautilus in KDE, start it with this:
Code:
nautilus --no-desktop
 
Old 05-25-2004, 01:22 PM   #3
vinay_s_s
Member
 
Registered: Jul 2003
Posts: 658

Rep: Reputation: 30
may be u had run nautilus in a previous session and then logged out.
if that is the probs, then do a killall nautilus , then logout and logback in.
 
Old 05-25-2004, 09:17 PM   #4
EThitop
Member
 
Registered: May 2004
Distribution: Slackware 10
Posts: 146

Original Poster
Rep: Reputation: 15
Yes I have used Nautilus during a KDE session before, I am going to try your sessions now (I am logged in with 'root' b/c I don't have that problem with it) and I'll let you know the results. I also have 2 other simple questions. One is, how can I log out of KDE without it restoring everything after I log back in (I'm using Slackware, I think I knew how to do this with SuSE....?) and the second questions is, how do I actually tell the computer to shut down? Can I tell it to shut down within KDE, or must I enter a command. Before, I would log out of KDE and then press the power button, but I want the full shutdown sequence.

Thankyou, Erik
 
Old 05-25-2004, 09:56 PM   #5
EThitop
Member
 
Registered: May 2004
Distribution: Slackware 10
Posts: 146

Original Poster
Rep: Reputation: 15
Yep, Killing nautilus worked!!! Thankyou very much! Now I just need help with my other 2 questions I left in the 3rd reply. TIA!

Erik
 
Old 05-25-2004, 11:56 PM   #6
vinay_s_s
Member
 
Registered: Jul 2003
Posts: 658

Rep: Reputation: 30
KDE control center -> KDE components -> Session Manager

Do u have kdm running? If so, then when u click logount in the Kmenu, a screen should appear asking u whether u wanna logout, turn off, or reboot.
Also check SUID permissions of /sbin/halt
 
Old 05-26-2004, 07:16 AM   #7
iainagray
Member
 
Registered: Sep 2003
Location: Aberdeenshire, Scotland
Distribution: Ubuntu Hardy
Posts: 64

Rep: Reputation: 15
There is a command line option also, from either a terminal or do a
"Ctl Alt 1" and log in as root then type:

shutdown -h now

There are other options with the shutdown command, but the 2 common ones are -h "halt" and -r "reboot"
 
Old 05-26-2004, 07:08 PM   #8
EThitop
Member
 
Registered: May 2004
Distribution: Slackware 10
Posts: 146

Original Poster
Rep: Reputation: 15
iainagray thanks for telling me what the -h meant, i was baffled lol... vinay_s_s how do i start KDM? Does it stand for K Display Manager? Anyway, how do i get that running?
 
Old 05-26-2004, 11:15 PM   #9
vinay_s_s
Member
 
Registered: Jul 2003
Posts: 658

Rep: Reputation: 30
yup, KDM is what u told.
U are using slackware right?
this is what i did to start kdm on startup:
open the /etc/rc.d/rc.local file
in the last line, type:
/opt/kde/bin/kdm


Thats it. this will start kdm on each boot. also make sure that u are not running other display managers like GDM, XDM.
 
Old 05-27-2004, 08:30 AM   #10
Nis
Member
 
Registered: Jul 2003
Location: Virginia
Distribution: Ubuntu Hoary (5.04)
Posts: 550

Rep: Reputation: 31
Better way to get KDM up in Slack: change your default run-level to level 4. You need to change a line in /etc/inittab:
Code:
id:3:initdefault:
to
Code:
id:4:initdefault:
 
Old 05-27-2004, 10:14 AM   #11
vinay_s_s
Member
 
Registered: Jul 2003
Posts: 658

Rep: Reputation: 30
hey, but runlevel 4 doesnt have the consoles on anything else but A-C-F6
 
Old 05-27-2004, 10:21 AM   #12
Nis
Member
 
Registered: Jul 2003
Location: Virginia
Distribution: Ubuntu Hoary (5.04)
Posts: 550

Rep: Reputation: 31
It depends. Also in your /etc/inittab you should see
Code:
1:1235:respawn:/sbin/mingetty tty1
2:1235:respawn:/sbin/mingetty tty2
3:1235:respawn:/sbin/mingetty tty3
4:1235:respawn:/sbin/mingetty tty4
5:1235:respawn:/sbin/mingetty tty5
6:12345:respawn:/sbin/mingetty tty6
Just change it to
Code:
1:12345:respawn:/sbin/mingetty tty1
2:12345:respawn:/sbin/mingetty tty2
3:12345:respawn:/sbin/mingetty tty3
4:12345:respawn:/sbin/mingetty tty4
5:12345:respawn:/sbin/mingetty tty5
6:12345:respawn:/sbin/mingetty tty6
and now your gettys are back! You can also follow the formula above and add more gettys up to 11 (or 12 if you have a F13 key).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Gnome Desktop Menu Edits (right click on desktop) jdier Linux - Software 11 08-03-2006 06:05 AM
Linux (with KDE+GNOME) takes a lot of RAM! ajagodnik Linux - General 12 12-28-2003 10:57 AM
Which Desktop, Gnome or KDE? KarlT Linux - Software 8 12-18-2003 06:24 PM
Switiching from a kde desktop to a gnome desktop amb5527 Slackware 4 06-04-2003 09:52 AM
convert gnome desktop to kde desktop puru_09 Linux - Newbie 7 11-26-2002 09:15 AM


All times are GMT -5. The time now is 09:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration