LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 02-10-2007, 03:34 PM   #1
MDesigner
Member
 
Registered: Jun 2004
Distribution: openSUSE 10.2
Posts: 69

Rep: Reputation: 15
Why does GNOME have a session manager and KDE doesn't?


In GNOME, it's fairly simple to add programs to a list that will execute when you log into your X session. In KDE, it seems you have to manually create txt files to go into the ~/.kde/Autostart directory? Why? I'm trying to set up an openSUSE machine for "amateur" users to use.. and if they can't figure out how to get their superkaramba gadgets to stay on the desktop after logging out/in again (I had to put a file in ~/.kde/Autostart).. well, that's no good.
 
Old 02-10-2007, 03:40 PM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,154

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
You can just drag an icon from your desktop into that folder, which is fairly simple to do. (Just right-click on the desktop to create the icon.)

And check your KDE options for saving and restoring sessions. Perhaps you've turned off session saving and restoring. It's usually automatic.
 
Old 02-10-2007, 03:45 PM   #3
MDesigner
Member
 
Registered: Jun 2004
Distribution: openSUSE 10.2
Posts: 69

Original Poster
Rep: Reputation: 15
Ah, right.. the session will auto save. I guess superkaramba is just one exception to the rule. Superkaramba runs upon startup, but its themes/gadgets don't. You have to manually add those into the Autostart dir. I guess if I'm going to set up this box for someone, I'll just make sure I do that before giving the machine to them.
 
Old 02-10-2007, 06:38 PM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
Normally Superkaramba will open previously running themes if the KDE session is set to restore previous sessions. Check your session manager settings by going to Kcontrol -> KDE Components -> Session Manager.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GNOME Session manager crash erro honghebox Linux - Newbie 2 09-03-2005 04:13 PM
Gnome Session Manager crashes for non-root users teegee543 Linux - Software 0 07-01-2005 03:08 PM
GNOME Session Manager Preventing Login jamberu Linux - Software 1 05-28-2005 09:49 PM
Resetting KDE and GNOME session to default free_mumia Linux - Newbie 1 01-01-2004 08:46 PM
Changing Session Manager from KDE to Gnome in SuSE 9 Pro skjellyfetti Linux - General 7 11-12-2003 02:19 PM


All times are GMT -5. The time now is 06:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration