LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-05-2008, 05:02 PM   #1
concoran
Member
 
Registered: Jun 2001
Location: 28N,82W
Distribution: XP,Ubuntu 9
Posts: 472

Rep: Reputation: 30
Why does Fedora mess up my computer time?


This happened second time in a row (Dell E1505). When installing FC9, installer showed a wrong time (for my time zone), so I adjusted. And it seems to have changed bios settings such that when I am in Windows (I dual boot) the system time is messed up. Not sure why.

Just wanted to bring it to your attention.
 
Old 08-05-2008, 06:10 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
Linux and UNIX operating systems have two possible settings for the hardware clock. One setting expects the hardware clock to be set to UTC. The other expects the hardware clock to be set to your local time. I believe that Windows always expects your hardware clock to be set to your local time. Therefore I am going to guess that FC thinks your hardware clock is set to UTC and it makes appropriate adjustments when displaying the actual time. Your mission, should you decide to accept it, is to persuade FC that your hardware clock is set to local time. I don't know how to do this.
 
Old 08-05-2008, 06:20 PM   #3
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
I assume you mean Fedora (it hasn't been Fedora Core since FC6)?

Does your problem sound like UTC as stress_junkie suggests? If so, this is an option you would normally select during intallation on the same screen that asks your timezone (it's called "system clock uses UTC" or someting along those lines.

Do you have a file "/etc/sysconfig/clock" (sorry, but I don't have Fedora running at present)? If so, you should be able to add a lint

UTC=false

or change it from true to false

You can change your timezone there too if it's wrong
 
Old 08-05-2008, 06:20 PM   #4
digerati1338
Member
 
Registered: May 2007
Location: CO
Distribution: Ubuntu
Posts: 152
Blog Entries: 1

Rep: Reputation: 18
The simple workaround is to set your timezone in Fedora to UTC.
 
Old 08-05-2008, 09:02 PM   #5
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
No, on the contrary, UTC should be disabled since Windows uses local time.
 
Old 08-06-2008, 12:56 AM   #6
concoran
Member
 
Registered: Jun 2001
Location: 28N,82W
Distribution: XP,Ubuntu 9
Posts: 472

Original Poster
Rep: Reputation: 30
Either I am retarded, or FC9 is.
I am now in FC9, and there is simply no way to change time (within GUI). In that, I right click on time icon and select 'adjust date and time' which brings up a little dialog box with 'time settings'. So I change the time to reflect correct time, but only options in that dialog are 'cancel' and 'set system time' whatever that means. But in spite of clicking 'set system time' nothing changes. That sucks.
I've had my share of time problems with FC8 before, but I think this is just the continuation.

PS: And I have no clue why the time applet wants to tell me about my local weather and temperature. I really don't care, except the time.

Last edited by concoran; 08-06-2008 at 01:02 AM.
 
Old 08-06-2008, 01:49 AM   #7
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 172Reputation: 172
Assuming gnome and that it has not moved since F8. System->Administration->Date & Time, Time zone tab, uncheck system uses UTC. Then set the time accordingly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 7 mess rhollmann Linux - Newbie 4 07-05-2007 11:37 AM
Fedora Core 5 Computer Providing A Windows Xp Computer With Internet FedoraNewbie Linux - Networking 6 10-28-2006 11:24 PM
My computer restart automatically from time to time ?? pleasehelpme Linux - Newbie 2 07-04-2005 04:29 PM
Having to re-name xp computer every time linux computer is reset sboothman Linux - Networking 4 12-24-2004 02:37 PM
PROB: Mandrake or WinXP or Fedora mess up kevingpo Linux - Newbie 4 12-13-2004 11:41 AM


All times are GMT -5. The time now is 07:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration