LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-30-2011, 05:24 PM   #1
DMKHAMMER
LQ Newbie
 
Registered: Jan 2011
Posts: 17

Rep: Reputation: 0
Exclamation Why cant it see the file?


PHP Code:
root@debianportable:/home/dave/Desktop/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100601/RT3070_LinuxSTA_V2.3.0.1_20100208/os/linux# $/sbin/insmod rt3070sta.ko
bash: $/sbin/insmodNo such file or directory
root
@debianportable:/home/dave/Desktop/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100601/RT3070_LinuxSTA_V2.3.0.1_20100208/os/linux
I am looking right at rt3070sta.ko and it is there ... what is my error?
 
Old 01-30-2011, 05:32 PM   #2
startover
Member
 
Registered: May 2010
Posts: 37

Rep: Reputation: 2
why there is a "$" in the beginning?
 
1 members found this post helpful.
Old 01-30-2011, 05:32 PM   #3
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,252

Rep: Reputation: 313Reputation: 313Reputation: 313Reputation: 313
The error is related to "$/sbin/insmod". You wrote this as command, but there is no that command name. You must write:
Code:
/sbin/insmod rt3070sta.ko
 
1 members found this post helpful.
Old 01-30-2011, 05:37 PM   #4
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,252

Rep: Reputation: 313Reputation: 313Reputation: 313Reputation: 313
I think this "$" is from copy-paste procedure from some web page. DMKHAMMER be more careful what you are writing,
you can damage your system if you will be executing commands without knowledge what they actually do.
 
1 members found this post helpful.
Old 01-30-2011, 10:43 PM   #5
DMKHAMMER
LQ Newbie
 
Registered: Jan 2011
Posts: 17

Original Poster
Rep: Reputation: 0
Bad Instructions

I think before the bad commands will destroy the laptop, I will. I cannot keep working hard-wired where I am. The insmod command isnt the only problem with
the instructions...
PHP Code:
dave@debianportable:~/Desktop/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100601/wpa_supplicant/wpa_supplicant-0.6.9$ ./wpa_supplicant -Dwext -ira0 -c wpa_supplicant.conf -d
bash
: ./wpa_supplicantis a directory 
PHP Code:
3In os/linux/config.mk 
    define the GCC 
and LD of the target machine
    define the compiler flags CFLAGS
    modify to meet your need
.
    ** 
Build for being controlled by NetworkManager or wpa_supplicant wext functions
       Please set 
'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y'.
       => 
#>cd wpa_supplicant-x.x
       
=> #>./wpa_supplicant -Dwext -ira0 -c wpa_supplicant.conf -d
    
** Build for being controlled by WpaSupplicant with Ralink Driver
       Please set 
'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n'.
       => 
#>cd wpa_supplicant-0.5.7
       
=> #>./wpa_supplicant -Dralink -ira0 -c wpa_supplicant.conf -d 
 
Old 01-31-2011, 03:11 PM   #6
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,252

Rep: Reputation: 313Reputation: 313Reputation: 313Reputation: 313
Message is descriptive: "./wpa_supplicant is a directory" you can't execute it.
And you shuldn't, read documentation carefuly. This is instruction what to write
in "os/linux/config.mk" file, or rather
"./wpa_supplicant -Dwext -ira0 -c wpa_supplicant.conf -d" should be written after compilation.

Last edited by eSelix; 01-31-2011 at 03:22 PM.
 
1 members found this post helpful.
Old 01-31-2011, 04:09 PM   #7
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
I see from your prompt that you use Debian. May I ask why you compile wpasupplicant from source, instead of using the one from the repositories?
 
1 members found this post helpful.
Old 02-01-2011, 12:52 AM   #8
DMKHAMMER
LQ Newbie
 
Registered: Jan 2011
Posts: 17

Original Poster
Rep: Reputation: 0
Thank you

I can see from what is meant by the people writing the instructions I followed, they arent considering the audience. The one newly setting a wireless
is going to be a newbie setting up a laptop so he isn't chained to a cable. your help is greatly appreciated and I intend to put it to practice as soon
as I have have a good nights sleep and get off work.
 
Old 02-05-2011, 10:01 PM   #9
DMKHAMMER
LQ Newbie
 
Registered: Jan 2011
Posts: 17

Original Poster
Rep: Reputation: 0
unknown symbol

PHP Code:
root@debianportable:/home/dave/Desktop/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100601/RT3070_LinuxSTA_V2.3.0.1_20100208/os/linux# /sbin/insmod rt3070sta.ko
insmoderror inserting 'rt3070sta.ko': -1 Unknown symbol in module
root
@debianportable:/home/dave/Desktop/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100601/RT3070_LinuxSTA_V2.3.0.1_20100208/os/linux
figurung out the unknown symbol amongst the pile of files boggles me... thoughts? Thanks
 
Old 02-05-2011, 10:33 PM   #10
linuxiso
LQ Newbie
 
Registered: Jan 2009
Posts: 10

Rep: Reputation: 1
Quote:
Originally Posted by DMKHAMMER View Post
PHP Code:
root@debianportable:/home/dave/Desktop/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100601/RT3070_LinuxSTA_V2.3.0.1_20100208/os/linux# $/sbin/insmod rt3070sta.ko
bash: $/sbin/insmodNo such file or directory
root
@debianportable:/home/dave/Desktop/rtl8712_8188_8191_8192SU_usb_linux_v2.6.0006.20100601/RT3070_LinuxSTA_V2.3.0.1_20100208/os/linux
I am looking right at rt3070sta.ko and it is there ... what is my error?
You are obviously trying to compile the source drivers for your wireless drivers. I tried this before some time ago with a wireless USB card to work with my desktop computer, and after some long time searching, I was actually able to get it to work.

I think you are missing some kind of build tools (can't remember) - but I might be able to find the directions saved somewhere on my hard drive. Will take some time to look for it though. Additionally, you may want to search for something like "compiling wireless drivers" or use the file name to find how to correctly do it. I am sure Ubuntu Forums somewhere on their site has more information on how to correctly do this.

Also, you probably want to double check the file location, and you may want to use the "cd" command to go into the directory that has the file you want to compile, and then execute the file from there, or use "~/" (followed by the file name), to avoid typing in the long directory name. The "~/" refers to the current present working directory, and would save you time if you do "cd" into the directory, and then run the file to compile.

Also, you probably want to move the main RT3070 directory out of the first very long directory, to make sure it works. Moving the 2nd directory out of the first, would "not" mess anyway on how the compiling works, it would just shorten the directory length, and might even fix the compile execute problems.
 
1 members found this post helpful.
Old 02-05-2011, 11:05 PM   #11
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
Again I have to ask why you compile from source instead of using the precompiled (and tested) packages from the repositories. Assuming that you have an adapter with Ralink chipset have a look here. If you have problems with Debian, the first place to look is the Debian Wiki, chances are high that you find what you need.
 
1 members found this post helpful.
Old 02-06-2011, 03:47 PM   #12
DMKHAMMER
LQ Newbie
 
Registered: Jan 2011
Posts: 17

Original Poster
Rep: Reputation: 0
Restart

Maybe I got buried in paper.
With Network manager, wireless is disabled.

wlan0 would be Atheros which reports but hasnt worked for months....
probably the switch is burnt.

Wicd says no wireless networks found
I think I got off track wrestling this thing... I have watches on ebay auctions on Linux wireless laptops. Need to get off the wire and to where
I can start working and learning with it.

Code:
root@debianportable:/home/dave# modprobe rt2870sta
root@debianportable:/home/dave# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
pan0      no wireless extensions.

wlan1     Ralink STA  ESSID:""  
          Mode:Auto  Frequency=2.412 GHz  
          Link Quality=10/100  Signal level:0 dBm  Noise level:-143 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

root@debianportable:/home/dave# ifconfig wlan1 up
root@debianportable:/home/dave# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
pan0      no wireless extensions.

wlan1     Ralink STA  ESSID:"Belkin_G_Wireless_05DF65"  Nickname:"RT2870STA"
          Mode:Managed  Frequency=2.437 GHz  Access Point: 94:44:52:05:DF:65   
          Bit Rate=54 Mb/s   
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality=100/100  Signal level:-45 dBm  Noise level:-83 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

root@debianportable:/home/dave# lspci | grep ralink
root@debianportable:/home/dave# lsmod | grep ralink
root@debianportable:/home/dave# iwlist wlan1 scan
wlan1     Scan completed :
          Cell 01 - Address: 94:44:52:05:DF:65
                    Protocol:802.11b/g
                    ESSID:"Belkin_G_Wireless_05DF65"
                    Mode:Managed
                    Channel:6
                    Quality:100/100  Signal level:-39 dBm  Noise level:-83 dBm
                    Encryption key:off
                    Bit Rates:54 Mb/s

root@debianportable:/home/dave# lsusb
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 005: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 002 Device 004: ID 152e:2571 LG (HLDS) 
Bus 002 Device 003: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@debianportable:/home/dave# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1a:80:b4:4c:75  
          inet6 addr: fe80::21a:80ff:feb4:4c75/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:124 errors:0 dropped:0 overruns:0 frame:0
          TX packets:56 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:19321 (18.8 KiB)  TX bytes:9310 (9.0 KiB)
          Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:728 errors:0 dropped:0 overruns:0 frame:0
          TX packets:728 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:71197 (69.5 KiB)  TX bytes:71197 (69.5 KiB)

wlan1     Link encap:Ethernet  HWaddr 00:a1:b0:ff:c3:c3  
          inet addr:192.168.2.13  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::2a1:b0ff:feff:c3c3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9335 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3906 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2217936 (2.1 MiB)  TX bytes:547817 (534.9 KiB)

root@debianportable:/home/dave# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:1a:80:b4:4c:75  
          inet6 addr: fe80::21a:80ff:feb4:4c75/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:127 errors:0 dropped:0 overruns:0 frame:0
          TX packets:56 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:19664 (19.2 KiB)  TX bytes:9310 (9.0 KiB)
          Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:728 errors:0 dropped:0 overruns:0 frame:0
          TX packets:728 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:71197 (69.5 KiB)  TX bytes:71197 (69.5 KiB)

pan0      Link encap:Ethernet  HWaddr e2:c1:7b:2c:b0:33  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:1d:d9:7a:43:fa  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan1     Link encap:Ethernet  HWaddr 00:a1:b0:ff:c3:c3  
          inet addr:192.168.2.13  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::2a1:b0ff:feff:c3c3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9600 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3910 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2266131 (2.1 MiB)  TX bytes:548218 (535.3 KiB)

root@debianportable:/home/dave#

Last edited by DMKHAMMER; 02-06-2011 at 03:54 PM.
 
Old 02-06-2011, 04:04 PM   #13
DMKHAMMER
LQ Newbie
 
Registered: Jan 2011
Posts: 17

Original Poster
Rep: Reputation: 0
Oh my, I pulled the wire and the internet kept going....whew!
Am I going to have to type the command to raise the radio everytime or is there a way to
automatically load the wireless?

---------- Post added 02-06-11 at 03:04 PM ----------

Oh my, I pulled the wire and the internet kept going....whew!
Am I going to have to type the command to raise the radio everytime or is there a way to
automatically load the wireless?
 
Old 02-06-2011, 04:14 PM   #14
DMKHAMMER
LQ Newbie
 
Registered: Jan 2011
Posts: 17

Original Poster
Rep: Reputation: 0
Lightbulb need help to get wireless to load without terminal

Answer myself: Unless I do something, I have to raise the radio manually unless I can find the way to configure it to
allow wireless auto-magically.

PHP Code:
root@debianportable:/home/dave# ifconfig wlan1 up
wlan1ERROR while getting interface flagsNo such device
root
@debianportable:/home/dave# modprobe rt2870sta
root@debianportable:/home/dave# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode
:Managed  Access PointNot-Associated   Tx-Power=0 dBm   
          Retry  long limit
:7   RTS thr:off   Fragment thr:off
          Encryption key
:off
          Power Management
:off
          
pan0      no wireless extensions
.

wlan1     Ralink STA  ESSID:""  
          
Mode:Auto  Frequency=2.412 GHz  
          Link Quality
=10/100  Signal level:0 dBm  Noise level:-143 dBm
          Rx invalid nwid
:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries
:0  Invalid misc:0   Missed beacon:0

root
@debianportable:/home/dave# ifconfig wlan1 up
root@debianportable:/home/dave
 
Old 02-06-2011, 10:52 PM   #15
DMKHAMMER
LQ Newbie
 
Registered: Jan 2011
Posts: 17

Original Poster
Rep: Reputation: 0
Question is there a way to do it?

Is there a way to make it so I dont have to terminal
Code:
modprobe rt2870sta
ifconfig wlan1 up
all the time?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vim file.tex !latex file.tex & pdfdvi file.dvi & xpdf -remote sname -reload Mol_Bolom Linux - General 0 07-09-2009 08:46 PM
Display by File Name, File Size, and File Owner using ls akeenabawa Linux - Newbie 9 08-15-2008 03:21 PM
How can read from file.txt C++ where can save this file(file.txt) to start reading sam_22 Programming 1 01-11-2007 06:11 PM
gave wrong syntax for tar as tar -cvzf file file.tgz how to recover the file gautham Linux - General 4 04-13-2005 04:15 AM
How to play a media file/ video file/mp3 file recorded in harddisk/cd-rom arindam Linux - Newbie 2 09-05-2003 11:31 AM


All times are GMT -5. The time now is 10:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration