LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-15-2010, 07:49 AM   #1
frustratednewbie
LQ Newbie
 
Registered: Mar 2010
Distribution: Fedora 10
Posts: 16

Rep: Reputation: 0
Why cant I connect to the internet?


Hello, I have just finished installing Fedora 10 on my machine and I have it connected to the internet via ethernet cable. The problem is it wont connect at all for some reason.

I click on the green Activate button in network configuration to see if it does anything but I keep getting this AVC denial error. I don't even understand what the problem is:
http://img59.imageshack.us/img59/3789/72645136.png

So I play around in the settings and put this SELINUX thing to permissive but the thing still pops up, so it didn't help:
http://img696.imageshack.us/img696/4697/82520734.png

The only other thing I messed around with is the DNS server; I put two DNS servers in those boxes, and I got those from the people in charge so it shouldn't be wrong.

Any help would be appreciated.
 
Old 03-15-2010, 07:56 AM   #2
bret381
Member
 
Registered: Nov 2009
Location: Alabama
Distribution: Arch x86_64
Posts: 650

Rep: Reputation: 78
post the output of ifconfig
 
Old 03-15-2010, 08:01 AM   #3
frustratednewbie
LQ Newbie
 
Registered: Mar 2010
Distribution: Fedora 10
Posts: 16

Original Poster
Rep: Reputation: 0
Hi, I got this from entering ifconfig in the terminal:

Code:
[linuxuser@localhost ~]$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:15:58:69:7A:92  
          inet6 addr: fe80::215:58ff:fe69:7a92/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:162 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8184 (7.9 KiB)  TX bytes:6282 (6.1 KiB)
          Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:800 (800.0 b)  TX bytes:800 (800.0 b)

[linuxuser@localhost ~]$
 
Old 03-15-2010, 08:06 AM   #4
kirukan
Senior Member
 
Registered: Jun 2008
Location: Eelam
Distribution: Redhat, Solaris, Suse
Posts: 1,272

Rep: Reputation: 148Reputation: 148
I don't have idea to set the selinux policy to allow dhclinet-eth0.lease but instead of DHCP did you try with static ip configuration?
 
Old 03-15-2010, 08:11 AM   #5
jamescondron
Member
 
Registered: Jul 2007
Location: Scunthorpe, UK
Distribution: Ubuntu 8.10; Gentoo; Debian Lenny
Posts: 961

Rep: Reputation: 69
Hmm.. you've set IPv6 on purpose? Or did it do that for you? That address looks like a default, compare the address with your mac address.
 
Old 03-15-2010, 08:13 AM   #6
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Rep: Reputation: 55
Welcome to LQ.

You may disable SELinux for time being
Code:
echo 0 > /selinux/enforce
Please paste the output of following commands.
Code:
cat /etc/resolv.conf
/sbin/service network restart
ifup eth0
cat /etc/sysconfig/network-scripts/ifcfg-eth0
Also make sure LAN cable is properly plugged.

Last edited by vinaytp; 03-15-2010 at 08:22 AM.
 
Old 03-15-2010, 08:19 AM   #7
frustratednewbie
LQ Newbie
 
Registered: Mar 2010
Distribution: Fedora 10
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by kirukan View Post
I don't have idea to set the selinux policy to allow dhclinet-eth0.lease but instead of DHCP did you try with static ip configuration?
Yes, I have tried setting the IP address manually but it still doesn't work.

Quote:
Originally Posted by jamescondron View Post
Hmm.. you've set IPv6 on purpose? Or did it do that for you? That address looks like a default, compare the address with your mac address.
Well, I'm not sure what IPv6 is, so I don't know what to tell you. What is a default address? Sorry if the question is dumb, I'm just starting out with Linux.
 
Old 03-15-2010, 08:25 AM   #8
frustratednewbie
LQ Newbie
 
Registered: Mar 2010
Distribution: Fedora 10
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by vinaytp View Post
Please paste the output of following commands.
Code:
cat /etc/resolv.conf
/sbin/service network restart
ifup eth0
cat /etc/sysconfig/network-scripts/ifcfg-eth0
Also make sure LAN cable is properly plugged.
Hi, I did as you asked and this is the output..I can't figure out what any of it means though. Any clues?

Quote:
[linuxuser@localhost ~]$ echo 0 > /selinux/enforce
bash: /selinux/enforce: Permission denied
[linuxuser@localhost ~]$ cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 10.221.0.101
nameserver 10.221.0.102
nameserver 10.221.0.103
# NOTE: the libc resolver may not support more than 3 nameservers.
# The nameservers listed below may not be recognized.
nameserver 10.221.0.10
[linuxuser@localhost ~]$ /sbin/services network restart
bash: /sbin/services: No such file or directory
[linuxuser@localhost ~]$ /sbin/service network restart
Shutting down interface eth0: [ OK ]
Shutting down loopback interface: Users cannot control this device.
[FAILED]
Cannot find device "sit0"
Bringing up loopback interface: Users cannot control this device.
[FAILED]
Bringing up interface eth0:
Determining IP information for eth0...Nothing to flush.
done.
[ OK ]
RTNETLINK answers: Operation not permitted
RTNETLINK answers: Operation not permitted
RTNETLINK answers: Operation not permitted
RTNETLINK answers: Operation not permitted
RTNETLINK answers: Operation not permitted
RTNETLINK answers: Operation not permitted
RTNETLINK answers: Operation not permitted
RTNETLINK answers: Operation not permitted
RTNETLINK answers: Operation not permitted
touch: cannot touch `/var/lock/subsys/network': Permission denied
[linuxuser@localhost ~]$ ifup eth0

Determining IP information for eth0...dhclient(11960) is already running - exiting.

This version of ISC DHCP is based on the release available
on ftp.isc.org. Features have been added and other changes
have been made to the base software release in order to make
it work better with this distribution.

Please report for this software via the Red Hat Bugzilla site:
http://bugzilla.redhat.com

exiting.
failed.
[linuxuser@localhost ~]$
 
Old 03-15-2010, 08:26 AM   #9
jamescondron
Member
 
Registered: Jul 2007
Location: Scunthorpe, UK
Distribution: Ubuntu 8.10; Gentoo; Debian Lenny
Posts: 961

Rep: Reputation: 69
IP Addresses; there is IPv4, and IPv6 (Don't ask about the others, the first rule etc., etc.)- IPv4 is as per 123.123.123.123- IPv6 is like yours: fe80::215:58ff:fe69:7a92. A bit of history; IPv4 addresses will run out, there are too few addresses, and a good chuck are reserved for internals and blah (see: http://www.google.co.uk/search?clien...utf-8&oe=utf-8). IPv6 has a wider range and so will one day probably face a mass rollout.

That being said, IPv4 is the standard and most used for now, yet your interface has been given an IPv6 address. Either the person running your DHCP server/ Router/ Switch has done this purposely (More power to 'em), or your machine hasn't received an address. The reason I feel the second is more likely is because your MAC address (The physical address of the interface) is 00:15:58:69:7A:92, and the IP address is fe80::215:58ff:fe69:7a92.

So...Are you using DHCP to assign you an address? Because something tells me it aint working
 
Old 03-15-2010, 08:27 AM   #10
jamescondron
Member
 
Registered: Jul 2007
Location: Scunthorpe, UK
Distribution: Ubuntu 8.10; Gentoo; Debian Lenny
Posts: 961

Rep: Reputation: 69
Oh, run those commands as root. Use 'sudo' in front of them
 
Old 03-15-2010, 08:34 AM   #11
kirukan
Senior Member
 
Registered: Jun 2008
Location: Eelam
Distribution: Redhat, Solaris, Suse
Posts: 1,272

Rep: Reputation: 148Reputation: 148
purely this problem cause due to selinux if you don't need selinux just disable it or else find a solution for selinux policy with someone who have idea about selinux, i believe that if you setup static ip instead of dhcp you can overcome this problem
 
Old 03-15-2010, 09:05 AM   #12
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Rep: Reputation: 55
Quote:
Originally Posted by frustratednewbie View Post
Hi, I did as you asked and this is the output..I can't figure out what any of it means though. Any clues?
Please execute the commands with root privileges. Normal users don't have privileges to run these commands.

If eth0 is up. try
Code:
ifdown eth0
and paste output of above commands

Last edited by vinaytp; 03-15-2010 at 09:08 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kubuntu - Can't connect to the internet, but can connect to the LAN KellyT Linux - Networking 1 11-12-2009 05:17 AM
Able to connect to default Gateway, Unable to connect to internet Dumb.Coder Linux - Newbie 11 04-14-2009 05:22 AM
connect to internet trough wireless others connect to me with lan Amir Menesy Linux - Wireless Networking 1 11-13-2007 09:28 PM
how i connect (bridging) two internet connection and how to use that both the connect karthi26 Linux - Newbie 1 08-26-2007 04:10 AM
can't connect to the internet:linux dont read my internet address droplsh Linux - General 1 02-29-2004 08:32 PM


All times are GMT -5. The time now is 04:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration