LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-21-2004, 04:00 PM   #1
xspy6bass
LQ Newbie
 
Registered: Mar 2004
Location: Columbus, Ohio
Distribution: Debian
Posts: 9

Rep: Reputation: 0
Question Why can't I connect I recieve mail in Ximian Evolution?


Hey everybody,

Today's my first day ever using Linux, and I'm a bit confused about setting up my e-mail account in Ximian Evolution. I have a free version of Red Hat 8.0 that I installed from a Dummies book.
I set up my e-mail account just the way I would if I was using Outlook Express. My e-mail for the website that I run is POP3, so I choose the POP option in Recieving Mail, I set my host as mail.bioelectricnutrition.com, which is my mail server. My user name is set as webmaster, which seems right, my email address is webmaster@bioelectricnutrition.com. I do not have SSL enabled, and I have my authentication set for password, and I left the 'remember this password' box unchecked. I have my outgoing mail set as SMTP, and my host as mail.bioelectricnutrition.com, no SSL, and my server does not require authentication. When I try to retrieve my mail, it appears the that SMTp server connects just fine, then it ask for my password, I type it and then I get a error box stating: Unable to connect to POP server, Error sending password:Authorization failed, and then it asks me retype my password, except that it says please enter the password for 'webmaster@mail.bioelectricnutrition.com', which seems wrong, since my actual e-mail address is webmaster@bioelectricnutrition.com. It would be much appreciated if someone could help my out with this. I am really liking the linux setup, but right now I'm just mystified. Thanks in advance for any help.

Phill
 
Old 03-22-2004, 12:55 AM   #2
liamoboyle
Member
 
Registered: Mar 2004
Location: Wellington, New Zealand
Distribution: Debian
Posts: 127

Rep: Reputation: 15
The message you're getting is the one that Evolution gives when it receives a message from the server saying that the username/password combination is wrong. You need to make sure that the username and password are definitely correct.

As for the message saying mail.bioelectricnutrition.com, the host bioelectricnutrition.com has redirected the request to it's mail server, so this is perfectly ok.
 
Old 03-22-2004, 08:53 AM   #3
xspy6bass
LQ Newbie
 
Registered: Mar 2004
Location: Columbus, Ohio
Distribution: Debian
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks liamoboyle,

I checked my username and password, and they are definitly correct. Could the problem be with my firewall settings? I checked them, and they are set on high security with default firewall rules, could this be preventing my computer from connecting?
 
Old 03-22-2004, 03:24 PM   #4
liamoboyle
Member
 
Registered: Mar 2004
Location: Wellington, New Zealand
Distribution: Debian
Posts: 127

Rep: Reputation: 15
It could be. Imap needs to have tcp port 143 open, smtp needs to have 25 open. What are you running as your firewall? I can help you with reconfiguring a linux firewall, but I've no idea about windows ones...
 
Old 03-22-2004, 07:36 PM   #5
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
xspy6bass -- 2 comments:

1. Just my 2 cents but you may want to reconsider posting your real live Email address in a public forum. I'd recommend that you use a fictitious one -- you can still accurately describe the problem using fake values. Don't get me wrong, the LQ community is very well behaved but it's generally a good practice to disguise real Email addresses.

2. I'm not at my Linux box right now, so I'll need to work from memory, but I'll suspect that you have either an incorrect username value entered, or an incorrect POP server name. The first thing I'd do is to verify both the POP and SMTP server names with your ISP. For instance, with my ISP, I need to use "postoffice.<provider>.com" for POP but "mail.<provider>.com" for SMTP. Your ISP may do something similar. Additionally, I'm not sure whether the username value you're supplying is "webmaster" or "webmaster@<your site name>.com" Whichever way you've got it set up now, try it the other way to see if that does it.

I will definitely check back on this thread after work tonight, and attempt to lend a hand. There's no doubt you are very close to success. -- J.W.
 
Old 03-22-2004, 10:22 PM   #6
xspy6bass
LQ Newbie
 
Registered: Mar 2004
Location: Columbus, Ohio
Distribution: Debian
Posts: 9

Original Poster
Rep: Reputation: 0
liamoboyle and J.W.,

Thanks for the thoughts and heads up. I am using the default firewall that came with this distro, the one you access by going to System Settings - Security. Thing is, it seems to be stuck at high, I changed it from both my user account and root, and it just goes back to high, any thoughts?
The more I think about it, I think the firewall settings are the problem. I checked my server names and I got them right, and my user name is right, and when I try using the full thing as my username it ends up saying that I can't connect to username@site@mail.site.com, so I don't think that could be right. So far, here in my third day of Linux I am really liking it, but the change from XP has been a bit difficult. I'm still getting the hang of the total paradigm shift. But anyhow, I've got plently of questions, thank for replys so far.
 
Old 03-22-2004, 10:24 PM   #7
xspy6bass
LQ Newbie
 
Registered: Mar 2004
Location: Columbus, Ohio
Distribution: Debian
Posts: 9

Original Poster
Rep: Reputation: 0
One more thing, about the firewall not changing. After I change the setting, when I log out should I hit the save settings tab in the box? Would that keep it set? And in the long run, does it matter if I do it from my user account or root?
 
Old 03-23-2004, 12:02 AM   #8
liamoboyle
Member
 
Registered: Mar 2004
Location: Wellington, New Zealand
Distribution: Debian
Posts: 127

Rep: Reputation: 15
I'm not sure about the firewall setup for redhat, but...

If you open up a terminal and type in

telnet mail.site.com 143

where mail.site.com is the site your email is at (try mail.site.com and just site.com).

If it can connect past the firewall then you will see something like this

Trying xxx.xxx.xxx.xxx...
Connected to mail.site.com.
Escape character is '^]'.
* OK mail.site.com Cyrus IMAP4 v1.5.19 server ready

And if it can't get past the firewall you'll see the Trying message, and it'll eventually time out.

If you can't change the firewall settings, and you won't be able to unless you run the program as root, then you can do the following to kill them, although it will leave you open and I don't recommend it for any other purpose than testing that the firewall is _definitely_ the problem.

su -
/sbin/iptables -F
/sbin/iptables -X
/sbin/iptables -P INPUT ACCEPT
/sbin/iptables -P OUTPUT ACCEPT
 
Old 03-23-2004, 12:03 AM   #9
liamoboyle
Member
 
Registered: Mar 2004
Location: Wellington, New Zealand
Distribution: Debian
Posts: 127

Rep: Reputation: 15
If you want, you can send me the output of the command

/sbin/iptables -L -v -n, which lists your firewall rules, and I can check them for you. I wouldn't post them to the general public. And also, don't tell me your IP address, otherwise you'd be giving me a pretty good idea of how best to attack your system
--edited to remove email address--

Last edited by liamoboyle; 03-08-2005 at 10:40 PM.
 
Old 03-23-2004, 12:17 AM   #10
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
xspy6bass - OK, here's the settings I've got under Evolution:

Receiving Mail: Server type = POP, Host = postoffice.<provider>.com, Username = <my_accountname>, Use SSL = Never, Authentication = Password, Remember PW = unchecked

Sending Mail: Host = mail.<provider>.com, Use SSL = Never, Authentication = none

Note that (obviously) I am substituting dummy values in any fields marked by <field> and you would need to confirm that the server names are appropriate to your ISP. Dunno if this will help or not but I hope it does.

As far as the RH Security settings, be sure you enable "Allow incoming Mail (SMTP)". I've got my setting at the Medium level, and it seems to work OK. -- J.W.
 
Old 03-23-2004, 04:31 PM   #11
xspy6bass
LQ Newbie
 
Registered: Mar 2004
Location: Columbus, Ohio
Distribution: Debian
Posts: 9

Original Poster
Rep: Reputation: 0
I tried again to change my firewall settings from the Security tab in the Systems Settings Menu, I changed them from my root account, an when I logged out I hit the save these settings tab, but it was still back at high when I logged in, so I changed it again, confirmed my action with the dialogue box, closed the program, reopened it, and it was back at high AGAIN. Any thoughts? I also tried the stuff from the terminal, I typed in the telnet command and I got...

Trying xx.xxx.xx.xx
telnet: Unable to connect to remote host: Connection refused

so I tried turning the firewall off through the terminal, by the way, shoulf I type those in one at a time?, or can I just copy and paste it in? I tried both, then tried telnet again and got the same response. Thanks again.
 
Old 03-23-2004, 08:52 PM   #12
liamoboyle
Member
 
Registered: Mar 2004
Location: Wellington, New Zealand
Distribution: Debian
Posts: 127

Rep: Reputation: 15
Conenction refused indicates that it got past the firewall and there was nothing listening at port 143 on the remote host... In which case, it would appear that your target is not an imap server. If you were trying to use a pop server (should have mentioned earlier sorry) then you should try to go to port 110 (I think).

OK, assuming that you're using the hosts originally mentioned, I've done a little investigation.

You need to use POP email, not imap, and your server should be mail.bioelectricnutrition.com. bioelectricnutrition.com itself doesn't run an imap or POP server, but mail.bioelectricnutrition.com runs a pop server only.

Try this and let us know how it goes.
 
Old 03-24-2004, 07:10 PM   #13
xspy6bass
LQ Newbie
 
Registered: Mar 2004
Location: Columbus, Ohio
Distribution: Debian
Posts: 9

Original Poster
Rep: Reputation: 0
Ok, heres the update. I ran the telnet command again connecting this time to port 110. Bingo! I got a connection, so I rebooted my computer and tried it again without typing all the /iptable commands and I was able to connect again. However, I still cannot get Evolution to connect. I went back to check the port settings but I am still getting the same authorization failed message. And yes, I have checked and rechecked my username, password, everything. I am definitely at a loss...any thoughts? Once again, thanks for the continued help, it is much appreciated.
 
Old 03-24-2004, 07:29 PM   #14
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
Can you successfully ping the POP and SMTP servers? Getting the connection is obviously positive, so the next thing would be to confirm that you can get a response from the mail servers. If not, then the mail server is either down or you are using the wrong name; if so, then I would conclude the problem must be within the Evolution settings.

Another approach would be to use a different Email client and see if you can get Email through it. Again, if not, then the mail server is either down or incorrectly specified; if so, then again if Evolution can't get in then the problem is with it, not your hardware.

Wish I could be more help but other than the comments I posted previously I'm tapped out. Good luck with it -- J.W.
 
Old 03-24-2004, 09:08 PM   #15
liamoboyle
Member
 
Registered: Mar 2004
Location: Wellington, New Zealand
Distribution: Debian
Posts: 127

Rep: Reputation: 15
I think J.W.'s suggestion of trying out another client's a good idea. If you're using mozilla as a browser, just fire up the email client. Make sure that the server is configured as POP and if it works... then yeah, blame evolution. Kick it around the room for a while or something
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ximian Evolution e-mail problem alex2002 Linux - Software 4 12-12-2008 09:01 AM
FC2 ximian-evolution e-mail problem. rblampain Linux - Distributions 2 08-28-2005 12:10 AM
Ximian Evolution Mail Client Error. maheshbh Linux - Software 1 03-10-2005 01:07 PM
Ximian Evolution e-mail client help sci0x Linux - Software 4 03-20-2004 05:04 PM
How do I make Evolution recieve mail upon opening? guitargeek Linux - Software 0 04-16-2003 08:32 PM


All times are GMT -5. The time now is 11:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration