LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Closed Thread
  Search this Thread
Old 04-18-2014, 08:01 AM   #1
sharathpadman
LQ Newbie
 
Registered: Apr 2014
Posts: 3

Rep: Reputation: Disabled
While trying to load .so file manually using command its failing


Hi all,

I am newbie to linux environment. I was trying to run an .so file manually which in turn call a method in bin folder.

Command given,

XXX_MODULES=libxxx.so /opt/servicename/bin/methodname -Le -c /opt/servicename/etc/methodname/methodname.conf -n -C -t -m ""

When i tried to execute the command its giving error as

" Initialization of module 'libxxx.so' failed with error code -1
Loading module libxxx.so failed, Continuing anyway. "

What would be the issue. Kindly help me with this...

Regards,
Sharath.
 
Old 04-18-2014, 09:25 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,711

Rep: Reputation: 4134Reputation: 4134Reputation: 4134Reputation: 4134Reputation: 4134Reputation: 4134Reputation: 4134Reputation: 4134Reputation: 4134Reputation: 4134Reputation: 4134
Please read the LQ Rules; do not post the same question multiple times. Thread reported.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
While trying to load .so file manually using command its failing sharathpadman Linux - Newbie 2 04-18-2014 07:24 PM
Possible to load apps manually, offline? Jeromeee Linux - Software 4 03-27-2008 07:42 PM
compiz failing, GLcore.so failing to load Schrambo Linux - Desktop 4 02-23-2008 06:13 PM
manually load m0n0wall Modules Codegen *BSD 0 03-13-2006 09:08 AM
X failing to load; AddScreen/InitScreen failing for driver 0 weblion Linux - Software 1 08-01-2002 06:14 AM


All times are GMT -5. The time now is 02:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration