LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Which 64bit Debian Wheezy Release is wright for my Intel 64bit P8700 CPU PC? (http://www.linuxquestions.org/questions/linux-newbie-8/which-64bit-debian-wheezy-release-is-wright-for-my-intel-64bit-p8700-cpu-pc-4175416651/)

esgol 07-14-2012 03:02 AM

My CPU is 64bit Intel P8700 but when VM put a Linux was told 64bit cpu not found
 
I have a 64bit P8700 on Windows vista business ( i htink they are 64bit also as writes to system info)

but when i tried to VM install a amd64 version it sed 64bit system not found. was cause of the vm?

Now that i want a clear installation wont have probs?

esgol 07-14-2012 03:14 AM

Which 64bit Debian Wheezy Release is wright for my Intel 64bit P8700 CPU PC?
 
I want to make a clear noVM instalation of 64bit Debian Wheezy.

However when i downloaded a amd64 version of Fedora (if i remember weel) and tried VM install, returned me "no 64bit PC found"

at a point i thought my intel wasnt 64bit really unless i checked up to intel website
edit: fixed link
http://www.google.com/url?sa=t&rct=j...zafcWe8KwTEVdQ

So I am most worried now, to chose carefully the wright version for downoad for my pc.

Which of these would be the wright version? Maybe not amd64 but ia64? I have to download from "other images" i guess.
Quote:

Other Images
amd64 armel kfreebsd-amd64 kfreebsd-i386 i386 ia64 mips mipsel powerpc s390 sparc
http://www.debian.org/devel/debian-installer/

honeybadger 07-14-2012 04:30 AM

Look at the output of '/proc/cpuinfo'. This will tell you what kind of cpu you have. If you have any doubts post the output here. Someone will be there to help you.
BTW the link that you posted goes to Error 404.

Hope this helps

nixblog 07-14-2012 04:30 AM

The link you supplied is broken so I cannot see if it supports VT or not. You need Intel VT support on your CPU else you cannot run 64bit OSes in a VM even if your CPU is 64bit. If it has VT support then you may need to enable VT support in your BIOS.

esgol 07-14-2012 05:05 AM

i ll try. fixed link also

http://www.google.com/url?sa=t&rct=j...zafcWe8KwTEVdQ

nixblog 07-14-2012 05:19 AM

Yes, that CPU should be ok for 64bit VM's. Try looking in your BIOS settings for a Intel VT enable option, my ASUS board had it switched off by default.

esgol 07-14-2012 05:42 AM

Yes but which of those versions i listed i have to download? Will it show up exactly (eg ur cpu is amd64) with the command u sugested in konsole?

brianL 07-14-2012 07:00 AM

Yes, you want the amd64 version.

esgol 07-14-2012 07:28 AM

Activating that VT option is required only for VM install and if i instal it clearly it will install normally?

Or i must activate it even for a clear instalation

edit

eeer is this the wright one? :SSSS
http://cdimage.debian.org/cdimage/da...i-arch/iso-cd/
debian-testing-amd64-i386-netinst.iso

netist it does not stand for network instalation eh :SS its for a clear instalation from cd

jefro 07-14-2012 11:55 AM

What virtual machine application are you using?

Any bios setting for vt-x or some virtual support. May have odd names.

Is it possible that you built the client as a 32 bit only?

I had another idea but forgot.

273 07-14-2012 11:57 AM

If you're running Vista 32 bit then it may be you can't run 64 bit clients.
Last time I read VirtualBox's documentation I was given the impression that 64 bit guests in 32 bit hosts is not supported, but people have told me this is wrong.

jefro 07-14-2012 05:16 PM

I was running 64 bit under Windows 7 32 but you have to have full support in cpu and motherboard/bios.

TobiSGD 07-14-2012 05:30 PM

To run 64 bit clients on a 32 bit host you need to have hardware virtualization support, which your CPU does have. You also have to tell the VM that it will be running a 64 bit guest (in Virtualbox this is done with setting the guest OS to "Linux 2.6 (64 bit)" or "distribution name (64 bit)").

nixblog 07-14-2012 11:22 PM

To install any 64bit distro as a VM you will have to have VT option enabled in your BIOS else it will not install or run. If it was a normal install (not VM) directly to your hard drive then the VT option is irrelevant to your choice of 32/64bit.

The Debian ISO your referred to is a multi-architecture version and supports installing Debian as a 32 or 64bit install. You will be given that choice when you start the installation.

esgol 07-15-2012 01:38 AM

Ahh... FINE
THREAD FINAL SOLUTION
So i get this error not because i dont have 64bit but just in VM install cause i need activating the VT option from the Bios.
The BIOS VT option is only for VM Ware Instalation, if you clear instal its irelative as you sed nixblog at post #9. thank you very much

I ve downloaded that debian iso with both i386-amd64 in it, so nice, I ll be given the choice in installation. as you Its fine i think.

P.S.
I hate half-way abandoned threads. Or cause starter managed to find way out.


All times are GMT -5. The time now is 11:23 AM.