LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-08-2011, 07:22 PM   #1
mrbasilsmudge
LQ Newbie
 
Registered: Aug 2011
Posts: 18

Rep: Reputation: Disabled
where to place xrandr configuration


I have migrtaed from Arch, my first experience with linux for the past 2 months, to Debian and i'm currently setting up my system. I have a X61s Thinkpad with a cracked screen which i use with the ultrabase with an external monitor and keyboard. The monitor requires me to use fbset on console and xrandr for a graphical enviroment

Whilst i was using Arch i used 'startx' to access openbox and placed my xrandr configuration in ~/.xinitrc but with debian i have wanted to use a login manager, Slim.

Because i am using KMS for my intel based system i don't have an xorg.conf and because i am using slim i am not using ~/.xinitrc

I read somwhere that creating an ~/.xprofile file would solve this but i have not had any luck. So i am wondering where would be the best place to put the xrandr configuration?

I would be very appreciative to any suggestions, thanks.

Last edited by mrbasilsmudge; 08-08-2011 at 07:24 PM.
 
Old 08-09-2011, 03:43 AM   #2
mrbasilsmudge
LQ Newbie
 
Registered: Aug 2011
Posts: 18

Original Poster
Rep: Reputation: Disabled
What i did....

I am not sure if anyone is interested but on reading the /etc/slim.conf file i noticed that there was an option to use either /etc/X11/Xsession or ~/.xinit. So i added the xrandr configuration to Xsession after the variables files and it seems to have worked
Code:
# initialize variables for use by all session scripts

OPTIONFILE=/etc/X11/Xsession.options

SYSRESOURCES=/etc/X11/Xresources
USRRESOURCES=$HOME/.Xresources

SYSSESSIONDIR=/etc/X11/Xsession.d
USERXSESSION=$HOME/.xsession
USERXSESSIONRC=$HOME/.xsessionrc
ALTUSERXSESSION=$HOME/.Xsession
ERRFILE=$HOME/.xsession-errors

#Try to use xrandr

xrandr --output LVDS1 --off --output VGA1 --mode 1280x1024 --rate 75
I am sure that the more correct solution would have been to utilise one of the mentioned configuration files.. but at the moment i am just glad it works.

If anyone is kind enough to criticise this please do so.

Thanks

Last edited by mrbasilsmudge; 08-09-2011 at 03:45 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
May not be the right place to post this but was no better place. Knightron LQ Suggestions & Feedback 5 03-13-2011 04:24 PM
Xrandr configuration in XF86 hammil Linux - Desktop 3 07-22-2010 03:09 AM
Xrandr Problem Libertes Linux - Newbie 19 02-06-2010 04:41 PM
radeon and dual head, to xrandr or not to xrandr, that's the question i92guboj Linux - Desktop 1 06-17-2009 06:48 AM
xrandr and others gone Beire Ubuntu 1 07-15-2005 07:51 AM


All times are GMT -5. The time now is 08:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration