LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-05-2005, 02:03 PM   #1
mazzo
Member
 
Registered: Jun 2003
Location: Thames Valley, UK
Distribution: RedHat from 5 -9, Fedora, Ubuntu, Centos 3 - 7, Puppy Linux
Posts: 140

Rep: Reputation: 15
Where to load a module ??


I have three nic's in my server, one of which is a legacy ISA nic (non plug and play) and can get it working using:

modprobe ne irq=5 io=0x300

and then

ifconfig eth2 192.168.0.1 netmask 255.255.255.0

This works fine. Then if I put the above into /etc/rc.d/rc.local sure enough it loads, but because it is one of the last things to load, it upsets everything else, such as firewall configuration.

Basically, I have to re-run the firewall config (I use guarddog). It then works OK.

Can I add the above lines to another place which will get them to be loaded much sooner in the startup process?

I've looked at modules.conf, but I'm not sure whether that would work or not (plus the syntax looks different).

Thanks - hopefully there is an easy answer.
 
Old 02-05-2005, 02:08 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
In Fedora, you would add the module to your /etc/modprobe.conf file. Some distros use /etc/modules.conf for this purpose. You can read the man pages on these two files for more information.
 
Old 02-05-2005, 02:24 PM   #3
mazzo
Member
 
Registered: Jun 2003
Location: Thames Valley, UK
Distribution: RedHat from 5 -9, Fedora, Ubuntu, Centos 3 - 7, Puppy Linux
Posts: 140

Original Poster
Rep: Reputation: 15
Thanks.

This is RH 7.3 - and there is no modprobe.conf file.

I have looked at the man page, but I am confused. I could load the module I guess (example of syntax would be very helpful), however I don't think I could load the ifconfig line in there.

What would be ideal is if it would set eth2 up when it sets up eth0 and eth1. BUT how do I get it to do that?
 
Old 02-05-2005, 03:11 PM   #4
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
OK, sorry, it's /etc/modules.conf in the RH 7.x series, and you can do man modules.conf to get some sense of the syntax. I think what you'd have to do is add a line to /etc/modules.conf as follows:

alias eth2 ne
options ne irq=5
options ne io=0x300

although to be honest, I'm not sure about this, since it's been awhile since I had to do this on a Red Hat box. You'll also want to make sure you have an /etc/sysconfig/network-script/ifcfg-eth2 file with the setup params for the device. Based on my quick read, the ifup script modprobes the device based on the /etc/modules.conf entry when it sets up the device.

At any rate, hopefully this will get you pointed in the right direction.
 
Old 02-06-2005, 12:25 PM   #5
mazzo
Member
 
Registered: Jun 2003
Location: Thames Valley, UK
Distribution: RedHat from 5 -9, Fedora, Ubuntu, Centos 3 - 7, Puppy Linux
Posts: 140

Original Poster
Rep: Reputation: 15
That's good advice. Thank you.

Will let you know how it goes.
 
Old 02-07-2005, 08:15 AM   #6
mazzo
Member
 
Registered: Jun 2003
Location: Thames Valley, UK
Distribution: RedHat from 5 -9, Fedora, Ubuntu, Centos 3 - 7, Puppy Linux
Posts: 140

Original Poster
Rep: Reputation: 15
Sadly, it didn't work.

I changed the modules.conf and included:

alias eth2 ne
options ne io=0x300 irq=5

I then added the config file for eth2 to the /etc/sysconfig/network-scripts/

It all boots up OK and it makes no mention of any problem with the modules.conf. It sets up all three nic's - but when it is finished all it has done is assign eth2's settings to eth1 and eth2 does not exist in the route.

Perhaps I have done something wrong, but I don't know what. It's like it sets eth2 but hasn't recognised that there is actually a card for it.

Just a thought, but is there another place I could put the original lines from rc.local that would be actioned much earlier in the startup?

I would prefer to do the modules.conf way if poss as it is much neater.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Module Auto-Load: module.conf tricks? m_e_perry Linux - Newbie 3 10-07-2004 06:45 PM
module cant load Ryan450 Linux - Software 2 08-13-2004 12:31 AM
module cant load Ryan450 Linux - Hardware 3 08-12-2004 02:33 PM
Need help getting module to load mitchmiller Linux - Hardware 1 05-16-2004 08:50 PM
why won't this module load? shanenin Linux - Software 1 10-16-2003 10:23 AM


All times are GMT -5. The time now is 08:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration