LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-06-2006, 10:10 PM   #1
TannerTS
LQ Newbie
 
Registered: Apr 2006
Distribution: Red Hat
Posts: 5

Rep: Reputation: 0
Where to get/install libssl.so.0.9.7?


Hi all,

Today I tried to install BZFlag (bzflag.org). I did no compiling, just downloaded it. When trying to run/install it I get a message saying that I am missing libssl.so.0.9.7. I've searched Google and found nothing in my newbie-linux language. Maybe ya'll can help me?

Thanks
-Tanner
 
Old 04-06-2006, 10:18 PM   #2
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
You need to install a package named Openssl

What distro you use?



Reegards



Bye
 
Old 04-06-2006, 10:19 PM   #3
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
You need to install openssl.
 
Old 04-06-2006, 10:29 PM   #4
TannerTS
LQ Newbie
 
Registered: Apr 2006
Distribution: Red Hat
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Acron_0248
You need to install a package named Openssl

What distro you use?



Reegards



Bye

I am using Red Hat 4. I'm not absolute on the number, but it is Red Hat.

-Tanner
 
Old 04-06-2006, 11:50 PM   #5
Acron_0248
Member
 
Registered: Feb 2006
Location: Venezuela
Distribution: Gentoo
Posts: 453

Rep: Reputation: 33
Well, you can use the redhat network (Main Menu > System Tools) to try to search the Openssl package or see here for the package you need


Hope you find it usefull


Reegards


Bye
 
Old 04-07-2006, 10:02 AM   #6
TannerTS
LQ Newbie
 
Registered: Apr 2006
Distribution: Red Hat
Posts: 5

Original Poster
Rep: Reputation: 0
Ok, I downloaded one which seemed fit for my system and when I attempt to install/run it I get:

The file "//tmp/openssl-0.9.7a-43.1.src.rpm" is a source RPM which cannot be installed with system-config-packages.

I'm assuiming that means I have to compile it?

-Tanner
 
Old 04-07-2006, 10:16 AM   #7
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
Redhat should have openssl packages. You need to install them from your installation media or using RHN as suggested above. The package you have downloaded won't work because its a source rpm which is meant to be rebuilt to create a binary rpm.

Last edited by reddazz; 04-07-2006 at 10:18 AM.
 
Old 04-07-2006, 07:40 PM   #8
TannerTS
LQ Newbie
 
Registered: Apr 2006
Distribution: Red Hat
Posts: 5

Original Poster
Rep: Reputation: 0
Ok I went to RHN and looked around. I found this package, but when trying to install I get a message telling me it has been installed already. I'm lost. :\

On RHN it tells me that I have these packages (with the words "openssl") installed on my Linux machine:

openssl-0.9.7a-43.8
openssl-devel-0.9.7a-43.8
openssl096b-0.9.6b-22.42
pyOpenSSL-0.6-1.p23
xmlsec1-openssl-1.2.6-3

-Tanner

Last edited by TannerTS; 04-07-2006 at 07:43 PM.
 
Old 04-09-2006, 09:55 AM   #9
TannerTS
LQ Newbie
 
Registered: Apr 2006
Distribution: Red Hat
Posts: 5

Original Poster
Rep: Reputation: 0
Bump.

-Tanner
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
libssl.so.5 and libcrypto.so.5 needed, but got libssl.so.6?! Lobais Linux - Software 4 10-08-2008 03:59 AM
libssl.so.0.9.7 ultrashawn Linux - Newbie 3 02-04-2005 02:09 AM
cant install libssl.so.4 tleviathan Linux - Newbie 5 11-05-2004 08:48 AM
LibSSL jadukor_bd Linux - Software 2 09-18-2003 03:11 PM
Openssl does not install libssl.so ninen Linux - Software 2 03-25-2003 03:35 AM


All times are GMT -5. The time now is 04:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration