LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-18-2004, 01:03 PM   #1
timsch75
Member
 
Registered: Feb 2004
Location: austin, TX
Distribution: slackware 10
Posts: 169

Rep: Reputation: 30
where does linux look for swap partition information @ bootup?


I have a system with win2k, suse9, and slack10, installed in that order. When I installed slack, I changed the location of the swap partition. Suse no longer boots correctly and I think it is because it does not know where to find the swap. I've changed the fstab file to indicate where it is located, but that doesn't help. Do I need to note the change somewhere else?

If I do end up having to reinstall suse, is there an option to not install grub? I don't recall seeing that option.
 
Old 08-18-2004, 01:15 PM   #2
ToniT
Senior Member
 
Registered: Oct 2003
Location: Zurich, Switzerland
Distribution: Debian/unstable
Posts: 1,357

Rep: Reputation: 47
/etc/fstab is the right location. Have you inititialized your swap partition (called mkswap for the partition in question)?
 
Old 08-18-2004, 01:19 PM   #3
mdg
Member
 
Registered: Sep 2003
Distribution: Slackware
Posts: 626

Rep: Reputation: 37
Check if you have an option in your suse entry in lilo.conf (if you use lilo) something like "resume=hd<your swap partition>. Make sure it points to the new location.
 
Old 08-18-2004, 04:19 PM   #4
timsch75
Member
 
Registered: Feb 2004
Location: austin, TX
Distribution: slackware 10
Posts: 169

Original Poster
Rep: Reputation: 30
I do not have "resume=hd<your swap partition> in my lilo.conf. However, that line is not listed for my SLACK section either and it works fine. Here's part of my lilo.conf.

image = /boot/vmlinuz
root = /dev/hdf1
label = SLACK
append="hdb=ide-scsi" # above line added for scsi emulation for cdrw
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hdf6
label = SUSE
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/hde1 label = windows
# map-drive = 0x80
# to = 0x81
# map-drive = 0x81
# to = 0x80
table = /dev/hde
# Windows bootable partition config ends ~


What does the "resume... line do if I enter it?
 
Old 08-18-2004, 05:01 PM   #5
timsch75
Member
 
Registered: Feb 2004
Location: austin, TX
Distribution: slackware 10
Posts: 169

Original Poster
Rep: Reputation: 30
It turns out that modprobe is not loading ANY modules on bootup, which probably explains my problems more than the swap business. On bootup, I recall seeing failure messages referring to swap, but dmesg shows that it did seem to pick up the swap partition after all. lsmod shows nothing being loaded, and an error message I get when manually entering modprobe states that the directory of modules that it is looking for, something/something/2.4.26 does not exist. I don't know what would have happened. Sure hope someone can clue me in....

I'd post error messages and boot information if I could, but I'm posting in slack and have no way that I know of to get those logs from suse to slack without my mouse, internet, etc. working.

Last edited by timsch75; 08-18-2004 at 05:03 PM.
 
Old 08-19-2004, 01:59 AM   #6
mdg
Member
 
Registered: Sep 2003
Distribution: Slackware
Posts: 626

Rep: Reputation: 37
It looks like you're booting the same kernel for Slack and Suse. You have "image=/boot/vmlinuz" for both distro's. Unless you have two separate lilo.conf files (one for each root partition), one of the "image" entries should be something like "image=/mnt/slack/boot/vmlinuz"
 
Old 08-19-2004, 08:34 AM   #7
timsch75
Member
 
Registered: Feb 2004
Location: austin, TX
Distribution: slackware 10
Posts: 169

Original Poster
Rep: Reputation: 30
Thanks for pointing that out. I really should not have missed that. I'll correct that later today and that should take care of the problem.
 
Old 08-19-2004, 10:42 PM   #8
timsch75
Member
 
Registered: Feb 2004
Location: austin, TX
Distribution: slackware 10
Posts: 169

Original Poster
Rep: Reputation: 30
well, I've tried several different versions of "image=/mnt/slack/boot/vmlinuz" and cannot get /sbin/lilo to accept any of them. I have two hard drives, with the second /dev/hdf, slack on hdf1 and suse on hdf6. I've tried "image=/mnt/hdf6/boot/vmlinuz" "image=/mnt/dev/hdf6/boot/vmlinuz" "image=/mnt/hdf1/boot/vmlinuz", and maybe others, all more shots in the dark than the previous.

damn, still a confused noob....
 
Old 08-20-2004, 03:20 AM   #9
mdg
Member
 
Registered: Sep 2003
Distribution: Slackware
Posts: 626

Rep: Reputation: 37
What hd is lilo installed on?
MBR or root partition?

Also, post your /etc/fstab file and complete /etc/lilo.conf
 
Old 08-20-2004, 07:02 AM   #10
timsch75
Member
 
Registered: Feb 2004
Location: austin, TX
Distribution: slackware 10
Posts: 169

Original Poster
Rep: Reputation: 30
Lilo is in the MBR, which is on the first HD, /dev/hde.

/etc/lilo.conf:

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hde
#compact # faster, but won't work on all systems.
prompt
timeout = 300
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0 # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hdf1
label = SLACK
append="hdb=ide-scsi"
# above line added for scsi emulation for cdrw
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends
# Linux bootable partition config begins

image =/boot/vmlinuz
root = /dev/hdf6
label = SUSE
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/hde1
label = windows
# map-drive = 0x80
# to = 0x81
# map-drive = 0x81
# to = 0x80
table = /dev/hde
# Windows bootable partition config ends
~


Here is the SLACK /etc/fstab file:

/dev/hdf1 / reiserfs defaults 1 1
/dev/hdf2 /home reiserfs defaults 1 2
/dev/hde1 /windows vfat gid=100,umask=002,noexec,nosuid 0 0
/dev/hde2 /w2 vfat defaults 1 0
/dev/hde3 /w3 vfat defaults 1 0
/dev/hde5 /w4 vfat defaults 1 0
/dev/hde6 /w5 vfat defaults 1 0
/dev/sdb1 /mnt/camera vfat noauto,users 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,users,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/sda4 /mnt/zip vfat noauto,user 0 0
proc /proc proc defaults 0 0
/dev/hdf6 /suse reiserfs defaults 0 0
~
****p.s. I just added this last line. It was not there when I was trying to fix my problems

I'd imagine that you need the SUSE /etc/fstab file, though:

/dev/hdf6 / reiserfs defaults 1 1
/dev/hdf3 /data1 auto noauto,user 0 0
/dev/hde1 /windows/C vfat users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0
/dev/hdf1 /windows/D vfat users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0

/dev/hdf5 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbdevfs /proc/bus/usb usbdevfs noauto 0 0
/dev/cdrecorder /media/cdrecorder auto ro,noauto,user,exec 0 0
/dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0
~
~


Here is the contents of /suse/boot

tim@sbc:/suse/boot$ ls
Kerntypes-2.4.21-226-athlon config-2.4.21-226-athlon message
System.map-2.4.21-226-athlon grub/ vmlinux-2.4.21-226-athlon.gz
backup_mbr initrd@ vmlinuz@
boot@ initrd-2.4.21-226-athlon vmlinuz-2.4.21-226-athlon


I'd imagine I need to use the vmlinuz-2.4.21-226-athlon kernel, although it doesn't look familiar.


thanks for your help
 
Old 08-20-2004, 07:35 AM   #11
mdg
Member
 
Registered: Sep 2003
Distribution: Slackware
Posts: 626

Rep: Reputation: 37
You installed Slack after Windows and Suse were already installed. The way I see it, if you installed lilo (again - it was already there with Suse) with Slack, it overwrote the Suse lilo already in MBR. So booting takes place from Slack's point of view, therefore all entries in lilo.conf should reflect that.

Looking at fstab (slack), you have the line to mount Suse:
Code:
/dev/hdf6 /suse reiserfs defaults 0 0
For that to work, you must have a folder "suse" (case sensitive) in your Slack / directory

Then edit lilo.conf and change the Suse entry from
Code:
image =/boot/vmlinuz
root = /dev/hdf6
label = SUSE
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
to
Code:
image =/suse/boot/vmlinuz-2.4.21-226-athlon
root = /dev/hdf6
label = SUSE
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
assuming that "vmlinuz-2.4.21-226-athlon" is your working kernel in Suse

Give that a shot. If it doesn't work, it's probably because of the Suse "image" line in lilo.conf. Maybe you use the initrd option to boot, I'm not familiar with Suse
 
Old 08-22-2004, 12:40 AM   #12
timsch75
Member
 
Registered: Feb 2004
Location: austin, TX
Distribution: slackware 10
Posts: 169

Original Poster
Rep: Reputation: 30
Well, I changed /etc/lilo.conf to:

Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hdf1
label = SLACK
append="hdb=ide-scsi"
# above line added for scsi emulation for cdrw
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends
# Linux bootable partition config begins

image =/suse/boot/vmlinuz
root = /dev/hdf6
label = SUSE
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/hde1
label = windows
# map-drive = 0x80
# to = 0x81
# map-drive = 0x81
# to = 0x80
table = /dev/hde
# Windows bootable partition config ends


I also used
image =/suse/boot/vmlinuz-2.4.21-226-athlon


Both were an improvement in that at least /sbin/lilo would run them, but when trying to boot into
suse, I got KERNEL PANIC: VFS: unable to mount root fs on 21:46 , I've searched but have found
no info on this error message.
 
Old 08-22-2004, 01:07 AM   #13
2damncommon
Senior Member
 
Registered: Feb 2003
Location: Calif, USA
Distribution: PCLINUXOS
Posts: 2,876

Rep: Reputation: 88
My old Suse 9.0 Lilo entry looks like this:
Code:
image = /mnt/hdaxx/boot/vmlinuz
  label = SUSE_9.0
  initrd = /mnt/hdaxx/boot/initrd
  root = /dev/hdaxx
  append = "splash=silent desktop hdc=ide-scsi hdclun=0"
  read-only
I think you need the "initrd" entry.
Both my 9.0 & 9.1 have the "splash=silent" and "desktop" entries after "append".
 
Old 08-23-2004, 08:21 AM   #14
timsch75
Member
 
Registered: Feb 2004
Location: austin, TX
Distribution: slackware 10
Posts: 169

Original Poster
Rep: Reputation: 30
thanks, 2d*, that did it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
doing away with linux swap partition? kahn Linux - Hardware 3 06-26-2005 04:14 PM
Telling Linux what to use as its swap partition timelord726 Fedora 26 01-01-2005 10:19 PM
swap information Xiangbuilder Linux - General 2 10-24-2003 10:37 PM
Swap partition in Linux mikeshn Linux - General 5 04-15-2002 10:22 AM
Linux put the swap partition on my second HD. Don't want it there. rdaves@earthlink.net Linux - General 3 09-21-2001 08:42 AM


All times are GMT -5. The time now is 01:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration