LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-03-2013, 11:26 PM   #1
arcon
LQ Newbie
 
Registered: Jan 2013
Posts: 2

Rep: Reputation: Disabled
when telnet to port 10000 ,it gives a "protocal mismatch"


When try to run " telnet XX.XX.XX.XX 10000" commnad the server gives out folowing error ( XX - ip address)

"SSH-2.0-OpenSSH_5.3p1 Debian-3ubuntu7"
"Protocol mismatch."

the correct output what i expected is somthing like this "$☺PYC☻♥ _ " please let me know how to solve this

Thanks
 
Old 01-04-2013, 12:03 AM   #2
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 2,404

Rep: Reputation: Disabled
You're trying to telnet to a service other than telnet. Specifically, the service listening on port 10000 is an SSH deamon, which expects connecting clients to communicate using the SSH protocol.

An SSH daemon always announces the SSH version and product name when a client connects. Why you would expect to see garbage characters instead is not immediately obvious.
 
1 members found this post helpful.
Old 01-04-2013, 04:00 AM   #3
NevemTeve
Senior Member
 
Registered: Oct 2011
Location: Budapest
Distribution: Debian/GNU/Linux, AIX
Posts: 2,956

Rep: Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845
Program telnet talks telnet protocol. Try netcat (nc).
Edit: but I don't think you could emulate ssh protocol... Perhaps you should use ssh client program?

Last edited by NevemTeve; 01-04-2013 at 04:02 AM.
 
Old 01-04-2013, 09:03 AM   #4
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,604

Rep: Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241
As noted, the daemon you are telneting to is a secure shell service.

The version identification is part of the protocol. The following garbage characters are the public key that the client should use for encrypting the next part of the communication.

The "protocol mismatch" is due to the failure of the handshaking (telnet protocol vs ssh protocol). If I remember right, you are supposed to present your public key.... but the telnet protocol from the client doesn't do that.
 
1 members found this post helpful.
Old 01-04-2013, 08:03 PM   #5
arcon
LQ Newbie
 
Registered: Jan 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thank you very much for your reply
What I really want to do is configure Symantec Backup exec client on the remote server , and it use port 10000 to communicate with the Backup exec server.with this specific server it failed to communicate because of this "protocol mismatch" issue. Please let me know what i should do to rectify this .

Thanks again for all your support ...
 
Old 01-04-2013, 08:35 PM   #6
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,604

Rep: Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241
As far as I know, that has nothing to do with Linux, nor ssh... It is a windows product only.

A client does exist for Linux... but it does its own thing.

Last edited by jpollard; 01-04-2013 at 08:37 PM.
 
Old 01-07-2013, 11:03 AM   #7
BE_lmoss
LQ Newbie
 
Registered: Jan 2013
Posts: 4

Rep: Reputation: Disabled
Hello,
Ive had much success with the following suggestions offered here
http://www.symantec.com/business/sup...t&id=TECH48522
 
Old 01-07-2013, 01:00 PM   #8
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,604

Rep: Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241Reputation: 1241
You just gave everyone on the (local) net the root password...

and confirmed that it is not using ssl/TLI for protection. Which is opposite what you listed at the beginning.
 
Old 01-07-2013, 01:18 PM   #9
Habitual
LQ Addict
 
Registered: Jan 2011
Location: Youngstown, Ohio
Distribution: LM17.1/Xfce4.11.8
Posts: 7,170
Blog Entries: 10

Rep: Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979Reputation: 1979
Quote:
Originally Posted by jpollard View Post
As far as I know, that has nothing to do with Linux, nor ssh... It is a windows product only.

A client does exist for Linux... but it does its own thing.
Port 10000 is the webmin port, no?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fortran 90 "Assertion exponent < 10000 failed" suicidaleggroll Programming 13 07-05-2013 04:12 AM
[SOLVED] sendmail logging "connection refused" but telnet to port 25 works lrtward Linux - Server 2 08-08-2012 01:58 PM
php "system"-call to access tty port, "error accessing" wedz Linux - Software 3 05-22-2012 08:34 PM
Trying webmin, getting "attempt to connect to 127.0.0.1:10000 (localhost) failed" jeffreybluml Linux - General 1 08-16-2007 12:16 PM
Error "Kernel version mismatch" when nic driver will be loaded grubjo Linux - Networking 1 10-03-2003 05:12 AM


All times are GMT -5. The time now is 04:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration