LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-21-2006, 05:16 PM   #1
Yihya
LQ Newbie
 
Registered: Feb 2006
Location: Germany
Distribution: fedora core 6
Posts: 3

Rep: Reputation: 0
When i update my system with yum update


Hi all,
when i update my system with yum update i get the errors at the end
i have changed the yum.repos.d files can anyone help me to fix this problem
and what it mean Package ¨something¨ set to be updated

---> Downloading header for faac to pack into transaction set.
faac-1.24-0.lvn.3.4.i386. 100% |=========================| 3.5 kB 00:00
---> Package faac.i386 0:1.24-0.lvn.3.4 set to be updated
---> Package gnome-python2-desktop.i386 0:2.13.3-1.1 set to be updated
---> Package liboil.i386 0:0.3.6-3.fc5.2 set to be updated
---> Package system-config-network.noarch 0:1.3.30-2.1 set to be updated
---> Downloading header for rhpxl to pack into transaction set.
rhpxl-0.15-1.noarch.rpm 100% |=========================| 16 kB 00:00
---> Package rhpxl.noarch 0:0.15-1 set to be updated
---> Package tomcat5-servlet-2.4-api.i386 0:5.0.30-8jpp_11fc set to be updated
---> Downloading header for sysfsutils to pack into transaction set.
sysfsutils-1.3.0-1.2.1.i3 100% |=========================| 6.3 kB 00:00
---> Package sysfsutils.i386 0:1.3.0-1.2.1 set to be updated
---> Package xml-commons-apis.i386 0:1.0-0.b2.7jpp_5fc set to be updated
---> Downloading header for gsm to pack into transaction set.
gsm-1.0.10-0.lvn.9.4.i386 100% |=========================| 5.3 kB 00:00
---> Package gsm.i386 0:1.0.10-0.lvn.9.4 set to be updated
---> Package system-config-soundcard.noarch 0:1.2.16-1 set to be updated
---> Package firstboot-tui.noarch 0:1.4.4-1 set to be updated
---> Downloading header for notify-daemon to pack into transaction set.
notify-daemon-0.3.1-8.i38 100% |=========================| 4.6 kB 00:00
---> Package notify-daemon.i386 0:0.3.1-8 set to be updated
---> Downloading header for imlib2 to pack into transaction set.
imlib2-1.2.1-1.fc4.i386.r 100% |=========================| 14 kB 00:00
---> Package imlib2.i386 0:1.2.1-1.fc4 set to be updated
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Processing Dependency: kudzu >= 1.2.0 for package: system-config-display
--> Processing Dependency: kudzu >= 1.2.0 for package: rhpxl
--> Processing Dependency: system-config-network-tui = 1.3.30-2.1 for package: system-config-network
--> Processing Dependency: libgs.so.7 for package: xine-lib
--> Processing Dependency: netconfig for package: firstboot-tui
--> Processing Dependency: kudzu for package: system-config-soundcard
--> Processing Dependency: XFree86-devel for package: fltk
--> Processing Dependency: xml-commons = 0:1.0-0.b2.7jpp_5fc for package: xml-commons-apis
--> Processing Dependency: libMagick.so.6 for package: xine-lib
--> Processing Dependency: Mesa-devel for package: fltk
--> Processing Dependency: libWand.so.6 for package: xine-lib
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package system-config-network-tui.noarch 0:1.3.30-2.1 set to be updated
---> Package xml-commons.i386 0:1.0-0.b2.7jpp_5fc set to be updated
---> Downloading header for netconfig to pack into transaction set.
netconfig-0.8.24-1.2.2.i3 100% |=========================| 15 kB 00:00
---> Package netconfig.i386 0:0.8.24-1.2.2 set to be updated
---> Downloading header for kudzu to pack into transaction set.
kudzu-1.2.30-1.i386.rpm 100% |=========================| 53 kB 00:00
---> Package kudzu.i386 0:1.2.30-1 set to be updated
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Processing Dependency: libgs.so.7 for package: xine-lib
--> Processing Dependency: XFree86-devel for package: fltk
--> Processing Dependency: libMagick.so.6 for package: xine-lib
--> Processing Conflict: kudzu conflicts kernel < 2.6.13
--> Processing Dependency: Mesa-devel for package: fltk
--> Processing Dependency: libWand.so.6 for package: xine-lib
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
--> Processing Conflict: initscripts conflicts kernel < 2.6.12
--> Processing Dependency: libgs.so.7 for package: xine-lib
--> Processing Dependency: XFree86-devel for package: fltk
--> Processing Dependency: libMagick.so.6 for package: xine-lib
--> Processing Conflict: kudzu conflicts kernel < 2.6.13
--> Processing Dependency: Mesa-devel for package: fltk
--> Processing Dependency: libWand.so.6 for package: xine-lib
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Missing Dependency: libWand.so.6 is needed by package xine-lib
Error: Missing Dependency: libgs.so.7 is needed by package xine-lib
Error: Missing Dependency: libMagick.so.6 is needed by package xine-lib
Error: Missing Dependency: XFree86-devel is needed by package fltk
Error: Missing Dependency: Mesa-devel is needed by package fltk
Error: kudzu conflicts with kernel < 2.6.13
Error: Unable to satisfy dependencies
Error: Package initscripts needs kernel < 2.6.12, this is not available.
Error: Package xine-lib needs libgs.so.7, this is not available.
Error: Package fltk needs XFree86-devel, this is not available.
Error: Package xine-lib needs libMagick.so.6, this is not available.
Error: Package kudzu needs kernel < 2.6.13, this is not available.
Error: Package fltk needs Mesa-devel, this is not available.
Error: Package xine-lib needs libWand.so.6, this is not available.
 
Old 02-22-2006, 10:33 AM   #2
victorh
Member
 
Registered: Jul 2005
Location: La Paz, Bolivia
Distribution: Debian Sarge - Sid, Slackware, Gentoo, openSuse, Fedora, Ubuntu, Mandriva
Posts: 241

Rep: Reputation: 30
This problem, is the consequence that you changed the repositories. I don't know the reason you did it, but when you did it, some of the packages installed in you system have unmet dependencies (probably available on the repositories you changed). In Fedora you have to be very careful while doing these changes in the repositories, some of them are not compatible.

You can try one of these solutions:

1. Uninstall all the packages with broken dependencies, and install them again with the new repositories.
2. Change back the file yum.repos.d and make available the repositories you changed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Online Update, System Update, WTF? Crito Suse/Novell 6 05-11-2006 02:43 PM
yum error, can't update system simeandrews Fedora 8 09-01-2005 12:35 PM
trying to update via yum and update fails lnxmacusr Fedora 4 12-17-2004 04:12 PM
Update Fedora2 using "yum update" problem chinaundead Fedora 9 04-27-2004 10:25 AM
Yum Update complains of missing file to do update, but file exists! davidas Linux - Newbie 0 03-28-2004 12:14 PM


All times are GMT -5. The time now is 02:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration