LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   when i try to start samba pdc's smb service nmbd failed to start . (http://www.linuxquestions.org/questions/linux-newbie-8/when-i-try-to-start-samba-pdcs-smb-service-nmbd-failed-to-start-117283/)

sandeepchau123 11-17-2003 11:12 PM

when i try to start samba pdc's smb service nmbd failed to start .
 
i have set samba pdc
when i tried to start smb service my smbd daemon start but nmbd fail to start.
when i tried to remove samba package by using following command
rpm -e samba*
it says samba package not installed
and when i tried to insatall samba by using following command
rpm -ivf samba*
it says samba package already installed.

my samba file is


# Samba config file created using SWAT
# from sandeep (127.0.0.1)
# Date: 2003/11/17 21:36:11

# Global parameters
[global]
workgroup = SANDEEP.COM
netbios name = SANDEEP
server string = Samba Server
encrypt passwords = Yes
obey pam restrictions = Yes
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
unix password sync = Yes
log file = /var/log/samba/%m.log
max log size = 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
domain admin group = root
logon script = %U.bat
logon drive = h:
domain logons = Yes
os level = 64
preferred master = Yes
domain master = Yes
dns proxy = No
wins server = 172.24.150.142
wins support = Yes
printing = cups

[homes]
comment = Home Directories
valid users = %S
read only = No
create mask = 0664
directory mask = 0775
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

[public]
path = /data
read only = No
guest only = Yes
guest ok = Yes

[netlogon]
path = /usr/local/samba/lib/netlogon
write list = root

[profiles]
path = /export/smb/ntprofile
read only = No
create mask = 0600
directory mask = 0700

michaelk 11-18-2003 07:08 AM

Have you looked at the samba logs to see if you can find a reason that nmbd failed to start? What distro / version are you running?

checkmate3001 10-20-2007 01:59 PM

I have same problem and fixed it.
 
I had the same problem. smbd would start, but after reloading the server it would always give me an error stating that the nmbd pid was not valid.

I then restarted samba (and it said it was starting smbd and nmbd) but after checking the processes (ps -A | grep nmbd) I found it was not running.

I checked the /var/log/samba/log.nmbd log file and found that it could not get the IP address I had set in the interfaces= section of the smb.conf.

I had it originally using eth1 through a switch (for testing) and then changed it back to using eth0 through my router. Unfortunately I did not notice that I gave the address of the router instead of the IP of the computer. So the router wasn't going to let that IP address get used.

I changed the interfaces= part of smb.conf to match the IP address of my computer and the interface (eth0). All works fine now.


All times are GMT -5. The time now is 04:01 AM.