LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-12-2005, 05:33 PM   #1
Snipersnest
Member
 
Registered: Jan 2005
Location: SC
Distribution: Ubuntu 7.10 Gusty Gibbon
Posts: 269

Rep: Reputation: 30
Whats Python do?


I sure wish I knew how to fix this problem
I get this on a different box of mine when I do up2date or yum...Even if I remove Python and reinstall it I still get this message.... Whats Python for and how can I finish my updates?

---> Package python-devel.i386 0:2.3.4-13.1 set to be updated
--> Running transaction check
--> Processing Conflict: python-devel conflicts python < 2.3.4-13.1
--> Finished Dependency Resolution
Error: python-devel conflicts with python < 2.3.4-13.1

Fedora Core 3
P4 2.5ghz
1GB PC2700

2.6.10_760 kernel
 
Old 02-12-2005, 05:53 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Python is a scripting language like Perl or Tcl. For example, Yum is written in Python. It looks like you have an older version of Python installed, and it's trying to put a newer python-devel on which is causing problems. You can confirm this using rpm -q python. The solution my be to upgrade your Python by hand, but I've never run into this on FC3.
 
Old 02-14-2005, 08:22 AM   #3
Snipersnest
Member
 
Registered: Jan 2005
Location: SC
Distribution: Ubuntu 7.10 Gusty Gibbon
Posts: 269

Original Poster
Rep: Reputation: 30
I still get the same error.... I can't even tell if any of the Python RPMs are installed.... But do I really even need Python for normal use of FC3 ?? Does it do something that I might need later?
 
Old 03-13-2005, 08:58 AM   #4
azacid
LQ Newbie
 
Registered: Feb 2004
Location: London
Distribution: Fedora Core 3
Posts: 18

Rep: Reputation: 0
I've been dogged by this problem as well, I'm sure there is a fix... somewhere!!!

But for now I use the fix -

yum --exclude=python-devel update

It gets the upgrades done.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Processing Conflict: python-devel conflicts python< 2.3.4-13.1 guarriman Fedora 2 04-23-2009 08:02 PM
installing python library's (Python Numeric) Four Linux - Newbie 1 10-16-2005 03:31 PM
WineX, python-gnome, and python-gtk DrD Fedora 0 08-03-2004 01:11 PM
install python 2.3 ,necssary to remove python 2.2 ngan_yine Linux - Newbie 7 12-28-2003 05:07 PM
Whats the best free IDE for Python ? nilch Linux - Software 2 01-05-2003 04:40 AM


All times are GMT -5. The time now is 06:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration