LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-19-2009, 09:39 PM   #1
trnz$mr
Member
 
Registered: Oct 2008
Posts: 121

Rep: Reputation: 15
What Would You Do?


If you where new to Linux and you had a Toshiba Satellite A135 Notebook with Slackware 12.2, and you where able to go online with your Ethernet cable but not your wireless card (An Intel(R) PRO/Wireless 3945ABG) what would you do?

I've spent a couple of days trying to fix it but the best information I can find online is out-of-date practically.

When I run a command, in my KDE Suite, shell Konsole like:
Quote:
iwconfig
this is what I get:
Quote:
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11abg ESSID:"DARKSTAR"
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=15 dBm
Retry min limit:7 RTS thrff Fragment thr=2352 B
Encryption keyff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
What is the first step to fixing this problem?
 
Old 02-19-2009, 09:43 PM   #2
trnz$mr
Member
 
Registered: Oct 2008
Posts: 121

Original Poster
Rep: Reputation: 15
Sorry, but for a little more info I have a lynksis WRT54G Router

Also, when my computer is booting off of slack, I get approximately a 100 lines of error code. like this.

Quote:
Error for wireless request "SET nickname" (8B1C)
Set failed on device wlano; operation not supported
wlano no private ioctls

grep: etc/wpa_suppicant.conf: No such file or directory
grep: etc/wpa_suppicant.conf: No such file or directory
'''''''''''''''''''''''''''''''''''''''''''''''''''''''
(this line repeats a hundred or so times)

Last edited by trnz$mr; 02-19-2009 at 10:23 PM. Reason: clarification
 
Old 02-19-2009, 10:03 PM   #3
digerati1338
Member
 
Registered: May 2007
Location: CO
Distribution: Ubuntu
Posts: 152
Blog Entries: 1

Rep: Reputation: 18
iwconfig is the right command.

More specifically you need iwconfig wlan0 and ifconfig wlan0. You can look at the man pages and help output for these commands to see what you need to do. Make sure everything is configured properly then do ifconfig wlan0 up.
 
Old 02-19-2009, 10:20 PM   #4
trnz$mr
Member
 
Registered: Oct 2008
Posts: 121

Original Poster
Rep: Reputation: 15
Quote:
More specifically you need iwconfig wlan0 and ifconfig wlan0. You can look at the man pages and help output for these commands to see what you need to do.
thanks for helping me be more specific when I run the command:
Quote:
iwconfig wlan0
I get something I don't know what to do with, and yet how do I configure it correctly? But I'll try to hunt down my man pages.
Quote:
wlan0 IEEE 802.11abg ESSID:"DARKSTAR"
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=15 dBm
Retry min limit:7 RTS thrff Fragment thr=2352 B
Encryption keyff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx e
Also for the command:
Quote:
ifconfig wlan0
this display's:
Quote:
wlan0 Link encap:Ethernet HWaddr 00:19:d2:32:9b:4c
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
It looks my wireless card is dead. It works fine with vista (sorry for my bad language), but I'm really looking forward using it with slack 12.2. right now I am obsessed with getting this thing to work. Only then will I be a happy man

Last edited by trnz$mr; 02-19-2009 at 10:24 PM.
 
Old 02-19-2009, 10:29 PM   #5
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,075

Rep: Reputation: 189Reputation: 189
Ok.

With Slackware, there are basically 2 ways to configure your wireless card.

One way is to manually edit /etc/rc.d/rc.inet1.conf and fill in the appropriate sections in order to get your wireless card running. This is the way I do it.

A second, perhaps simpler way to get it up and running is to download wicd,(from any Slackware mirror) or if you have the slackware installation media available, it's in /extra, and install it:

as root

#installpkg wicd....tgz.

Depending on what you're using as a DE (I'm assuming KDE), you should be able to find the wicd executable, and fill in the blanks, and you should be up and running. There are numerous threads and references to wicd, particularly in the Slackware forum.

Likewise, there are many threads on how to properly configure rc.inet1.conf.

I'll let you take it from here, and if you get bogged down somewhere, we'll go from there.

Edit: the previous poster is correct in how you would manually configure your wireless card, but going with one of the methods I've addressed will automate the process for future bootups.

cheers,

Last edited by mrclisdue; 02-19-2009 at 10:32 PM.
 
Old 02-19-2009, 10:32 PM   #6
Phunkedelik
LQ Newbie
 
Registered: Feb 2009
Location: alberta canada
Distribution: archlinux
Posts: 19

Rep: Reputation: 2
can he run iwlist scan? if so its just a matter of configuration. i personally like to use netcfg to connect.
 
Old 02-19-2009, 10:40 PM   #7
trnz$mr
Member
 
Registered: Oct 2008
Posts: 121

Original Poster
Rep: Reputation: 15
Awesome. Thanks.

but right now I'm trying to find the full name of the wicd...tgz. you said something that it's located in the /extra directory. Is that what /etc is? Because I didn't see it in there? But I do know that my shell-Konsole is recognizing it somewhat. It said:

Quote:
Cannot install wicd: package does not end in .tgz
Thanks for putting me back on track
 
Old 02-19-2009, 10:46 PM   #8
trnz$mr
Member
 
Registered: Oct 2008
Posts: 121

Original Poster
Rep: Reputation: 15
What would I configure if I ran "iwlist scan"?

I get this:
Quote:
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning.

wlan0 Scan completed :

Cell 05 - Address: 00:18:F8:E9:9B:62
ESSID:"FOSHO"
Mode:Master
Channel:11
Frequency:2.462 GHz (Channel 11)
Quality=83/100 Signal level:-51 dBm Noise level=-127 dBm
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:tsf=000000399ec03189
Extra: Last beacon: 1584ms ago
I noticed that my wireless card scanned something. I should connect to Cell 05. Because that's my router. How do I go about doing that?

Last edited by trnz$mr; 02-19-2009 at 10:48 PM.
 
Old 02-19-2009, 10:53 PM   #9
Phunkedelik
LQ Newbie
 
Registered: Feb 2009
Location: alberta canada
Distribution: archlinux
Posts: 19

Rep: Reputation: 2
well to configure manually and connect you would have to iwconfig wlan0 essid "FOSHO" then iwconfig wlan0 ap 00:18:F8:E9:9B:62 then iwconfig wlan0 key yourkey and finally ifconfig wlan0 up and dhcpcd wlan0 im assuming

with netcfg you can set it to do all of this on startup
 
Old 02-19-2009, 10:56 PM   #10
trnz$mr
Member
 
Registered: Oct 2008
Posts: 121

Original Poster
Rep: Reputation: 15
Quote:
with netcfg you can set it to do all of this on startup
netcfg sounds great but my Konsole doesn't recognize it as a command
 
Old 02-19-2009, 11:03 PM   #11
Phunkedelik
LQ Newbie
 
Registered: Feb 2009
Location: alberta canada
Distribution: archlinux
Posts: 19

Rep: Reputation: 2
heh try installing it first a quick google should suffice
 
Old 02-19-2009, 11:05 PM   #12
Phunkedelik
LQ Newbie
 
Registered: Feb 2009
Location: alberta canada
Distribution: archlinux
Posts: 19

Rep: Reputation: 2
ill also give you the run down... if you want to connect to a wireless network say if you left ur house and are at the mall you first scan by using iwlist scan then you set all of the iwconfig settings then you connect

if you want to connect to you home network you will likely run netcfg "name"
 
Old 02-19-2009, 11:15 PM   #13
trnz$mr
Member
 
Registered: Oct 2008
Posts: 121

Original Poster
Rep: Reputation: 15
Thanks for the "netcfg" I downloaded and untared the thing but it won't seem to install. Is there a particular designation folder i need to put it in before it installs? Also, is the command "install" good enough to install it?


Quote:
root@blah:~/Desktop# install gnome-netcfg-0.7
install: missing destination file operand after `gnome-netcfg-0.7'
Try `install --help' for more information.
that was the error message i got in my konsole
 
Old 02-19-2009, 11:19 PM   #14
trnz$mr
Member
 
Registered: Oct 2008
Posts: 121

Original Poster
Rep: Reputation: 15
You know what I bet you I downloaded from the wrong source. I got it from sourceforge.net. good site, I think, but I'm using KDE and not gnome. Do you think that's the problem?
 
Old 02-20-2009, 01:47 AM   #15
Phunkedelik
LQ Newbie
 
Registered: Feb 2009
Location: alberta canada
Distribution: archlinux
Posts: 19

Rep: Reputation: 2
well.. im not an expert in your distro. but netcfg does require a conf file
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 03:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration