LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-15-2004, 02:20 AM   #1
lifetaster
LQ Newbie
 
Registered: Feb 2004
Location: Singapore
Distribution: HP-UX
Posts: 29

Rep: Reputation: 15
what to do next after "tar"?


Now trying to install a new driver for my onboard (ASUS P4C800) lan.

First of all I download the driver 3c2000.tar.gz
then the command followed,
# tar xvzf 3c2000.tar.gz

what to do next? should I rebuild the kernel?
How to get the new driver work?

(This is the second post due to the same problem,
problem can't be solved even got help from some kind guys.)
 
Old 02-15-2004, 02:35 AM   #2
quietguy47
Member
 
Registered: Mar 2003
Location: Everett
Distribution: Slackware
Posts: 794

Rep: Reputation: 34
As user type:
$ tar xvzf 3c2000.tar.gz
$ cd 3c2000
$ ./configure
$ make
$ su -c
# make install
 
Old 02-15-2004, 02:47 AM   #3
lifetaster
LQ Newbie
 
Registered: Feb 2004
Location: Singapore
Distribution: HP-UX
Posts: 29

Original Poster
Rep: Reputation: 15
after $ ./configure
it showed that there is no such file or directory.
 
Old 02-15-2004, 02:54 AM   #4
quietguy47
Member
 
Registered: Mar 2003
Location: Everett
Distribution: Slackware
Posts: 794

Rep: Reputation: 34
then try just make install after ./configure
 
Old 02-15-2004, 02:55 AM   #5
lifetaster
LQ Newbie
 
Registered: Feb 2004
Location: Singapore
Distribution: HP-UX
Posts: 29

Original Poster
Rep: Reputation: 15
thanks but when I typed $./configure [enter]
it shows no such file or dir.

Last edited by lifetaster; 02-15-2004 at 03:48 AM.
 
Old 02-15-2004, 05:51 AM   #6
quietguy47
Member
 
Registered: Mar 2003
Location: Everett
Distribution: Slackware
Posts: 794

Rep: Reputation: 34
http://www.linuxquestions.org/questi...03/11/1/112455
 
Old 02-15-2004, 09:16 AM   #7
lifetaster
LQ Newbie
 
Registered: Feb 2004
Location: Singapore
Distribution: HP-UX
Posts: 29

Original Poster
Rep: Reputation: 15
first of all, i am not quite sure what i t means by "Make sure that the kernel source is installed in /usr/src/linux or /usr/src/linux-2.4." what is the mentioned kernel source here?

I just skipped to the steps followed, till "$make load" I got a long error msg which stopped from proceeding the left instructions.

error msg:

gcc: /usr/src/linux-2.4/include/linux/version.h: No such file or directory
gcc: no input files
gcc: /usr/src/linux-2.4/include/linux/autoconf.h: No such file or directory
gcc: no input files
In file included from /usr/include/linux/prefetch.h:13,
from /usr/include/linux/list.h:6,
from /usr/include/linux/module.h:11,
from skge.c:344:
/usr/include/asm/processor.h:55: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/asm/processor.h:55: error: requested alignment is not a constant
In file included from /usr/include/linux/module.h:297,
from skge.c:344:
/usr/include/linux/version.h:2:2: #error "======================================================="
/usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
/usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
/usr/include/linux/version.h:5:2: #error ""
/usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
/usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
/usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the"
/usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
/usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
/usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
/usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13:2: #error ""
/usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
/usr/include/linux/version.h:15:2: #error ""
/usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
/usr/include/linux/version.h:17:2: #error ""
/usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exists and points to"
/usr/include/linux/version.h:20:2: #error " the matching kernel source directory"
/usr/include/linux/version.h:21:2: #error ""
/usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to"
/usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h"
/usr/include/linux/version.h:24:2: #error ""
/usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following"
/usr/include/linux/version.h:26:2: #error " compiler option to use the correct include files:"
/usr/include/linux/version.h:27:2: #error ""
/usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/include"
/usr/include/linux/version.h:29:2: #error ""
/usr/include/linux/version.h:30:2: #error " instead of"
/usr/include/linux/version.h:31:2: #error ""
/usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
/usr/include/linux/version.h:33:2: #error ""
/usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordingly."
/usr/include/linux/version.h:35:2: #error "======================================================="
In file included from skge.c:344:
/usr/include/linux/module.h:299: error: syntax error before "UTS_RELEASE"
In file included from /usr/include/linux/mm.h:12,
from /usr/include/linux/slab.h:14,
from /usr/include/linux/proc_fs.h:5,
from skge.c:346:
/usr/include/linux/mmzone.h:44: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/linux/mmzone.h:44: error: requested alignment is not a constant
In file included from h/skdrv1st.h:96,
from skge.c:347:
/usr/include/linux/version.h:2:2: #error "======================================================="
/usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
/usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
/usr/include/linux/version.h:5:2: #error ""
/usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
/usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
/usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the"
/usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
/usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
/usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
/usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13:2: #error ""
/usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
/usr/include/linux/version.h:15:2: #error ""
/usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
/usr/include/linux/version.h:17:2: #error ""
/usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exists and points to"
/usr/include/linux/version.h:20:2: #error " the matching kernel source directory"
/usr/include/linux/version.h:21:2: #error ""
/usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to"
/usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h"
/usr/include/linux/version.h:24:2: #error ""
/usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following"
/usr/include/linux/version.h:26:2: #error " compiler option to use the correct include files:"
/usr/include/linux/version.h:27:2: #error ""
/usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/include"
/usr/include/linux/version.h:29:2: #error ""
/usr/include/linux/version.h:30:2: #error " instead of"
/usr/include/linux/version.h:31:2: #error ""
/usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
/usr/include/linux/version.h:33:2: #error ""
/usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordingly."
/usr/include/linux/version.h:35:2: #error "======================================================="
In file included from h/skdrv1st.h:147,
from skge.c:347:
/usr/include/linux/version.h:2:2: #error "======================================================="
/usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
/usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
/usr/include/linux/version.h:5:2: #error ""
/usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
/usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
/usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the"
/usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
/usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
/usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
/usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13:2: #error ""
/usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
/usr/include/linux/version.h:15:2: #error ""
/usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
/usr/include/linux/version.h:17:2: #error ""
/usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exists and points to"
/usr/include/linux/version.h:20:2: #error " the matching kernel source directory"
/usr/include/linux/version.h:21:2: #error ""
/usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to"
/usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h"
/usr/include/linux/version.h:24:2: #error ""
/usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following"
/usr/include/linux/version.h:26:2: #error " compiler option to use the correct include files:"
/usr/include/linux/version.h:27:2: #error ""
/usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/include"
/usr/include/linux/version.h:29:2: #error ""
/usr/include/linux/version.h:30:2: #error " instead of"
/usr/include/linux/version.h:31:2: #error ""
/usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
/usr/include/linux/version.h:33:2: #error ""
/usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordingly."
/usr/include/linux/version.h:35:2: #error "======================================================="
In file included from h/skdrv1st.h:154,
from skge.c:347:
/usr/include/linux/version.h:2:2: #error "======================================================="
/usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
/usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
/usr/include/linux/version.h:5:2: #error ""
/usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
/usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
/usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the"
/usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
/usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
/usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
/usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13:2: #error ""
/usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
/usr/include/linux/version.h:15:2: #error ""
/usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
/usr/include/linux/version.h:17:2: #error ""
/usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exists and points to"
/usr/include/linux/version.h:20:2: #error " the matching kernel source directory"
/usr/include/linux/version.h:21:2: #error ""
/usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to"
/usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h"
/usr/include/linux/version.h:24:2: #error ""
/usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following"
/usr/include/linux/version.h:26:2: #error " compiler option to use the correct include files:"
/usr/include/linux/version.h:27:2: #error ""
/usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/include"
/usr/include/linux/version.h:29:2: #error ""
/usr/include/linux/version.h:30:2: #error " instead of"
/usr/include/linux/version.h:31:2: #error ""
/usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
/usr/include/linux/version.h:33:2: #error ""
/usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordingly."
/usr/include/linux/version.h:35:2: #error "======================================================="
In file included from /usr/include/asm/hardirq.h:6,
from /usr/include/linux/interrupt.h:46,
from h/skdrv1st.h:161,
from skge.c:347:
/usr/include/linux/irq.h:65: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/linux/irq.h:65: error: requested alignment is not a constant
In file included from /usr/include/linux/interrupt.h:46,
from h/skdrv1st.h:161,
from skge.c:347:
/usr/include/asm/hardirq.h:16: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/asm/hardirq.h:16: error: requested alignment is not a constant
In file included from h/skdrv1st.h:161,
from skge.c:347:
/usr/include/linux/interrupt.h:129: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/linux/interrupt.h:129: error: requested alignment is not a constant
In file included from h/skdrv1st.h:166,
from skge.c:347:
/usr/include/linux/netdevice.h:165: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/linux/netdevice.h:165: error: requested alignment is not a constant
In file included from h/skdrv1st.h:166,
from skge.c:347:
/usr/include/linux/netdevice.h:517: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/linux/netdevice.h:517: error: requested alignment is not a constant
In file included from skge.c:347:
h/skdrv1st.h:172:26: net/checksum.h: No such file or directory
skge.c: In function `skge_probe':
skge.c:525: warning: integer constant is too large for "long" type
skge.c:644: error: `proc_net' undeclared (first use in this function)
skge.c:644: error: (Each undeclared identifier is reported only once
skge.c:644: error: for each function it appears in.)
skge.c:791:42: missing binary operator before token "("
skge.c: In function `skge_cleanup_module':
skge.c:986: error: `proc_net' undeclared (first use in this function)
skge.c:2039:41: missing binary operator before token "("
skge.c:2143:41: missing binary operator before token "("
skge.c:2199:41: missing binary operator before token "("
skge.c:2351:41: missing binary operator before token "("
skge.c:2442:41: missing binary operator before token "("
skge.c:2842:41: missing binary operator before token "("
skge.c:2936:41: missing binary operator before token "("
make: *** [skge.o] Error 1
 
Old 02-15-2004, 09:26 AM   #8
HoosTrax
Member
 
Registered: Feb 2004
Distribution: Red Hat 9.0/Windows XP
Posts: 55

Rep: Reputation: 15
Is the dash before the command options optional? I thought it had to be:
# tar -xvzf 3c2000.tar.gz

Maybe try ./INSTALL?

Or cd to the folder, then cd src, then make, then make install?

What does ls say is in the directory?

Last edited by HoosTrax; 02-15-2004 at 09:31 AM.
 
Old 02-15-2004, 10:03 AM   #9
lifetaster
LQ Newbie
 
Registered: Feb 2004
Location: Singapore
Distribution: HP-UX
Posts: 29

Original Poster
Rep: Reputation: 15
I think the - is opt. I checked the instructions from the driver cd.
 
Old 02-15-2004, 10:21 AM   #10
quietguy47
Member
 
Registered: Mar 2003
Location: Everett
Distribution: Slackware
Posts: 794

Rep: Reputation: 34
Quote:
first of all, i am not quite sure what i t means by "Make sure that the kernel source is installed in /usr/src/linux or /usr/src/linux-2.4." what is the mentioned kernel source here?
Go to /usr/src and make sure that linux or linux-2.4.xx is there.
1. Make sure that the kernel source is installed in /usr/src/linux
or /usr/src/linux-2.4.
2. Type tar zxvf 3c2000.tar.gz(the - is not necessary)
3. Type cd 3c2000
If you are using SuSE:
Note: on SuSE systems since 7.1, you will have to execute the
following commands before running make:

cp /boot/vmlinuz.version.h /usr/src/linux/include/linux/version.h
cp /boot/vmlinuz.autoconf.h /usr/src/linux/include/linux/autoconf.h
4. Type insmod 3c2000.o
Something like the following will be added to /var/log/messages:

Jan 22 19:31:19 localhost kernel: 3C2000: 3Com Gigabit NIC Driver Version A08
Jan 22 19:31:19 localhost kernel: Copyright (C) 2003 3Com Corporation.
Jan 22 19:31:19 localhost kernel: Copyright (C) 2003 Marvell.
Jan 22 19:31:19 localhost kernel: eth0: 3Com Gigabit NIC (3C2000)

Depending on your configuration, the OS may then automatically bring the
interface up and request an address from a DHCP server. If it does not,
bring the interface up with the command:

ifconfig eth0 up

You may have to substitue 'eth0' for your actual interface if you have
more than one ethernet NIC installed.

If your system is not configured for DHCP, you can assign an IP address
with the command:

ifconfig eth0 a.b.c.d

Where a.b.c.d is the IP address that you wish to use. Again, eth0 may
be different depending on your system configuration.

Configuring the Driver
------------------------

The 3C2000 driver supports various options, which can be supplied
as command line arguments to the 'insmod' command or in the
/etc/modules.conf file. You may specify more than one option.
Unless otherwise stated, all settings take the form of:

=value [,value...]

If you use the modules.conf file to load the driver at boot time,
include the word "options" when configuring the driver.

For example:
options 3c2000 DupCap_A=Full

If you use command line 'insmod', do not include the word "option"
when configuring the driver.

For example:
insmod 3c2000.o DupCap_A=Full


The following options are supported:

OPTION: Speed_A
Selects the speed of Port A of the NIC.

"Auto" - Automatic Resolution
"10" - 10MBPS
"100" - 100MBPS
"1000" - 1GIG

OPTION: DupCap_A
Selects the duplex capabilities of Port A of the NIC.

"Full" - Full Duplex
"Half" - Half Duplex
"Both" - Both Half Duplex & Full Duplex
 
Old 02-15-2004, 11:34 AM   #11
lifetaster
LQ Newbie
 
Registered: Feb 2004
Location: Singapore
Distribution: HP-UX
Posts: 29

Original Poster
Rep: Reputation: 15
quietbuy47, I've read instruction from the driver cd as well.
but the problem is when I went to step 4,
with $make load
the error msg appeared as give above
with $insmod 3c2000.o
also another error msg appeared.

btw, I am using Mandrake 9.2
 
Old 02-15-2004, 07:52 PM   #12
quietguy47
Member
 
Registered: Mar 2003
Location: Everett
Distribution: Slackware
Posts: 794

Rep: Reputation: 34
Are you 'root' or 'user' when typing these commands?
 
Old 02-15-2004, 11:15 PM   #13
lifetaster
LQ Newbie
 
Registered: Feb 2004
Location: Singapore
Distribution: HP-UX
Posts: 29

Original Poster
Rep: Reputation: 15
actually I tried 'user' as well as 'root'
if i try ./INSTALL or insmod 3c2000.o
a msg "... no such file or dir..." appeared.

Last edited by lifetaster; 02-16-2004 at 08:04 AM.
 
Old 03-01-2004, 01:53 PM   #14
MadTurki
Member
 
Registered: Nov 2003
Location: Toronto
Distribution: RedHat 9, Mandrake 10, OS X
Posts: 114

Rep: Reputation: 15
Wow... Okay, so I'm using RH9 as well and install the same driver. Use redhat-config-pacages and make sure you have the kernel source code installed. Run your up2date, then un-tar that file and go into the 3c2000 folder. Then do an "su - root" (oops - go back to that folder) and then do a "make load". That should be it. Dont use ./configure.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
bash script: using "select" to show multi-word options? (like "option 1"/"o zidane_tribal Programming 7 12-19-2015 01:03 AM
what is "sticky bit mode" , "SUID" , "SGID" augustus123 Linux - General 10 08-03-2012 04:40 AM
Telling people to use "Google," to "RTFM," or "Use the search feature" Ausar General 77 03-21-2010 11:26 AM
"Xlib: extension "XFree86-DRI" missing on display ":0.0"." zaps Linux - Games 9 05-14-2007 03:07 PM
getting error during "tar -xvzf filename.tar.gz" b0nd Linux - Newbie 11 04-23-2005 08:50 PM


All times are GMT -5. The time now is 10:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration