LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-07-2003, 10:48 PM   #1
mahsan
LQ Newbie
 
Registered: Sep 2003
Posts: 4

Rep: Reputation: 0
Unhappy What to change in XF86Config file


Hi .

I'm new to Linux & installed RH9 , I want to change my screen resolution 1024x786. I tried my best through the display setting it keeps on restarting & comes to same old. I have my XF86Config file here ..Plz make the requied changes & send it back to change the screen resolution.

Thanks.

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell E551c"
DisplaySize 280 210
HorizSync 30.0 - 54.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel 845"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 10-08-2003, 12:09 AM   #2
jayakrishnan
Member
 
Registered: Feb 2002
Location: India
Distribution: Slacky 12.1, XP
Posts: 992

Rep: Reputation: 30
try the redhat-config-xfree86 command
 
Old 10-08-2003, 12:36 AM   #3
mahsan
LQ Newbie
 
Registered: Sep 2003
Posts: 4

Original Poster
Rep: Reputation: 0
the changes which are made with redhat-config-xfree86 commad is not working , asking to restart. When restarted gives some error & comes back to same old stuff . What to do ??
 
Old 10-08-2003, 12:52 AM   #4
slackmagic
Member
 
Registered: Aug 2003
Distribution: Slackware
Posts: 253

Rep: Reputation: 32
hi mahsan,

you haven't told us what resolution you want

but I can tell you how you can go ahead and change to the desired resolution by yourself

Quote:
Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
I've MARKED the line that you need to edit by yourself with the list of desired resolutions.

By your [current] config, you have 1024*768, 800*600 and 640*480 available at this moment. You can switch between them by using the key-sequence:

CTRL + ALT + -
or
CTRL + ALT + +

let me know if you need more help with this!


Last edited by slackmagic; 10-08-2003 at 12:56 AM.
 
Old 10-08-2003, 03:48 AM   #5
jayakrishnan
Member
 
Registered: Feb 2002
Location: India
Distribution: Slacky 12.1, XP
Posts: 992

Rep: Reputation: 30
hey retiredsoldier nice tip but when i tried doing that the screen went blank
 
Old 10-08-2003, 07:08 AM   #6
slackmagic
Member
 
Registered: Aug 2003
Distribution: Slackware
Posts: 253

Rep: Reputation: 32
hi there,

well it depends on your XF86Config file. If there aren't any resolutions listed besides the one that you normally use, then I believe that's what happens.

However, I never had any problems with resolutions and I use 2 different ones (1600*1200 and 800*600) - I switch between them probably 10 times a day

check your XF86Config to see if you have more than 1 MODE listed...

hope this helps
 
Old 02-25-2004, 08:28 PM   #7
jamv.co
LQ Newbie
 
Registered: Feb 2004
Location: Bucaramanga, Colombia
Distribution: Red Hat 9
Posts: 2

Rep: Reputation: 0
Lightbulb Re: What to change in XF86Config file

Hi...
 
Old 02-25-2004, 08:35 PM   #8
jamv.co
LQ Newbie
 
Registered: Feb 2004
Location: Bucaramanga, Colombia
Distribution: Red Hat 9
Posts: 2

Rep: Reputation: 0
Lightbulb Re: What to change in XF86Config file

Hi... I used to have the same problem trying to get the 1024x768 display size in a Dell's E551c monitor. Im using a Optiplex GX260. An the video card its an Intel 845. I tryed everithing and nothig works.

Finally... I change the BIOS configuration, and the problem was that there were no enough RAM for the card. So I put a little more RAM... like 8MB and thats work for me.
 
Old 02-25-2004, 09:05 PM   #9
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
May be the refresh rate is not correct. This part:

Quote:
Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell E551c"
DisplaySize 280 210
HorizSync 30.0 - 54.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection
You should refer to your monitor documentation for correct refresh rate, or may be it is somewhere in the back of your monitor.
 
Old 02-25-2004, 11:39 PM   #10
M9595
LQ Newbie
 
Registered: Feb 2004
Posts: 1

Rep: Reputation: 0
Ok, I followed this thread to the bottom..and pretty much followed it through to the end thinking I was going to find my answer; so here I am appending...simply to keep this thread complete.

I just installed Fedora everything identified fine. It appears my desktop is using the maximum refresh rate of 85 (I know this since Windows mis aligns the screen at that refresh rate & the same appears to be the case in Fedora). I need to set the refresh rate for a patricular "Screen" to 75...how can it be done? I do not want to simply limit all the fresh rates to 75 by modifying the "Monitor" section.
 
Old 02-26-2004, 01:34 AM   #11
sharpie
Member
 
Registered: Jan 2004
Location: California
Distribution: Slackware 10.1
Posts: 190

Rep: Reputation: 30
For the people who are trying to set a different resolution, you might need to add some modelines if just adding the modes doesn't work. You can find out your modelines by searching for someone elses XF86Config file who has the same monitor as you, or getting the read-edid package, google it. It's imortant you set the right modelines, although I haven't heard of anybody's monitor being destroyed due to using incorrect modelines.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
where is the XF86config-4 or XF86config file in the fedora? u2911 Fedora 4 07-24-2004 08:38 PM
xf86config woes -- display won't change dpp777 Linux - Hardware 2 05-25-2004 04:38 PM
can't login to GNOME as acct's created before XF86Config change? morrolan Linux - Software 7 01-16-2004 06:08 AM
how do i change the resoltution in XF86Config? andym Linux - Newbie 1 04-16-2003 06:52 AM
Can i see someone XF86Config File? Kane Linux - Software 1 08-18-2002 11:00 AM


All times are GMT -5. The time now is 05:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration