LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-27-2014, 02:22 PM   #1
jyunker
Member
 
Registered: Aug 2009
Posts: 167

Rep: Reputation: 0
What provides libgpg-error.a


What rpm package for Centos 6.5, 64 bit provides the file

libgpg-error.a

?

I keep getting this messsage when configuring aide version 0.15.

Code:
checking for gpg_strerror in -lgpg-error... no
configure: error: You need to have libgpg-error.a installed to use libgcrypt.
I ran a locate and a find on my computer and

libgpg-error.a

is not there.

I must install it.

What package provides it. The sudo yum provides command is not helpful

Thanks.

R,


jyunker
 
Old 03-27-2014, 02:53 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153
The package providing libgpg-error.a , libgpg-error.so is 'libgpg-error-devel'.

'libgpg-error-devel' is available from ATrpms :
http://atrpms.net/documentation/install/
... as a repo for RHEL6 and/or Scientific Linux SL6.

! The recommendation is that you add this repo temporarily only,
as it is not compatible with "CentOS.repo" or epel.repo !

Package overview http://packages.atrpms.net/dist/el6/
>>> http://packages.atrpms.net/dist/el6/libgpg-error/

-
 
Old 03-27-2014, 03:15 PM   #3
jyunker
Member
 
Registered: Aug 2009
Posts: 167

Original Poster
Rep: Reputation: 0
libgcrypt

Please elaborate on this. I am confused from this link.

http://pkgs.org/centos-6/centos-x86_...86_64.rpm.html

It seems thta libgcrypt.a is not available for Centos 6.5, 64 bit which I use.

It is availbale for other flavors of linu, but not Centos or RedHat.
 
Old 03-27-2014, 03:16 PM   #4
jyunker
Member
 
Registered: Aug 2009
Posts: 167

Original Poster
Rep: Reputation: 0
libgcrypt.a

Please elaborate on this.

I am confused from this link.

http://pkgs.org/centos-6/centos-x86_...86_64.rpm.html

It seems that libgcrypt.a is not available for Centos 6.5, 64 bit which I use.

It is available for other flavors of linux, but not Centos or RedHat.

Any help appreciated. Thanks in advance.

R,

jyunkeer
 
Old 03-27-2014, 03:47 PM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153
#3 - #4 .

The same : Use an ATrpms package. Still : At your own risk.

Repeat, see post #2 http://packages.atrpms.net/dist/el6/
>>> libgcrypt > http://packages.atrpms.net/dist/el6/libgcrypt/
>>> libgcrypt-devel-1.4.0-15.el6.x86_64.rpm

The safe way : # yum install aide

-
 
Old 03-27-2014, 04:05 PM   #6
jyunker
Member
 
Registered: Aug 2009
Posts: 167

Original Poster
Rep: Reputation: 0
error on ./configure

Oaky you have talked me out of using that way. I will now try to compile

libgcrypt.a from a tar.gz file.

However, when I did that I also got an error as shown:

Code:
configure: error: libgpg-error is needed.
                See ftp://ftp.gnupg.org/gcrypt/libgpg-error/ .
[root@james libgcrypt-1.6.1]# sudo yum install libgpg-error
Loaded plugins: downloadonly, fastestmirror, priorities, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: mirror.unl.edu
 * elrepo: ftp.cc.uoc.gr
 * epel: mirror.csclub.uwaterloo.ca
 * extras: centos.mirror.nac.net
 * rpmforge: mirror.nexcess.net
 * updates: mirror.pac-12.org
Setting up Install Process
Package libgpg-error-1.7-4.el6.x86_64 already installed and latest version
Nothing to do
I am only showing the output where the error is concerned. It says it needs

libgpg-error,

but that package is installed.

So what is it looking for and not finding?

Any help appreciated.


R,

jyunker
 
Old 03-27-2014, 04:30 PM   #7
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: CentOS 6 (pre-systemd)
Posts: 2,609

Rep: Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702Reputation: 702
libgpg-error and libgpg-error-devel are different packages.
 
1 members found this post helpful.
Old 03-27-2014, 05:02 PM   #8
jyunker
Member
 
Registered: Aug 2009
Posts: 167

Original Poster
Rep: Reputation: 0
They are both installed

Yes they are different files and they are both installed.

Code:
checking whether a -O flag munging is requested... yes
checking whether to enable AMD64 as(1) feature detection... yes
checking for gpg-error-config... /usr/bin/gpg-error-config
checking for GPG Error - version >= 1.11... no
configure: error: libgpg-error is needed.
                See ftp://ftp.gnupg.org/gcrypt/libgpg-error/ .
[root@james libgcrypt-1.6.1]# sudo yum install libgpg-error
Loaded plugins: downloadonly, fastestmirror, priorities, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: mirror.net.cen.ct.gov
 * elrepo: ftp.cc.uoc.gr
 * epel: less.cogeco.net
 * extras: mirror.anl.gov
 * rpmforge: mirror.nexcess.net
 * updates: centos.sonn.com
Setting up Install Process
Package libgpg-error-1.7-4.el6.x86_64 already installed and latest version
Nothing to do
[root@james libgcrypt-1.6.1]# sudo yum install libgpg-error-devel
Loaded plugins: downloadonly, fastestmirror, priorities, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: mirrors.bluehost.com
 * elrepo: ftp.cc.uoc.gr
 * epel: archive.linux.duke.edu
 * extras: centos.mirror.nac.net
 * rpmforge: mirror.nexcess.net
 * updates: centosi3.centos.org
Setting up Install Process
Package libgpg-error-devel-1.7-4.el6.x86_64 already installed and latest version
Nothing to do

Specifically what file(s) is it looking for here? The packages are installed, but maybe the file it seeks is not installed or it is
not in the path.


Thanks,

R,

jyunker
 
Old 03-27-2014, 05:31 PM   #9
jyunker
Member
 
Registered: Aug 2009
Posts: 167

Original Poster
Rep: Reputation: 0
I think I know what is wrong

I believe I see the error. It is looking for libgpg-error package that is later than 1.11.

Mine is 1.7. It is not new enough.

I installed from Centos rpm files (I have Centos 6.5, 64 bit)
So what do I do to get the packae in if the rpm one is only 1.7 and I need 1.11 at least?

I must uninstall the rpm package in install the *.tar.gz package that is equal to or later

than 1.11.

Is this the way? Is there an easier way say a patch?

ny help appreciated.


Thanks,

R
 
Old 03-28-2014, 09:42 AM   #10
jyunker
Member
 
Registered: Aug 2009
Posts: 167

Original Poster
Rep: Reputation: 0
libgpg-error.a put in /usr/local/lib/

I simply downloaded libgpg-error.tar.gz onto my system. The allows me to directly configure, make and make install
the system. I do use the slightly changed commands

./configure --enable-static

make

make install

on the system.

However, it puts libgpg-error.a into the directory /usr/local/lib/.

Everything is fine except there is a directory /usr/local/lib64/.

I have Centos 6.5, 64 bit. So why did it not put it there?

I have a native 64 bit system. I think it should be in /usr/local/lib64/.

Now I tried to determine if libgpg-error.a is 32 or 64 bit using the file command - nothing useful.

Why did it put it is /usr/local/lib/ instead of /usr/local/lib64/?

It would seem usr/local/lib64/ is where it should go.

I checked the config.log and it said everyting is 64 bit or so it appeared to me.

In the README and INSTALL files it said the file would wind up in /usr/local/lib/, but
again why?

Thanks in advance,

jyunker
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error 502 : Display Fatal Error Message, Error pushing image, dbpaCT failed! HaloCheng Linux - Newbie 1 09-12-2012 01:02 PM
[SOLVED] OPEN LDAP:-INSTALL STUCK WITH libgpg-error-1.0 DEPENDENCY linux_rhca Linux - Software 18 08-24-2011 03:08 AM
Sendmail: eocket wedge , 504 error , dsn error, mail relay connection error djcs Debian 0 03-03-2009 01:41 AM
Gentoo, problem when "emergeing" libgpg-error Snerkel Linux - Distributions 1 10-26-2004 09:46 AM
Gentoo libgpg-error-1.0 emerge problem ahh Linux - Software 2 09-21-2004 06:19 PM


All times are GMT -5. The time now is 08:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration