LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 05-30-2012, 07:43 AM   #1
omega341991
Member
 
Registered: May 2012
Posts: 39

Rep: Reputation: Disabled
what is the Linux terminal command to enable wireless?


There is an option in the taskbar in Ubuntu named "Enable Wireless"
How can i enable and disable this option from the terminal ?

I have already tried the commands

ifconfig interface_name up
ifconfig interface_name down

These have no effect whatsoever.

please reply
 
Old 05-30-2012, 09:41 AM   #2
r00t
LQ Newbie
 
Registered: May 2012
Posts: 23

Rep: Reputation: Disabled
You need to use iwconfig instead of ifconfig for wireless.
 
1 members found this post helpful.
Old 05-30-2012, 10:18 AM   #3
whysoserious
Member
 
Registered: May 2012
Location: London
Distribution: Debian and slackware for uni
Posts: 61

Rep: Reputation: Disabled
iwconfig then the interface name should do it. Are you using DHCP assignment or static?
 
Old 05-30-2012, 02:03 PM   #4
elliott678
Member
 
Registered: Mar 2005
Location: North Carolina
Distribution: Arch
Posts: 977

Rep: Reputation: 72
When you use the "Enable/Disable" wireless does it actually turn your card off or does it just disconnect from the router? If you want to turn off the card rfkill is what you want. I believe "rfkill block wifi" to disable and "rfkill unblock wifi" to enable should work.
 
1 members found this post helpful.
Old 06-01-2012, 12:01 AM   #5
omega341991
Member
 
Registered: May 2012
Posts: 39

Original Poster
Rep: Reputation: Disabled
When i use iwconfig , this is the error that i get


root@ubn1# iwconfig wlan0 down
iwconfig: unknown command "down"

If i dont give "down" ,it just lists the wireless devices


What should i do?
 
Old 06-01-2012, 06:16 AM   #6
whysoserious
Member
 
Registered: May 2012
Location: London
Distribution: Debian and slackware for uni
Posts: 61

Rep: Reputation: Disabled
What is the output of the ifconfig command and the iwlist command

Last edited by whysoserious; 06-01-2012 at 06:18 AM.
 
Old 06-01-2012, 02:00 PM   #7
hidoussi
LQ Newbie
 
Registered: May 2012
Location: ALGERIA
Posts: 14

Rep: Reputation: Disabled
Quote:
Originally Posted by omega341991 View Post
There is an option in the taskbar in Ubuntu named "Enable Wireless"
How can i enable and disable this option from the terminal ?

I have already tried the commands

ifconfig interface_name up
ifconfig interface_name down

These have no effect whatsoever.

please reply
try with this commande

for me i have debian and it's work

the command is: ifdown wlan0
 
Old 06-01-2012, 04:59 PM   #8
elliott678
Member
 
Registered: Mar 2005
Location: North Carolina
Distribution: Arch
Posts: 977

Rep: Reputation: 72
Those commands just disconnect the wireless, do you want to disconnect or actually turn the card off?
 
Old 06-04-2012, 12:46 AM   #9
omega341991
Member
 
Registered: May 2012
Posts: 39

Original Poster
Rep: Reputation: Disabled
It's workung now. Used a combination of rfkills and ifconfig
Rfkill refreshes the network and ifconfig down temporarily downs the network

Problem solved

Thanks for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How to enable command autocomplete by searching history in Linux LXer Syndicated Linux News 0 03-24-2012 07:11 PM
Wireless enable port of laptop not working in Linux(RHEL 5.3) abikkrishnan Linux - Networking 1 01-30-2012 08:50 AM
Wireless is not enable on my Redhat enterprise linux 5 box Ashish Sood Linux - General 10 02-02-2011 03:30 AM
Enable wireless in linux mint 9 isadora for e-machines m5312 laptop Doruletz Linux - Laptop and Netbook 8 09-11-2010 02:48 AM
[SOLVED] Make linux terminal transparent with terminal command? yooy Linux - Newbie 1 05-11-2010 04:24 AM


All times are GMT -5. The time now is 09:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration