LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-14-2011, 03:50 PM   #1
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,125

Rep: Reputation: 46
What is the device (/dev/?) to output audio?


kernel 2.6.21.5, slackware 12.0
alsa 1.0.14

Hi:
A program I have that generates audio uses /dev/dsp to output. In the output jack (machine rear panel) however I do not get anything. But the program gives me the choice to select another device. What device should I select to have audio through it? Also, /dev/dsp is linked to /dev/sound/dsp:
Code:
semoi@darkstar:/dev$ v dsp
lrwxrwxrwx 1 root root 9 2011-09-14 15:47 dsp -> sound/dsp
semoi@darkstar:/dev$ v sound
total 0
crw-rw--w- 1 root audio 14, 12 2011-09-14 15:47 adsp
crw-rw--w- 1 root audio 14,  4 2011-09-14 15:47 audio
crw-rw--w- 1 root audio 14,  3 2011-09-14 15:47 dsp
crw-rw--w- 1 root audio 14,  0 2011-09-14 15:47 mixer
crw-rw--w- 1 root audio 14,  1 2011-09-14 15:47 sequencer
crw-rw--w- 1 root audio 14,  8 2011-09-14 15:47 sequencer2
semoi@darkstar:/dev$

Thanks.
 
Old 09-15-2011, 03:12 AM   #2
vadiml
Member
 
Registered: Oct 2003
Posts: 42

Rep: Reputation: 19
You should check using following command:
Code:
lsmod | grep oss
that oss sound driver modules are loaded
 
1 members found this post helpful.
Old 09-15-2011, 07:37 PM   #3
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,125

Original Poster
Rep: Reputation: 46
Thanks for your post.

Code:
semoi@darkstar:~/STORE1/soft/linux$ lsmod|grep oss
snd_seq_oss            32896  0 
snd_seq_midi_event     10112  1 snd_seq_oss
snd_seq                50640  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            42784  0 
snd_mixer_oss          18048  1 snd_pcm_oss
snd_pcm                72068  3 snd_pcm_oss,snd_trident,snd_ac97_codec
snd_seq_device         10508  5 snd_seq_dummy,snd_seq_oss,snd_seq,snd_trident,snd_rawmidi
snd                    47204  13 snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_trident,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
semoi@darkstar:~/STORE1/soft/linux$
 
Old 09-16-2011, 02:58 AM   #4
vadiml
Member
 
Registered: Oct 2003
Posts: 42

Rep: Reputation: 19
Are you able to produce ANY sound on your system?
for example with [code]aplay somefile.wav[/aplay]

Can you check permissions on your /dev/snd/* ?

Can you try to run your program under sudo?
 
Old 09-16-2011, 05:58 AM   #5
Trickie
Member
 
Registered: Sep 2004
Posts: 38

Rep: Reputation: 23
Or check the that the alsa mixer is not muted.

Richard
 
Old 09-16-2011, 08:01 AM   #6
vadiml
Member
 
Registered: Oct 2003
Posts: 42

Rep: Reputation: 19
Wink

Quote:
Originally Posted by Trickie View Post
Or check the that the alsa mixer is not muted.

Richard
Well this one is from "Is you powercord connected to the wall socket" department
 
Old 09-16-2011, 08:14 AM   #7
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,125

Original Poster
Rep: Reputation: 46
My fault. Post #3 is wrong, belongs to another thread. The problem here was the program. Afterwards I could check /dev/dsp is okey. Sorry.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do you make "/dev/dsp1" the default Audio Output Device? lothario Linux - Software 1 02-16-2011 03:01 AM
no audio output device is installed Billy Makk General 9 12-10-2010 07:47 AM
audio output device changes to 'dummy output' Joshwaaa Linux - Software 1 04-02-2010 10:03 PM
oss audio output error: cannot open audio device (/dev/dsp)? Bug? Config error? brianpbarnes Linux - Software 1 04-25-2009 04:18 AM
Failed to open audio device (/dev/dsp): No such device stevesk Slackware 6 01-01-2009 06:29 AM


All times are GMT -5. The time now is 12:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration