LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-10-2002, 08:19 PM   #1
caid
Member
 
Registered: Dec 2002
Location: NZ
Distribution: slack current
Posts: 61

Rep: Reputation: 15
Unhappy (yet another) newbie with a linmodem


i know this has been asked 100s of times, but no matter how many threads i trawl through, i just don't geddit.

i installed RH8.0 yesterday (my first distro, dual-booted w/ Win98) & downloaded the right (I'm pretty sure it was right) rpm from www.heby.de/ltmodem.

it kept giving me an error when i tried to unpack it, so i downloaded the tarball, compiled & installed it.
i think it worked but don't quote me on that.

i didn't see any errors and nothing spat the dummy afterwards, but the modem still isn't being detected.

in language a day-old newbie would understand, could someone tell me what to do next?

thanks heaps

caid
 
Old 12-10-2002, 10:44 PM   #2
caid
Member
 
Registered: Dec 2002
Location: NZ
Distribution: slack current
Posts: 61

Original Poster
Rep: Reputation: 15
what do i do after installing the linmodem driver?

i have a lucent winmodem, works fine on COM3 in win98, but can't get it to install in rh8.

downloaded and installed the appropriate driver from www.heby.de/ltmodem but the modem still isn't being detected. what do i do next?

ta

caid
 
Old 12-11-2002, 01:46 AM   #3
isajera
Senior Member
 
Registered: Jun 2001
Posts: 1,635

Rep: Reputation: 45
linmodems are testy things... there isn't much good news we can give you about them. if you're getting any error messages or specific problems, let us know, and we'll help as much as we can. make sure you have the driver number correct - it needs to be exact. iirc, the heby driver comes with a HOWTO - are you getting stuck at any point in it?
 
Old 12-11-2002, 02:52 AM   #4
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Rep: Reputation: 146Reputation: 146
try the device tab in kppp dialer

my modem did not show up as /dev/modem or as tty0 but works fine as tty1.

Hope this helps....




...can't believe I actually paid for a copy of windows
 
Old 12-11-2002, 03:56 AM   #5
KnightAbel
Member
 
Registered: Sep 2002
Location: Kaysville, UT USA
Distribution: Red Hat Linux, Slackware
Posts: 242

Rep: Reputation: 30
This may help you: http://linuxnewbie.org/nhf/Modems/Co...PCI_Modem.html
 
Old 12-11-2002, 03:58 AM   #6
annehoog
Member
 
Registered: Jan 2002
Location: Nederland
Distribution: RH 8 Psyche and Debian Woody
Posts: 373

Rep: Reputation: 30
If you dual boot:
/dev/modem is a link to where the modem actually is which is:
tty0 (in windows com 1)
tty1 (in windows com 2)

etc.
That might give you a clue...

Anne
 
Old 12-11-2002, 04:56 AM   #7
caid
Member
 
Registered: Dec 2002
Location: NZ
Distribution: slack current
Posts: 61

Original Poster
Rep: Reputation: 15
thanks for the reply

i just compiled the newest source file thingy from heby.de and installed the modules and all *seemed* to go well,

ls -l /dev/modem

says the modem is linked to ttyLT0, which it's supposed to do i think, according to the how-to manual at the site.

but it still isn't detected in the internet config wizard, and when i type in /dev/ttyLT0 in the appropriate gap on the next screen, and go to activate the modem, it just says "unable to activate device" or something of the like.

am i missing a step/several steps, or has something gone wrong with the driver install?
 
Old 12-11-2002, 05:05 AM   #8
caid
Member
 
Registered: Dec 2002
Location: NZ
Distribution: slack current
Posts: 61

Original Poster
Rep: Reputation: 15
thanks for the replies guys, but i'm still stuck

ls -l /dev/modem

says the modem is linked to ttyLT0

to be honest, i don't know what that means or what to do from there.

if i try putting ttyLT0 in the appropriate box in the internet config wizard (it unsurprisingly, isn't in the drop-down box) and activate the device it says "cannot activate the device" or something of the like.

how do i get from ttyLT0 to ttySx?

sorry, i need step by step instructions, i'm a total and utter noob.
 
Old 12-11-2002, 05:11 AM   #9
annehoog
Member
 
Registered: Jan 2002
Location: Nederland
Distribution: RH 8 Psyche and Debian Woody
Posts: 373

Rep: Reputation: 30
You could try to make a symlink from ttyLTO to ttySx
ln -s /dev/ttyLTO /dev/TTySx

You could also try wvdial and see wheter it detects the modem. It searches for modems on the first run.
(wvdial btw is the very program the RH dialer with gui runs on)

Anne
 
Old 12-11-2002, 07:29 AM   #10
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
Hi,

Taken from: http://www.heby.de/ltmodem

The modem drivers are NOT loaded on boot up, but are loaded on demand (typically by ppp initiation), thanks to the lines added by ./autoload to /etc/modules.conf:
# lt_drivers: autoloading and insertion parameter usage
alias char-major-62 lt_serial
alias /dev/tts/LT0 lt_serial
alias /dev/modem lt_serial
# The next line is a syntax example, rarely needed, to automate parameter usage during lt_drivers insertion.
# options lt_modem vendor_id=0x115d device_id=0x0420 Forced=3,0x130,0x2f8
# section for lt_drivers ends

did you alter /etc/modules.conf?
 
Old 12-11-2002, 02:49 PM   #11
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
when i set up an ltmodem a while back, the
directory where the code was had something
like ltinst1 and ltinst2, where one would set up
the module to autoload, and the device LT0 and
make a symlink "modem" pointing to it.
Look at the readme in the directory where you extracted
the code to see. i think you run build_module, then ltinst2, and
then you're done.
you access your modem by /dev/modem or
/dev/LT0

edit: i think its actually /dev/ttyLT0
put the whole device path in the box.
/dev/modem

Last edited by whansard; 12-11-2002 at 05:08 PM.
 
Old 12-11-2002, 03:42 PM   #12
isajera
Senior Member
 
Registered: Jun 2001
Posts: 1,635

Rep: Reputation: 45
i merged your two linmodem threads - please try to keep questions about the same problems in the same thread - it makes it easier to keep track of - ...


could you check what chipset your modem has? run 'lspci -vv', and post the results... that should tell you a bit more about the chipset, and which driver you need.

Last edited by isajera; 12-11-2002 at 09:24 PM.
 
Old 12-11-2002, 10:52 PM   #13
SML
Member
 
Registered: Dec 2002
Location: US
Distribution: ARCH
Posts: 376

Rep: Reputation: 30
Linmodems are simple ... I think the heby.de site is for Lucent winmodems.
(Lucent Apollo and Mars chipsets) Check first with lspci command - as someone above suggested.

1. In a terminal, type: uname -a
This will identify the exact kernel that you are running. ie when I installed
RH8.0, the kernel was 2.4.18-14. After I installed the Red Hat updates, this
included an update of the kernel. Using 'uname -a' now results in the
response 2.4.18-18.8.0.

2. Go to www.heby.de/ltmodem and select your Red Hat distribution. Select the latest drivers ie the set of 8.26a9. Find the correct rpm that matches your kernel and cpu. It will be either the 2.4.18-14 or 2.4.18-18.8.0 for RH8.0 and with your i686. The download is only about 350k.

3. Install the rpm with the following command as root:
rpm -ivh --force --nodeps ltmodem-kv_2.4.19_4GB-8.22a5-1.i386.rpm
(that was the filename for the SuSE driver, but replace the filename with the
driver you download.)

4. It should now be working - hopefully. Maybe restart the computer and try
using kppp. Set up your linmodem as /dev/modem. Should now be working.

5. If that fails, maybe have a look in the "System Settings" and "Network"
and set up the modem in there. Also maybe use the command: 'minicom -s' and setup the modem as /dev/modem in 'serial port setup'.
 
Old 12-11-2002, 10:59 PM   #14
SML
Member
 
Registered: Dec 2002
Location: US
Distribution: ARCH
Posts: 376

Rep: Reputation: 30
BTW - the files from heby.de are .rpm. This means that you do not have to unpack it or compile or make them. Just get go straight ahead and install it with the rpm command.

(The source of the file has already been compiled for your kernel by somebody else and subsequently converted it to a rpm. ... that is why there are so many rpm's on the heby.de website. You have to match the kernel.)

See my post above or read 'man rpm'.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help installing a linmodem rcmcghee Linux - Hardware 4 03-22-2005 03:15 PM
Linmodem driver installation problem seagreen Linux - Hardware 0 12-18-2004 05:07 AM
unpack linmodem driver greenlinux Linux - Hardware 9 10-11-2004 08:28 PM
Linmodem Driver? jcap Linux - Hardware 7 04-27-2004 08:44 PM
Cannot install linmodem driver. lcadwell Linux - Hardware 1 02-17-2003 02:48 PM


All times are GMT -5. The time now is 02:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration