LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-30-2007, 10:25 AM   #16
nebula010
LQ Newbie
 
Registered: Jun 2007
Posts: 12

Original Poster
Rep: Reputation: 0

OK, this worked:

./configure --x-includes=/usr/include/X11/X.h

But now it says it cant find the x libraries. Sheesh! Where are those?
 
Old 06-30-2007, 10:38 AM   #17
nebula010
LQ Newbie
 
Registered: Jun 2007
Posts: 12

Original Poster
Rep: Reputation: 0
double post
 
Old 06-30-2007, 12:36 PM   #18
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Do a "locate libX11" to find out.
 
Old 06-30-2007, 01:03 PM   #19
nebula010
LQ Newbie
 
Registered: Jun 2007
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Nylex
Do a "locate libX11" to find out.
Here's what I get:

Code:
/etc/cron.daily/mlocate.cron
/usr/bin/locate
/usr/lib/libX11.so
/usr/lib/libX11.so.6
/usr/lib/libX11.so.6.2.0
/usr/share/apps/ksgmltools2/docbook/xsl/params/htmlhelp.button.locate.xml
/usr/share/doc/libX11-1.0.0
/usr/share/doc/mlocate-0.14
/usr/share/doc/docbook-style-xsl-1.69.1/doc/html/htmlhelp.button.locate.html
/usr/share/doc/libX11-1.0.0/AUTHORS
/usr/share/doc/libX11-1.0.0/COPYING
/usr/share/doc/libX11-1.0.0/ChangeLog
/usr/share/doc/libX11-1.0.0/INSTALL
/usr/share/doc/libX11-1.0.0/NEWS
/usr/share/doc/libX11-1.0.0/README
/usr/share/doc/mlocate-0.14/AUTHORS
/usr/share/doc/mlocate-0.14/COPYING
/usr/share/doc/mlocate-0.14/README
/usr/share/doc/openldap-devel-2.3.19/drafts/draft-ietf-ldapext-locate-xx.txt
/usr/share/doc/selinux-policy-2.3.7/html/apps_slocate.html
/usr/share/locale/cs/LC_MESSAGES/mlocate.mo
/usr/share/man/man1/locate.1.gz
/usr/share/man/man3/XdbeAllocateBackBufferName.3x.gz
/usr/share/man/man3/XdbeDeallocateBackBufferName.3x.gz
/usr/share/man/man3p/posix_fallocate.3p.gz
/usr/share/man/man5/mlocate.db.5.gz
/usr/share/snmp/mib2c-data/generic-data-allocate.m2i
/var/lib/mlocate
/var/lib/mlocate/mlocate.db
/var/lib/mlocate/mlocate.db.LiOGVj
I added this to ./configure:
--x-libraries=/usr/lib/libX11

but got this error:

Code:
checking for X... libraries /usr/lib/libX11, headers /usr/include/X11/X.h
checking for IceConnectionNumber in -lICE... yes
checking for libXext... yes
checking for pthread_create in -lpthread... yes
checking for extra includes... no
checking for extra libs... no
checking for libz... configure: error: not found.
          Possibly configure picks up an outdated version
          installed by XFree86. Remove it from your system.

          Check your installation and look into config.log
 
Old 06-30-2007, 05:06 PM   #20
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Looks like you now need the development version of libz. This is in the zlib-devel package on my Fedora 7 install at work.
 
Old 06-30-2007, 10:58 PM   #21
nebula010
LQ Newbie
 
Registered: Jun 2007
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by btmiller
Looks like you now need the development version of libz. This is in the zlib-devel package on my Fedora 7 install at work.
yum says its already instaaled. this is turning out to be a serious p.i.t.a...
 
Old 07-01-2007, 02:01 AM   #22
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Maybe your installation is broken or something :/.
 
Old 07-01-2007, 02:04 AM   #23
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
Quote:
Originally Posted by nebula010
OK, this worked:

./configure --x-includes=/usr/include/X11/X.h

But now it says it cant find the x libraries. Sheesh! Where are those?
The include dir should be ./configure -x-includes=/usr/include/X11

X.h is the header file itself.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Displaying "MyComputer", "Trash", "Network Servers" Icons On A GNOME Desktop LXer Syndicated Linux News 0 04-02-2007 09:31 AM
Any way to get "Alice"; "Call of Duty" series and "Descent 3" to work? JBailey742 Linux - Games 13 06-23-2006 02:34 PM
LXer: Google "Summer of Code" includes embedded Linux projects LXer Syndicated Linux News 0 05-09-2006 05:21 AM
Kopete 0.10.3 "Can't find X includes" SuSE 9.3 kahlil88 Linux - Software 4 08-20-2005 01:36 AM
"Can't find X includes" when installing KDE-theme christian-s Linux - Software 3 01-15-2004 01:01 PM


All times are GMT -5. The time now is 07:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration