LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-20-2008, 10:14 AM   #1
Zeno McDohl
Member
 
Registered: Apr 2005
Location: Saratoga, NY
Distribution: Slackware
Posts: 316

Rep: Reputation: 30
What's wrong with vim?


A vim guide says
Quote:
Go from Normal mode to Insert mode by giving the command "i"
I open a file with vim, I press i, then I press down on the keypad to move down to another line... and it inserts a B. What's going on?
 
Old 05-20-2008, 10:28 AM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Are you sure it was in normal mode after you opened the file? Press ESC once or twice to make sure..

Another thing that could be is that it somehow don't get what your keyboard is like, or in other words, gives different output than what you'd expect. Well, I don't believe in that myself.. but anyway. First check that you're in normal mode.
 
Old 05-20-2008, 10:40 AM   #3
Zeno McDohl
Member
 
Registered: Apr 2005
Location: Saratoga, NY
Distribution: Slackware
Posts: 316

Original Poster
Rep: Reputation: 30
I hit ESC a few times, pressed i, then pressed down. It inserted a B again. Left is inserting a D, right is inserting a C, up is inserting an A.

The keyboard is fine everywhere else (Firefox, etc). Oh and if it matters I'm using PuTTy.
 
Old 05-20-2008, 11:06 AM   #4
whk
Member
 
Registered: Jun 2005
Posts: 202

Rep: Reputation: 35
On the very basic vi the insert mode does not have movement. You need to ESC to move.
If you want to get more options you may need to download vim-common to your vim-minimal.
ie Synaptic
hth & gl
 
Old 05-20-2008, 11:31 AM   #5
Maligree
Member
 
Registered: Mar 2008
Distribution: Gentoo, CentOS, Fedora, Arch
Posts: 231
Blog Entries: 1

Rep: Reputation: 42
Actually, just do..
Code:
:set nocompatible
..and it should be back to normal. You might want to add that to your .vimrc.

Last edited by Maligree; 05-20-2008 at 11:32 AM.
 
Old 05-20-2008, 11:32 AM   #6
vadkutya
Member
 
Registered: Apr 2008
Distribution: slackware 10.2
Posts: 117

Rep: Reputation: 16
that's right. your vim is completely in order. no navigation while in insert mode. modern flavors of vim however support even this. but it's a bad habit. once you are forced to do system maintenance on a unix system you'll know why.

vadkutya
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
VIM Users: Do you use VIM via console or gui? JMJ_coder Linux - General 48 04-16-2008 04:12 AM
Fortran - G95 - Wrong Syntax or wrong compiler settings laucian Programming 1 03-21-2008 11:18 AM
encryption with Vim (vim -x) mikshaw Linux - Software 2 03-07-2007 10:00 AM
LXer: Vim tips: Using Vim mappings and abbreviations LXer Syndicated Linux News 0 06-18-2006 02:54 PM
LXer: Cream for Vim - Making Vim more user friendly LXer Syndicated Linux News 0 06-18-2006 12:54 AM


All times are GMT -5. The time now is 08:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration