LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   wget & GNUTLS Installation Issue (required for Broadcom Wireless Chipset BCM43224) (http://www.linuxquestions.org/questions/linux-newbie-8/wget-and-gnutls-installation-issue-required-for-broadcom-wireless-chipset-bcm43224-906823/)

SkM007 10-06-2011 05:30 PM

wget & GNUTLS Installation Issue (required for Broadcom Wireless Chipset BCM43224)
 
Dear All,

i almost spent 3-4 hours in googling & "./configure"ing & what not... now i m lost & came here for help...

I am trying to install GNUTLS package but while doing the "./configure..." i am getting error
<<<
checking for P11_KIT... configure: error: Package requirements (p11-kit-1 >= 0.2) were not met:

No package 'p11-kit-1' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables P11_KIT_CFLAGS
and P11_KIT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
>>>

I tried to downloand p11-kit in both rpm & tar.gz format (p11-kit-0.7.tar.gz / p11-kit-0.6-1.fc17.x86_64.rpm)... though tar.gz package got installed without any error but still GNUTLS is giving the same error... & while installing .rpm package it got failed coz of following dependencies...
p11-kit-0.6-1.fc17.x86_64.rpm > dependency > libc.2.14
glibc.2.14 > dependency > glibc-common.2.93...x86_64

glibc...x86_64 got failed coz glibc is required... then i downloaded glibc-2.14.tar.gz & tried to install it but while doing ./configure it gave error that "you should consider different directory for configuration file..."

See, i have no idea what these glib's are for or that p-11-kit is (IT WILL BE GREAT IF ANYONE CAN EXPLAIN WHAT ARE THOSE glib's & p-11-kit FOR)... all i wanted to install Broadcom BCM43224 wireless chipset driver (I have a dell wireless card & its not working in RHEL 6.1 so i googled & found that i need my chipset's driver)... BCM43224 driver installation requires "wget" & wget needs GNUTLS thing...

Please help me in following things:
1. Installation of those glibs... (IF POSSIBLE explanation also...)
2. installation of GNUTLS

if anyone has installed BCM43224 or BCM43XX chipset driver, then update me on that...

Thanks in Advance...

knudfl 10-07-2011 03:01 AM

RHEL 5 ? RHEL 6 ?

All system packages are already present on your OS :
gnutls, glibc etc.

The parts you are missing : The development files.

Install the correct versions with your package manager :
glibc-devel glibc-headers kernel-headers kernel-devel gnutls-devel.

None of the above can use versions different from the system versions.

If you don't have a Redhat account and don't want to pay,
use a free version of RHEL : CentOS http://www.centos.org/
Or migrate RHEL to CentOS http://wiki.centos.org/HowTos/MigrationGuide
Look for ""Migration from RHEL5 to CentOS5"" etc.

.


All times are GMT -5. The time now is 11:05 AM.