LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-11-2010, 08:45 AM   #1
sephstorm
LQ Newbie
 
Registered: Aug 2010
Distribution: Fedora
Posts: 18

Rep: Reputation: 0
wget


I am trying to dl the files located here: http://good.net/dl/bd/CCCamp-2007/video/m4v/ using wget.

Now when I use the command wget -r -A .m4v http://good.net/dl/bd/CCCamp-2007/video/m4v/

I get the just a bunch of filefolders, but no files, ex."cccamp07-de-1845-Freifunk_und_Recht.m4v" but its a folder.

help?
 
Old 10-11-2010, 08:52 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,318

Rep: Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880
try "wget -r -m -l1 -H -A.m4v <website>". No space between the -A.m4v.
 
Old 10-11-2010, 08:57 AM   #3
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,603
Blog Entries: 25

Rep: Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981
Hi,

Quote:
Originally Posted by sephstorm View Post
I am trying to dl the files located here: http://good.net/dl/bd/CCCamp-2007/video/m4v/ using wget.

Now when I use the command wget -r -A .m4v http://good.net/dl/bd/CCCamp-2007/video/m4v/

I get the just a bunch of filefolders, but no files, ex."cccamp07-de-1845-Freifunk_und_Recht.m4v" but its a folder.

help?
Try: wget -r *.m4v http://good.net/dl/bd/CCCamp-2007/video/m4v/

Make sure you have the space.
 
1 members found this post helpful.
Old 10-11-2010, 08:58 AM   #4
sephstorm
LQ Newbie
 
Registered: Aug 2010
Distribution: Fedora
Posts: 18

Original Poster
Rep: Reputation: 0
not working, I think it may because it is a file hosting site, maybe the files are actually located at a different url. can you explain those options?
 
Old 10-11-2010, 09:39 AM   #5
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,603
Blog Entries: 25

Rep: Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981
Hi,

Quote:
Originally Posted by sephstorm View Post
not working, I think it may because it is a file hosting site, maybe the files are actually located at a different url. can you explain those options?
I tested both suggestions. Works here.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wget help Pinkdog Linux - Software 2 09-22-2009 03:21 PM
Using wget mierdatuti Linux - Networking 3 08-17-2008 07:19 AM
wget not working! but "man wget is" ??? wrapster Solaris / OpenSolaris 5 07-30-2008 04:00 AM
wget noir911 Linux - Newbie 8 07-30-2005 09:57 AM
wget Harp00 Linux - Newbie 4 11-15-2004 08:27 PM


All times are GMT -5. The time now is 02:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration