LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-02-2009, 10:27 PM   #1
trekgirl
Member
 
Registered: Feb 2009
Location: Bremerton, WA, USA
Distribution: Red Hat
Posts: 60

Rep: Reputation: 26
Weird issue when restarting Ubuntu 9


I installed Ubuntu 9 to dual boot on my Vista box. It is a Dell XPS410. When I do a shutdown from within Ubuntu, it shuts the computer down as expected. When I hit restart however, it acts like it shuts Ubuntu down then goes to a black screen where it says:
801.648244]
Restarting System

Except...it never restarts the system. It hangs until I push the power button off. I know this isn't good for Windows, and I would assume its not good for Linux either. Anybody have any ideas? I can do a shutdown if I have to but it would be nice to be able to just do a restart to get to Vista when I need Microsoft's evil to do something.
 
Old 07-03-2009, 01:19 AM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
how does sleep and hibernate work for you? have you tried switching wireless off before restart attempt?

dmesg | grep acpi


There is a very interesting discussion
http://lists.freebsd.org/pipermail/f...il/062599.html
... for BSD, but it has pointers for linux.

Suggests there may be a bios/mobo issue. adding "reboot=b" to the kernel line in /boot/grub/menu.lst may be worth a try.
 
Old 07-03-2009, 01:28 AM   #3
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Yeah this issue seems to be with acpi. Putting acpi=force can also solve the problem as with reboot=b. I had this similar issue with dell desktop and acpi=force option made it for me.
 
Old 07-03-2009, 07:37 AM   #4
kb2tfa
Member
 
Registered: Oct 2006
Location: Philadelphia PA
Posts: 151

Rep: Reputation: 16
despite the advances, the two systems,on the same pc, is an invite to trouble.
 
Old 07-03-2009, 11:10 AM   #5
trekgirl
Member
 
Registered: Feb 2009
Location: Bremerton, WA, USA
Distribution: Red Hat
Posts: 60

Original Poster
Rep: Reputation: 26
Thanks guys, I will give the ACPI option a shot. I know that Open Solaris had a problem related to ACPI when the computer had a SATA hard drive, because Dell sets the SATA up a little weird. Maybe this is similar. I will definitely give it a try and let you know how it goes.
Other than that, dual boot has been working great! Linux is my main OS, and I have Vista to fall back on for Microsoft evilness. I have a laptop running XP as well so I should be covered. I have another laptop running the same distro Ubuntu 9 so I'm good on all fronts.
 
Old 07-07-2009, 11:00 PM   #6
trekgirl
Member
 
Registered: Feb 2009
Location: Bremerton, WA, USA
Distribution: Red Hat
Posts: 60

Original Poster
Rep: Reputation: 26
Quote:
Originally Posted by Simon Bridge View Post
how does sleep and hibernate work for you? have you tried switching wireless off before restart attempt?

dmesg | grep acpi


There is a very interesting discussion
http://lists.freebsd.org/pipermail/f...il/062599.html
... for BSD, but it has pointers for linux.

Suggests there may be a bios/mobo issue. adding "reboot=b" to the kernel line in /boot/grub/menu.lst may be worth a try.
Reboot=b did fix it but not in the kernel line in my case. I read on another site about a gentleman who had the same issue. He found that when he booted it wiped out the reboot=b entry so he put it into the commented out kopt line in the /boot/grub/menu.lst file. I tried it and I just had a successful reboot! Thanks guys I couldn't have done it without you. I wouldn't have found the article if you hadn't pointed me in the right direction!
 
Old 07-11-2009, 10:55 PM   #7
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Well done - now find someone else to go help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Vuze: Issue with constant cycle of restarting. cynicalpsycho Linux - Software 1 05-26-2009 03:06 PM
Can't access Windows. Weird, weird grub issue. MightyHard Linux - General 2 12-31-2008 04:35 PM
ubuntu 8.04 restarting itself when shut down is selected techemically Linux - Software 3 11-21-2008 11:32 AM
Ubuntu restarting automatically on each boot charlesreid1 Linux - Laptop and Netbook 4 12-13-2007 01:05 PM
x server keeps restarting on ubuntu 6.10 rameshg87 Ubuntu 4 02-17-2007 11:47 AM


All times are GMT -5. The time now is 08:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration