LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-28-2006, 08:01 PM   #1
rogee
LQ Newbie
 
Registered: Feb 2006
Posts: 19

Rep: Reputation: 0
weird email problem


Hi,

I have a rootserver and im having some problems, Im using plesk,when i try to send a email through horde, or send an email from another place to this partcular email they send but i dont see any of teh emails checking the system logs iam seeing this error and im wondering if any one can point me into the right direction here is the system log

Mar 1 01:05:27 beacon imapd: Connection, ip=[127.0.0.1]
Mar 1 01:05:27 beacon imapd: IMAP connect from @ [127.0.0.1]INFO: LOGIN, user=peter, ip=[127.0.0.1], protocol=IMAP
Mar 1 01:05:27 beacon imapd: 1141171527.922704 LOGOUT, user=peter, ip=[127.0.0.1], headers=0, body=0, rcvd=187, sent=711, maildir=/var/qmail/mailnames/mydomain.com/peter/Maildir
Mar 1 01:05:31 beacon imapd: Connection, ip=[127.0.0.1]
Mar 1 01:05:31 beacon imapd: IMAP connect from @ [127.0.0.1]INFO: LOGIN, user=peter, ip=[127.0.0.1], protocol=IMAP
Mar 1 01:05:32 beacon imapd: 1141171532.11573 LOGOUT, user=peter, ip=[127.0.0.1], headers=0, body=0, rcvd=187, sent=711, maildir=/var/qmail/mailnames/mydomain.com/peter/Maildir
Mar 1 01:05:34 beacon imapd: Connection, ip=[127.0.0.1]
Mar 1 01:05:34 beacon imapd: IMAP connect from @ [127.0.0.1]INFO: LOGIN, user=peter, ip=[127.0.0.1], protocol=IMAP
Mar 1 01:05:35 beacon imapd: 1141171535.60747 LOGOUT, user=peter, ip=[127.0.0.1], headers=0, body=0, rcvd=187, sent=711, maildir=/var/qmail/mailnames/mydomain.com/peter/Maildir
Mar 1 01:05:38 beacon imapd: Connection, ip=[127.0.0.1]
Mar 1 01:05:38 beacon imapd: IMAP connect from @ [127.0.0.1]INFO: LOGIN, user=peter, ip=[127.0.0.1], protocol=IMAP
Mar 1 01:05:38 beacon imapd: 1141171538.940598 LOGOUT, user=peter, ip=[127.0.0.1], headers=0, body=0, rcvd=87, sent=581, maildir=/var/qmail/mailnames/mydomain.com/peter/Maildir
Mar 1 01:05:54 beacon imapd: Connection, ip=[127.0.0.1]
Mar 1 01:05:54 beacon imapd: IMAP connect from @ [127.0.0.1]INFO: LOGIN, user=peter, ip=[127.0.0.1], protocol=IMAP
Mar 1 01:05:54 beacon smtpd[2760]: SMTP HELO from localhost(127.0.0.1) as "localhost"
Mar 1 01:05:54 beacon smtpd[2760]: mail from <peter@mydomain.com.com>
Mar 1 01:05:54 beacon smtpd[2760]: Can not open from address check file /etc/smtpd_check_rules (No such file or directory)!
Mar 1 01:05:54 beacon smtpd[2760]: Recipient <somonefrom@hotmail.com>
Mar 1 01:05:54 beacon smtpd[2760]: Received 582 bytes of message body from localhost(127.0.0.1)
Mar 1 01:05:54 beacon imapd: 1141171554.921169 LOGOUT, user=peter, ip=[127.0.0.1], headers=0, body=0, rcvd=683, sent=636, maildir=/var/qmail/mailnames/mydomain.com/peter/Maildir
 
Old 03-01-2006, 03:22 AM   #2
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
Quote:
Mar 1 01:05:54 beacon smtpd[2760]: Can not open from address check file /etc/smtpd_check_rules (No such file or directory)!
This clearly indicates that your system can't check the from: address because it's not finding the file
/etc/smtpd_check_rules.
Either create the file, possibly with appropriate rules in it, or re-configure your system to use a different file (if you already have one).

As for the SMTP (the mail that is sent): everything seems to be ok. You've got the HELO message, mail from, recipient and a message body. The only problem I see is with the from: address checking.

The rest of the log entries are simple login/logout to open and close an IMAP connection. No problems at first sight there, but I'm no expert.
 
Old 03-01-2006, 03:40 PM   #3
rogee
LQ Newbie
 
Registered: Feb 2006
Posts: 19

Original Poster
Rep: Reputation: 0
thanks

Many thanks for the info really appreciate it,because im a noob to the linux stuff.what rules do i need to put in the smtpd_check_rules ?and also just recently ive been getting the following cron deamon mails to my email every 10 mins




1st email
/usr/share/sendmail/sendmail: line 820: /usr/sbin/sendmail-msp: No such file or
directory



2nd email

/bin/sh: line 1: {LOG_DIR}/vhcs2-vrl-traff.log: No such file or directory




3rd email
/bin/sh: line 1: {LOG_DIR}/vhcs2-srv-traff.log: No such file or directory




Ive tried understanding all of it but damn its baffling me,and im still not able to read any email or the recipents get any mails appreciate any assitance you can offer.
 
Old 03-02-2006, 03:11 AM   #4
timmeke
Senior Member
 
Registered: Nov 2005
Location: Belgium
Distribution: Red Hat, Fedora
Posts: 1,515

Rep: Reputation: 61
2nd and 3rd e-mail seem to be related to VHCS software, which is installed for virtual hosting.
As mentioned on http://slackware.hostinghacks.net/vhcs/, a Slackware related site, vhcs2 has it's own service (daemon).

VHCS2's config example from the site has some Apache and e-mail stuff in it. So, the mails you're seeing can be related to some e-mail problems too.

Maybe you can find some help on:
http://vhcs.net/new/
It has a forum too.

Furthermore, http://www.electrictoolbox.com/artic...ebsd-sendmail/ tells you that it's possible to restart the sendmail-msp daemon on FreeBSD. Maybe you can try something similar to resolve the problem of the 1st mail?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
weird, weird problems with logitech precision USB gamepad ikataii Linux - Hardware 4 10-14-2005 05:31 AM
Weird, weird apache2 problem atheist Debian 1 09-17-2004 09:26 PM
Weird window in Evolution eMail caged Linux - Software 1 05-05-2004 12:50 PM
weird kernel problem and fs mount problem intense Slackware 5 03-16-2004 01:36 PM
Problem receiving email from email server sharon Linux - Newbie 3 07-11-2003 04:57 AM


All times are GMT -5. The time now is 03:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration