LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-30-2004, 07:00 AM   #1
icedude
Member
 
Registered: Nov 2004
Location: South Africa
Posts: 43

Rep: Reputation: 15
Question Web browsing in text mode


Hi

I'm using Links-2.1pre14 to brows the web but it cant find a connection.
We are using a proxy server and im dont know where to enter the settings or
change any thing

Could someone please give me advise.
 
Old 12-30-2004, 07:12 AM   #2
amfoster
Member
 
Registered: Aug 2004
Distribution: debian, SuSE
Posts: 365

Rep: Reputation: 35
proxy etc are usually set in the config files. I am not sure what browser you are using. If it is links, the config is in the ~/.link directory. Just man links but the syntax is something like
hostort to set what the proxy server is.

If you are using lynx, just man that and it has a user guide in it.

What web based browser are you using?
links, lynx, elinks, w3m?
 
Old 12-30-2004, 07:20 AM   #3
icedude
Member
 
Registered: Nov 2004
Location: South Africa
Posts: 43

Original Poster
Rep: Reputation: 15
I'm using Links for browsing the net in text mode.
 
Old 12-30-2004, 07:32 AM   #4
amfoster
Member
 
Registered: Aug 2004
Distribution: debian, SuSE
Posts: 365

Rep: Reputation: 35
do an info on links. It will show you the format for the config file, or you can set that from the command line with this option:

-http-proxy <hostort>

So, create a configuration file for it, or make an alias in your ~/.bashrc file

alias links="links -http-proxy xxx.xxx.xxx.xxx:8080

or whatever your proxy info is.

then run
. ~/.bashrc or log out and log back in (your choice)
 
Old 12-30-2004, 07:45 AM   #5
cl2imson
LQ Newbie
 
Registered: Feb 2004
Location: Norman, OK
Distribution: Fedora, Core 2
Posts: 23

Rep: Reputation: 15
well what I did was I added the following line to my ~/.bash_profile file and it works in both lynx and elinks...(and any other command line network proggie as far as I know)

export http_proxy="10.3.0.3:8080"

or whateva ur pl2oxy addl2ess is.

good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How change text color using linux in text mode only runlevel 3? Xavius Linux - General 7 05-07-2009 03:19 AM
Change the display mode in text mode Drunkalot Linux - General 7 08-12-2005 12:35 PM
How to; Suse9.3 prof. text mode to graphical mode anjum Linux - Software 5 07-21-2005 12:36 AM
Booting in text mode versus graphics mode LChalupa Linux - Newbie 3 01-15-2005 08:53 PM
text only web browsing with cygwin? chingasman Linux - General 1 03-04-2003 10:10 PM


All times are GMT -5. The time now is 11:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration