LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-28-2016, 11:22 AM   #16
imjustkillingtime
LQ Newbie
 
Registered: May 2016
Distribution: Slackware
Posts: 26

Original Poster
Rep: Reputation: 4

Hi BW-userx, thanks again for your suggestions. i will check them out later.

Last edited by imjustkillingtime; 10-30-2016 at 08:46 AM.
 
Old 10-28-2016, 11:41 AM   #17
goumba
Senior Member
 
Registered: Dec 2009
Location: New Jersey, USA
Distribution: Debian Sid. Arch. In the process of converting to and learning FreeBSD
Posts: 1,023
Blog Entries: 6

Rep: Reputation: 237Reputation: 237Reputation: 237
Check which driver module is loaded for Bluetooth on your machine.

Code:
lspci -v
and look for the Bluetooth device, or if that shows nothing,

Code:
lsmod | grep bluetooth
It will help if you already know the manufacturer of the device. All else fails, post the output of the above commands here, and someone may be able to help you figure which one.

Then, you'll have to blacklist the module. Create a file, say, 10-bluetooth.conf in /etc/modprobe.d. In it, put the line

Code:
blacklist module
You could theoretically, rather than trying to figure out the driver, just make it

Code:
blacklist bluetooth
That may work. It may not. The caveat of disabling the driver is that some modern hardware (so you will hopefully be lucky to not be affected) combine wireless and bluetooth chipsets. Disabling bluetooth will disable wireless, and vice-versa. I'm pretty sure disabling module bluetooth will do that and only that.

I've not used Slack in a long time, and Pat may not follow the configuration directory scheme like other distros. If that's the case, look for modprobe.conf, or something similar and just add that line to it.

Last edited by goumba; 10-28-2016 at 11:47 AM.
 
Old 10-28-2016, 11:51 AM   #18
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,080

Rep: Reputation: Disabled
Quote:
Originally Posted by goumba View Post
Check which driver module is loaded for Bluetooth on your machine.

Code:
lspci -v
and look for the Bluetooth device, or if that shows nothing,

Code:
lsmod | grep bluetooth
It will help if you already know the manufacturer of the device. All else fails, post the output of the above commands here, and someone may be able to help you figure which one.

Then, you'll have to blacklist the module. Create a file, say, 10-bluetooth.conf in /etc/modprobe.d. In it, put the line

Code:
blacklist module
You could theoretically, rather than trying to figure out the driver, just make it

Code:
blacklist bluetooth
That may work. It may not. The caveat of disabling the driver is that some modern hardware (so you will hopefully be lucky to not be affected) combine wireless and bluetooth chipsets. Disabling bluetooth will disable wireless, and vice-versa. I'm pretty sure disabling module bluetooth will do that and only that.

I've not used Slack in a long time, and Pat may not follow the configuration directory scheme like other distros. If that's the case, look for modprobe.conf, or something similar and just add that line to it.
Oh yeah this is Slack, I wasn't keeping that in mind, just remove your user from them three groups, I told you about earlier in this post on how to add your user to the Bluetooth.
 
Old 10-28-2016, 02:10 PM   #19
goumba
Senior Member
 
Registered: Dec 2009
Location: New Jersey, USA
Distribution: Debian Sid. Arch. In the process of converting to and learning FreeBSD
Posts: 1,023
Blog Entries: 6

Rep: Reputation: 237Reputation: 237Reputation: 237
Quote:
Originally Posted by BW-userx View Post
Oh yeah this is Slack, I wasn't keeping that in mind, just remove your user from them three groups, I told you about earlier in this post on how to add your user to the Bluetooth.
The OP removing the user from the bluetooth group is not going to solve his problem, which is disabling the hardware altogether, thus shutting off the LED as s/he desires to do. Stopping the kernel module from loading will do so.
 
Old 10-28-2016, 02:20 PM   #20
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,080

Rep: Reputation: Disabled
Quote:
Originally Posted by goumba View Post
The OP removing the user from the bluetooth group is not going to solve his problem, which is disabling the hardware altogether, thus shutting off the LED as s/he desires to do. Stopping the kernel module from loading will do so.
I was referring to removing the icon, that he said he thought he had disabled
Quote:
i thought i disabled the tray icon. wow!
, ... just open it up and rip out the device . .problem solved. get on with life...

Last edited by BW-userx; 10-28-2016 at 02:21 PM.
 
Old 10-28-2016, 07:16 PM   #21
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,080

Rep: Reputation: Disabled
OK OK OK WTF
am I wrong?

I just booted into Slackware to try this out, I did this.
Code:
userx@SlackDaddy & ~ >> $sudo chmod -x /etc/rc.d/rc.bluetooth
rebooted
then did this
Code:
userx@SlackDaddy & ~ >> $ps -aux | grep bluetooth
userx     1516  0.0  0.0   9644  1872 pts/0    S+   18:13   0:00 grep bluetooth
Bluetooth is no longer running, nor am I getting the Bluetooth icon in my application area.
So without having to read through everything posted in here to see what is what.

I have successfully removed Bluetooth from starting on Slackware.
 
Old 10-28-2016, 08:22 PM   #22
goumba
Senior Member
 
Registered: Dec 2009
Location: New Jersey, USA
Distribution: Debian Sid. Arch. In the process of converting to and learning FreeBSD
Posts: 1,023
Blog Entries: 6

Rep: Reputation: 237Reputation: 237Reputation: 237
Congratulations sir, on solving that by monkeying with the permissions, but you still haven't solved his/her issue of the LED, which was their original desire.

For reference, s/he stated he disabled it in Windows, so it's doable.

Last edited by goumba; 10-28-2016 at 08:24 PM.
 
Old 10-28-2016, 08:36 PM   #23
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,080

Rep: Reputation: Disabled
Quote:
Originally Posted by goumba View Post
Congratulations sir, on solving that by monkeying with the permissions, but you still haven't solved his/her issue of the LED, which was their original desire.

For reference, s/he stated he disabled it in Windows, so it's doable.
again I bet it is the hardware and not the OS, unplug it from your motherboard.

that too by definition is not monkeying with permissions, it is PP ~ proper procedure. like black listing is.

Last edited by BW-userx; 10-28-2016 at 08:38 PM.
 
Old 10-29-2016, 12:55 AM   #24
imjustkillingtime
LQ Newbie
 
Registered: May 2016
Distribution: Slackware
Posts: 26

Original Poster
Rep: Reputation: 4
Thanks for hearing me out folks.

@goumba i have

Code:
# lsmod | grep bluetooth
bluetooth             295560  4 btbcm,btrtl,btusb,btintel
rfkill                 15655  3 cfg80211,acer_wmi,bluetooth
@BW-userx i have
Code:
$ ps -aux | grep bluetooth
me      2814  0.0  0.0   3304  1956 pts/3    S+   11:46   0:00 grep bluetooth
this is of course after i presumably done more harm than good on my system's configuration.

i'm proud to confess my sins:

Attempt 1: "The answer my friend, is blowin' in the wind"
Code:
1.unchecked "Bluetooth" on System Settings > Startup and Shutdown >Service Manager
2.ticked System Settings > Startup and Shutdown >Session Managemenet >Start with an empty session (On Login)
3.# chmod -x /etc/rc.d/rc.bluetooth
Code:
Results:
*The bluetooth system tray icon is gone, BUT
*The LED is still automatically ON across reboots and logins
Attempt 2: "Don't think twice, It's alright"
Code:
4.$ gsettings set org.blueman.plugins.powermanager auto-power-on false

5. removed /etc/xdg/autostart/blueman.desktop

6. added the following lines to /etc/rc.d/rc.local

PATH=/bin:/sbin:/usr/bin:/usr/sbin
/etc/rc.d/rc.bluetooth start
hciconfig hci0 down

7.created /etc/modprobe.d/blacklist_bluetooth.conf
with the following lines:
blacklist btbcm
blacklist btrtl
blacklist btusb
blacklist btintel
blacklist bnep
blacklist rfcomm
Code:
Results:
*The bluetooth system tray icon is gone, BUT
*The LED is still automatically ON across reboots and logins, AND
*I noticed that i can no longer run bluetooth manually via Bluetooth Manager.
Attempt 3: "It's alright Ma, i'm only bleeding"

The given solution for Slackware, as far as i'm able to comprehend it, on one of the links (post#9) simply requires adding the following lines to /etc/rc.d/rc.local, so I tried to sort of undo (if there is such a thing) Attempts 1 & 2, Reboot, before proceeding
Code:
#!/bin/sh
rfkill block bluetooth
exit 0
Code:
Result:
post#10
Attempt 4: "i know something's happening here, but i dont know what it is"

After posts 11, 12, and 13, I decided to do this again
Code:
# chmod -x /etc/rc.d/rc.bluetooth
Code:
Results:
1. I think I achieved GOAL1, success! BUT
2. Launching Bluetooth Manager after pushing the Bluetooth button/LED to turn it on gives me the prompt:
"Connection to BlueZ failed Bluez daemon is not running, blueman-manager cannot continue.This probably means that there were no Bluetooth adapters  detected or Bluetooth daemon was not started"
i'm enjoying the process even though it is totally overwhelming.
honestly, as of writing, disabling the kernel module as pointed out by goumba is what i suspect would completely solve my problem but
DavidMcCann's suggestions seem to have worked until i discovered that i still have the bluetooth tray icon when
i try to manually activate the bluetooth (GOAL2).

Last edited by imjustkillingtime; 10-31-2016 at 02:33 AM.
 
Old 10-29-2016, 08:15 AM   #25
goumba
Senior Member
 
Registered: Dec 2009
Location: New Jersey, USA
Distribution: Debian Sid. Arch. In the process of converting to and learning FreeBSD
Posts: 1,023
Blog Entries: 6

Rep: Reputation: 237Reputation: 237Reputation: 237
Quote:
Originally Posted by BW-userx View Post
that too by definition is not monkeying with permissions, it is PP ~ proper procedure. like black listing is.
I must admit my mistake, sir: I was thinking, incorrectly, that Slackware was SysV based init. In fact it's BSD. As I had admitted previously, it had been a while.

Last edited by goumba; 10-29-2016 at 08:18 AM.
 
Old 10-29-2016, 09:15 AM   #26
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 2,080

Rep: Reputation: Disabled
Quote:
Originally Posted by imjustkillingtime View Post
Results:
1. I think I achieved GOAL1, success! BUT
2. Launching Bluetooth Manager after pushing the Bluetooth button/LED to turn it on gives me the prompt:
"Connection to BlueZ failed Bluez daemon is not running, blueman-manager cannot continue.This probably means that there were no Bluetooth adapters detected or Bluetooth daemon was not started"
[/code]

i'm enjoying the process even though it is totally overwhelming.
honestly, as of writing, disabling the kernel module as pointed out by goumba is what i suspect would completely solve my problem but
DavidMcCann's suggestions seem to have worked until i discovered that i still have the bluetooth tray icon when
i try to manually activate the bluetooth (GOAL2).
you might have to write a script and give it root permissions, now that you are modifying (monkeying around) with proper procedures in how it was designed to work.

a script that will be called up on when launching your interphase Bluez or whatever it is called, so that when the bluetooth is called into play it will run the command to start your daemons for bluetooth, and anything else that it needs to continue with the desired operation.

or a script that you will call upon first that will start up your daemons first then call the bluez or whatever interphase used to manage your bluetooth.

you've only modified it part way, you now have to figure out how to finish what you've started.

or start up your daemons first before you start that manager

Last edited by BW-userx; 10-29-2016 at 09:23 AM.
 
Old 10-29-2016, 10:43 PM   #27
Jjanel
Member
 
Registered: Jun 2016
Posts: 368

Rep: Reputation: 66
Is the light on (or off) *before* linux boots/loads/runs?

"catch" grub>

Is the light OFF? Then it's Linux 'doing' it (turning it on). Linux always CAN be 'fixed'!

I think of the grub program like a tiny 'OS'! It can do `ls` and fifty other commands!
(Consider even the <446byte 'program' IN the MBR, which can say "Hard Disk Read Error" or "OS not found")

Last edited by Jjanel; 10-29-2016 at 11:14 PM.
 
Old 10-30-2016, 06:09 AM   #28
imjustkillingtime
LQ Newbie
 
Registered: May 2016
Distribution: Slackware
Posts: 26

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by Jjanel View Post
Is the light on (or off) *before* linux boots/loads/runs?
...
hi Jjanel thanks for asking.

During boot up, the bluetooth LED automatically turns ON exactly when my screen becomes black right before it display smaller (compare to the initial size) fonts.
I believe that's when where i can read
Code:
...
[   12.737393] Bluetooth: Core ver 2.21
...
and then automatically turns OFF when the screen displays these lines
Code:
...
Compiling GSettings XML schema files:
  /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas &

Welcome to Linux 4.4.14-smp (tty1)

login:
And will stay OFF even when i login and startx. That's good news for me.
BUT when i click the "drop up" on my tray icons to check if there is no bluetooth... Wow!


@BH-userx
Thanks again. I will look into that later.

Last edited by imjustkillingtime; 10-31-2016 at 02:36 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
rfkill (software but not hardware) block bluetooth saves battery? stozi Linux - Newbie 1 10-12-2016 03:41 PM
[SOLVED] How to stop remote access, sharing and bluetooth? jdr97 Fedora 4 03-04-2012 05:19 PM
How to get bluetooth audio to stop interferring with wifi? redss Ubuntu 1 12-26-2011 02:31 PM
Latitude D820 + Firewire drive/bluetooth/WiFi/Core Duo issues, please stop by NeXuS_2006 Linux - Laptop and Netbook 2 12-17-2006 03:53 PM
How do I stop Xwindows from autostarting ehsan Linux - General 2 03-14-2001 10:26 AM


All times are GMT -5. The time now is 10:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration