LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-21-2008, 11:02 PM   #1
etotheidotpy
LQ Newbie
 
Registered: Jan 2008
Location: Vancouver, BC
Distribution: Fedora 8
Posts: 11

Rep: Reputation: 0
Want to disable touch zones for laptop mousepad


Hi,

I'm currently using an HP Compaq nc6400 laptop with RHEL 5.1 on it, and I would like to disable the tap zones on the mousepad.

From what I've found, adding the line
Quote:
Option "MaxTapTime" "0"
to xorg.conf should fix it. However, after adding that and then logging in and out, the touch zones are still enabled.

Help, please?

Here's my current xorg.conf file:
Quote:
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
Option "MaxTapTime" "0"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "HP L1755 LCD Flat Panel Monitor"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 82.0
VertRefresh 56.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x800" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Last edited by etotheidotpy; 01-21-2008 at 11:29 PM.
 
Old 01-22-2008, 05:49 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Try using the TouchpadOff option, example below;
Code:
Section "InputDevice"
	Identifier  "Synaptics"
	Driver      "synaptics"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "auto-dev"
	Option	    "Emulate3Buttons" "yes"
	Option	    "TouchpadOff" "2"
EndSection
You need to restart the X server after making the change also.

Last edited by Lenard; 01-22-2008 at 05:50 AM.
 
Old 01-22-2008, 09:10 PM   #3
etotheidotpy
LQ Newbie
 
Registered: Jan 2008
Location: Vancouver, BC
Distribution: Fedora 8
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks -- I did that, and it disabled the back/forward in browser history feature with the corners of the pad, but it has also disabled the vertical scrolling feature. How can I enable the vertical scrolling but not the forwards/backwards?
 
Old 01-22-2008, 09:37 PM   #4
elliott678
Member
 
Registered: Mar 2005
Location: North Carolina
Distribution: Arch
Posts: 977

Rep: Reputation: 72
This gets rid of the corner buttons and horizontal scrolling, but leaves everything else.
Code:
	Option      "RTCornerButton"        "0"
	Option      "RBCornerButton"        "0"
	Option      "LTCornerButton"        "0"
	Option      "LBCornerButton"        "0"
        Option      "LeftRightScrolling"    "off"

Last edited by elliott678; 01-22-2008 at 09:39 PM.
 
Old 01-22-2008, 09:47 PM   #5
etotheidotpy
LQ Newbie
 
Registered: Jan 2008
Location: Vancouver, BC
Distribution: Fedora 8
Posts: 11

Original Poster
Rep: Reputation: 0
I just tried that out; it isn't working. (The vertical scrolling is enabled, but so is the corner zones and the left/right scrolling.)
 
Old 01-22-2008, 09:53 PM   #6
elliott678
Member
 
Registered: Mar 2005
Location: North Carolina
Distribution: Arch
Posts: 977

Rep: Reputation: 72
Do you happen to have an Alps touchpad? I've heard of issues like this on them.
 
Old 01-22-2008, 10:04 PM   #7
etotheidotpy
LQ Newbie
 
Registered: Jan 2008
Location: Vancouver, BC
Distribution: Fedora 8
Posts: 11

Original Poster
Rep: Reputation: 0
I managed to figure out, thanks guys for the help.

I found this page:
http://linux.die.net/man/5/synaptics

And from there I got the idea to set HorizScrollDelta to zero in addition to the lines elliott678 posted, and it it seems to be working just the way I want it to now.

That section's code is now:
Quote:
Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"

Option "HorizScrollDelta" "0"
Option "RTCornerButton" "0"
Option "RBCornerButton" "0"
Option "LTCornerButton" "0"
Option "LBCornerButton" "0"
Option "LeftRightScrolling" "off"
EndSection
Thanks again
 
Old 01-25-2008, 10:38 AM   #8
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 230Reputation: 230Reputation: 230
Welcome to LQ.

Cool, you found the piece on your own.

Also, thank you for posting the solution. That's a big part of how LQ is supposed to work & you're getting the spirit form the beginning -- good job.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable Touch pad *Clicking* wh33t Mandriva 20 10-27-2008 10:00 AM
touch pad on laptop lotec25 Slackware 1 06-21-2006 12:38 PM
Laptop mousepad prh Mandriva 2 12-13-2005 10:59 AM
[Fedora Core 4] No mousepad on laptop lachesis Linux - Laptop and Netbook 2 11-06-2005 06:20 AM
Laptop install - use mouse or touch pad? mark_2811 Linux - General 1 02-21-2004 06:06 PM


All times are GMT -5. The time now is 09:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration