LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-11-2005, 11:12 AM   #1
nearfar
LQ Newbie
 
Registered: Oct 2003
Posts: 10

Rep: Reputation: 0
Question vsftpd problem


Hi, I have installed fedora4, and for ftp i'm trying to use vsftpd.
the vsftpd daemon seems to be running o.k. and I can ftp from the same system (just to check if ftp is working) but when i try to ftp from Windows through smartftp, or editplus, it fails. It seems to establish connection at first, but then i get a timeout. In case of smartftp i get the following message:
" A socket operation was attempted to an unreachable
host."

any suggestions on how i should configure vsftpd.conf, or any settings? I would appreciate your help!
thank you!!
 
Old 12-11-2005, 12:32 PM   #2
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
Have you checked your firewall settings (you need to enable ftp) and selected your network card as a trusted device.
 
Old 12-11-2005, 02:12 PM   #3
amitsharma_26
Member
 
Registered: Sep 2005
Location: New delhi
Distribution: RHEL 3.0/4.0
Posts: 777

Rep: Reputation: 31
iptables -F
or
service iptables stop

& then checkback again.
 
Old 12-12-2005, 03:43 PM   #4
nearfar
LQ Newbie
 
Registered: Oct 2003
Posts: 10

Original Poster
Rep: Reputation: 0
thank you so much!! i did "iptables stop", and I am able to use ftp.....
how can i permanently disable iptables?
 
Old 12-12-2005, 05:49 PM   #5
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
Quote:
...how can i permanently disable iptables?
In general, that would be a bad idea, since iptables is your firewall.

If you are running X, the easy fix is to modify System Settings > Security Level and set ftp as a trusted service, which will add a line to /etc/sysconfig/iptables opening port 21 to new inbound tcp traffic.
 
Old 12-12-2005, 08:30 PM   #6
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
Quote:
Originally Posted by WhatsHisName
In general, that would be a bad idea, since iptables is your firewall.

If you are running X, the easy fix is to modify System Settings > Security Level and set ftp as a trusted service, which will add a line to /etc/sysconfig/iptables opening port 21 to new inbound tcp traffic.
Same thing as I posted above. Sometimes its really frustrating when you post the solution and you are never listened to even though you are right.
 
Old 12-13-2005, 08:16 AM   #7
amitsharma_26
Member
 
Registered: Sep 2005
Location: New delhi
Distribution: RHEL 3.0/4.0
Posts: 777

Rep: Reputation: 31
Quote:
Originally Posted by nearfar
thank you so much!! i did "iptables stop", and I am able to use ftp.....
how can i permanently disable iptables?
chkconfig --level 345 iptables off

Disable iptables in run-level 3 4 & 5. But it will come into effect on the next restart.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd settingd and VSFTPD DEAD BUT SUBSYS LOCKED pc_copat Linux - Newbie 15 11-05-2009 11:31 PM
vsftpd.conf/chroot/vsftpd.chroot_list issue Jerman Linux - Security 2 06-01-2007 08:24 PM
VSFTPD with 500 oops :vsftpd: missing argv[0] mole_13 Linux - Newbie 0 05-04-2005 02:05 AM
vsftpd problem... Scrag Linux - Software 4 02-25-2005 03:25 AM
vsftpd problem.. yenonn Linux - Networking 9 07-08-2004 10:03 PM


All times are GMT -5. The time now is 06:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration