LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-29-2015, 09:55 AM   #1
kylesouza
LQ Newbie
 
Registered: May 2015
Posts: 9

Rep: Reputation: Disabled
vsftpd not allowing local users to log on


I am trying to allow local users to us the ftp for my site (really, any user would work, I just thought this would be easiest). I am trying to make it so that I can upload themes, install plugins, etc on a WordPress site hosted on my Ubuntu 14.04 machine. Here is the contents of my vsftpd.conf file from /etc/

# Example config file /etc/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
#
# Run standalone? vsftpd can run either from an inetd or as a standalone
# daemon started from an initscript.
listen=YES
#
# Run standalone with IPv6?
# Like the listen parameter, except vsftpd will listen on an IPv6 socket
# instead of an IPv4 one. This parameter and the listen parameter are mutually
# exclusive.
#listen_ipv6=YES
#
# Allow anonymous FTP? (Disabled by default)
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# If enabled, vsftpd will display directory listings with the time
# in your local time zone. The default is to display GMT. The
# times returned by the MDTM FTP command are also affected by this
# option.
use_localtime=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
#xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may restrict local users to their home directories. See the FAQ for
# the possible risks in this before using chroot_local_user or
# chroot_list_enable below.
#chroot_local_user=YES
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (Warning! chroot'ing can be very dangerous. If using chroot, make sure that
# the user does not have write access to the top level directory within the
# chroot)
#chroot_local_user=YES
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
# Customization
#
# Some of vsftpd's settings don't fit the filesystem layout by
# default.
#
# This option should be the name of a directory which is empty. Also, the
# directory should not be writable by the ftp user. This directory is used
# as a secure chroot() jail at times vsftpd does not require filesystem
# access.
secure_chroot_dir=/var/run/vsftpd/empty
#
# This string is the name of the PAM service vsftpd will use.
pam_service_name=vsftpd
#
# This option specifies the location of the RSA certificate to use for SSL
# encrypted connections.
rsa_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
# This option specifies the location of the RSA key to use for SSL
# encrypted connections.
rsa_private_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
 
Old 05-29-2015, 10:18 AM   #2
kylesouza
LQ Newbie
 
Registered: May 2015
Posts: 9

Original Poster
Rep: Reputation: Disabled
When I try to connect this is what I get:

myuser@ip-111-11-11-11:~$ ftp mywebsite.com
Connected to mywebsite.com.
220 (vsFTPd 3.0.2)
Name (mywebsite:myuser): mkdir /var/www//html/test
331 Please specify the password.
Password:
530 Login incorrect.
Login failed.


I have changed the username, domain name, and IP address to something generic. The directory is owned by www-data, but my user is part of that group. Here are the current permissions:

ls -l /var/www/html
total 0
lrwxrwxrwx 1 www-data www-data 20 May 22 19:02 wordpress -> /usr/share/wordpress
 
Old 05-29-2015, 06:22 PM   #3
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 619

Rep: Reputation: 238Reputation: 238Reputation: 238
Quote:
Name (mywebsite:myuser):
Enter the username to log in as here (press enter for myuser) Then enter the password for the user at the "password:" prompt.

If login is successful, you should see a prompt like the following where you can enter your commands:
Code:
ftp>
 
Old 05-30-2015, 08:57 AM   #4
mralk3
Member
 
Registered: May 2015
Posts: 849

Rep: Reputation: 269Reputation: 269Reputation: 269
You need to log in using your user name and then your password prior to executing any ftp commands.

Additionally, for security purposes, you may also decide to move your Apache root directory to a single user's home directory. Then you could set up vsftpd to chroot that directory, set its permissions for file uploads and limit access for uploads for a basic user. This will prevent security breaches, or at least limit them. Whatever you do, do not enable root logins for vsftpd.
 
Old 06-01-2015, 01:33 PM   #5
kylesouza
LQ Newbie
 
Registered: May 2015
Posts: 9

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by norobro View Post
Enter the username to log in as here (press enter for myuser) Then enter the password for the user at the "password:" prompt.

If login is successful, you should see a prompt like the following where you can enter your commands:
Code:
ftp>
Okay, here's what I got:
kyle@ip-172-31-28-71:~$ ftp pandplandservice.com
Connected to pandplandservice.com.
220 (vsFTPd 3.0.2)
Name (pandplandservice.com:kyle): kyle
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> exit

Successful, right? but when I go to ftp://ftp.pandplandservice.com/ and use the same credentials I get a "This webpage is not available. ERR_CONNECTION_RESET" message (Chrome). What could cause this?
 
Old 06-01-2015, 01:36 PM   #6
kylesouza
LQ Newbie
 
Registered: May 2015
Posts: 9

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by mralk3 View Post
You need to log in using your user name and then your password prior to executing any ftp commands.

Additionally, for security purposes, you may also decide to move your Apache root directory to a single user's home directory. Then you could set up vsftpd to chroot that directory, set its permissions for file uploads and limit access for uploads for a basic user. This will prevent security breaches, or at least limit them. Whatever you do, do not enable root logins for vsftpd.
1. I am running a WordPress site from this server - will doing that mess-up the site at all?
2. If not, how do I do that? Is there a good tutorial online you could point me to? Is this, http://tareq.wedevs.com/2012/04/chan...oot-in-ubuntu/, what you mean?

Last edited by kylesouza; 06-01-2015 at 01:49 PM.
 
Old 06-01-2015, 02:17 PM   #7
kylesouza
LQ Newbie
 
Registered: May 2015
Posts: 9

Original Poster
Rep: Reputation: Disabled
Okay, I think I am making progress. I am looking at the vsftpd log file:
Mon Jun 1 19:13:22 2015 [pid 6376] CONNECT: Client "<IP ADDRESS>"
Mon Jun 1 19:13:22 2015 [pid 6375] [kyle] OK LOGIN: Client "<IP ADDRESS>"
Mon Jun 1 19:13:25 2015 [pid 6377] [kyle] FAIL MKDIR: Client "<IP ADDRESS>", "/srv/www/wp-content/localhost/upgrade"
Mon Jun 1 19:13:25 2015 [pid 6377] [kyle] FAIL RMDIR: Client "<IP ADDRESS>", "/srv/www/wp-content/localhost/upgrade/twentytwelve.1.7"

Given the permissions stated above, what am I doing that isn't allowing my user to create folders?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd Local Users hmartires Linux - Server 2 05-22-2008 03:14 PM
GDM stopped allowing two users to log in - Linux Mint Daryna Setlew Linux - Software 2 01-06-2008 11:37 AM
vsftpd not allowing users to log in Rokkun Linux - Software 6 11-14-2004 07:46 PM
vsftpd and local users mieslep Linux - Networking 6 11-05-2004 12:21 PM
vsftpd and (some) local users totothehero Linux - Networking 0 09-29-2004 04:08 PM


All times are GMT -5. The time now is 08:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration