LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 04-12-2006, 06:43 AM   #1
dazz
LQ Newbie
 
Registered: Apr 2005
Posts: 22

Rep: Reputation: 15
vsftpd : localhost connection refused problem


Hi

I am trying to set up vsftpd as a server to allow a web page on an ISP to dial-up and grab images from a web-cam to be located at my kart racing track.

I am running Redhat 9. I successfully got vsftpd working standalone by running the commmands
<usr/sbin/vsftpd &>
<ftp localhost>
I got all the expected responses. I could <ls> the directory OK.

I then modified the vsftpd.conf file to run from xinetd.
now when I run:
<ftp localhost>
I get the response:
ftp : connect : connection refused
ftp>

vsftpd is running but I can't make a connection for test purposes. The log is empty.
I have checked to make sure PAM is linked OK. I have checked the xinet.d file vftpd file entry. It all looks OK to me.

Can anyone tell me where I am going wrong? I am only a Linux beginner so any help would be much appreciated.


My next step is to set up a guest login. I want to restrict who can dial-up and transfer images to prevent the phone line being hogged. The aim is to regularly update a related webpage at the ISP.

Below is my vsftpd.conf file.



# Example config file /etc/vsftpd.conf

#

# The default compiled in settings are very paranoid. This sample file

# loosens things up a bit, to make the ftp daemon more usable.

#

# Allow anonymous FTP?

anonymous_enable=YES

#

# Uncomment this to allow local users to log in.

local_enable=YES

#

# Uncomment this to enable any form of FTP write command.

#write_enable=YES

#

# Default umask for local users is 077. You may wish to change this to 022,

# if your users expect that (022 is used by most other ftpd's)

local_umask=022

#

# Uncomment this to allow the anonymous FTP user to upload files. This only

# has an effect if the above global write enable is activated. Also, you will

# obviously need to create a directory writable by the FTP user.

#anon_upload_enable=YES

#

# Uncomment this if you want the anonymous FTP user to be able to create

# new directories.

#anon_mkdir_write_enable=YES

#

# Activate directory messages - messages given to remote users when they

# go into a certain directory.

dirmessage_enable=YES

#

# Activate logging of uploads/downloads.

xferlog_enable=YES

#

# Make sure PORT transfer connections originate from port 20 (ftp-data).

connect_from_port_20=YES

#

# If you want, you can arrange for uploaded anonymous files to be owned by

# a different user. Note! Using "root" for uploaded files is not

# recommended!

#chown_uploads=YES

#chown_username=whoever

#
# You may override where the log file goes if you like. The default is shown

# below.

#xferlog_file=/var/log/vsftpd.log

#
# If you want, you can have your log file in standard ftpd xferlog format

xferlog_std_format=YES

#

#YES Turns on per-command logging, FTP protocol commands, that is , triggered by
#but distinct from FTP user-space commands. Good for troubleshooting.

log_ftp_protocol=YES

#

# You may change the default value for timing out an idle session.

#idle_session_timeout=600

#

# You may change the default value for timing out a data connection.

#data_connection_timeout=120

#

# It is recommended that you define on your system a unique user which the

# ftp server can use as a totally isolated and unprivileged user.

#nopriv_user=ftpsecure

#

# Enable this and the server will recognise asynchronous ABOR requests. Not

# recommended for security (the code is non-trivial). Not enabling it,

# however, may confuse older FTP clients.

#async_abor_enable=YES

#

# By default the server will pretend to allow ASCII mode but in fact ignore

# the request. Turn on the below options to have the server actually do ASCII

# mangling on files when in ASCII mode.

# Beware that turning on ascii_download_enable enables malicious remote parties

# to consume your I/O resources, by issuing the command "SIZE /big/file" in

# ASCII mode.

# These ASCII options are split into upload and download because you may wish

# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),

# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be

# on the client anyway..

#ascii_upload_enable=YES

#ascii_download_enable=YES

#

# You may fully customise the login banner string:

ftpd_banner=You have connected to the Kart Sport Webcam FTP server.

#

# You may specify a file of disallowed anonymous e-mail addresses. Apparently

# useful for combatting certain DoS attacks.

#deny_email_enable=YES

# (default follows)

#banned_email_file=/etc/vsftpd.banned_emails

#

# You may specify an explicit list of local users to chroot() to their home

# directory. If chroot_local_user is YES, then this list becomes a list of

# users to NOT chroot().

#chroot_list_enable=YES

# (default follows)

#chroot_list_file=/etc/vsftpd.chroot_list

#

# You may activate the "-R" option to the builtin ls. This is disabled by

# default to avoid remote users being able to cause excessive I/O on large

# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume

# the presence of the "-R" option, so there is a strong case for enabling it.

#ls_recurse_enable=YES


pam_service_name=vsftpd

#userlist_enable=YES

#enable for standalone mode

listen=NO

tcp_wrappers=YES




Regards

Dazz
 
Old 04-12-2006, 06:51 AM   #2
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
You could place your code inside tags, so it would look nicer. Don't know if it helps, but try setting listen to yes and restart vsftpd.
 
Old 04-12-2006, 07:08 AM   #3
mouse46
Member
 
Registered: Mar 2004
Location: London
Distribution: Kubuntu, Debian
Posts: 87

Rep: Reputation: 15
I had a similar problem with fedora core 1. only way I got it to work again was to reinstall.
 
Old 04-13-2006, 03:26 AM   #4
dazz
LQ Newbie
 
Registered: Apr 2005
Posts: 22

Original Poster
Rep: Reputation: 15
Hi

My understanding is that the "listen=no" tells vsftpd that it is being run as a service from xinetd. Yes says it is standalone.

I setup this machine as a server and ticked the "ftp" option when Redhat was first installed. I might try installing a later version of vsftpd as an option of last resort.

Thanks for your ideas.

Dazz
 
Old 04-13-2006, 03:34 AM   #5
james.farrow
Member
 
Registered: Mar 2003
Location: UK Darlington
Distribution: Fedora Freebsd Centos
Posts: 288

Rep: Reputation: 30
Have you allowed vsftpd in /etc/hosts.allow ??

something like

vsftpd: ALL

That will allow everything, then you can refine it by inly allowing hosts on your network and loopback.
 
Old 04-14-2006, 06:52 AM   #6
dazz
LQ Newbie
 
Registered: Apr 2005
Posts: 22

Original Poster
Rep: Reputation: 15
Hi

I managed to solve the problem by reinstalling vsftpd using the following commands:

First uninstall vsftpd
#rpm -e vsftpd

locate the rpm from the redhat 9 distro cds and install
#rpm -ivh vsftpd vsftpd-1.1.3-8.rpm

turn on the vsftpd servie
#chkconfig vsftpd on

start vsftpd
#service vsftpd start

check that it is running
#netstat -a | grep ftp
you should get a response that looks like
tcp 0 0 *:ftp *.* LISTEN

Before changing any config files, I did the following test

#ftp localhost

I got logged on as anonymous and got a connection. It now works.

Documents I have found don't seem to agree on whether vsftpd runs stand-alone, or not in Redhat 9. The default config indicates it does run stand-alone.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CUPS problem! "localhost:631, connection refused"!!! robbow52 Debian 5 03-04-2009 02:27 PM
localhost connection refused. Sapient Linux - Networking 6 01-17-2006 05:52 AM
The connection was refused when attempting the localhost green_njk Linux - Software 14 12-17-2005 01:34 AM
Connection to localhost refused?!? a_priebe47 Slackware 4 09-01-2004 10:05 PM
connection to localhost refused digitalgravy Linux - Networking 5 05-03-2004 05:27 PM


All times are GMT -5. The time now is 12:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration