LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-19-2009, 12:59 AM   #1
dsartain
LQ Newbie
 
Registered: Feb 2007
Posts: 22

Rep: Reputation: 0
VSFTPD - Changing FTP Port


I'm having trouble getting my VSFTPD server on Fedora Core 11 to listen on both ports 21 and 2020.

It works fine on 21, with the command

Quote:
ftp localhost

But when I try it on 2020 with the command


Quote:
ftp localhost:2020
I get the error:
Quote:
ftp: localhost:2020: Name or service not known
I've added port 2020 to SELINUX, the firewall (and tried disabling it), and added the listen_port line in the vsftpd.conf file...

As the error I'm getting is saying that the name or service isn't known, I think that it's somehow that the OS doesn't know that port 2020 = FTP...


/etc/vsftpd/vsftpd.conf file contents...

Quote:

# Example config file /etc/vsftpd/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
#write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
#local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES

# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES

# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
#xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES

# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd/banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd/chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
# When "listen" directive is enabled, vsftpd runs in standalone mode and
# listens on IPv4 sockets. This directive cannot be used in conjunction
# with the listen_ipv6 directive.
listen=YES
listen_port=2020
listen_port=21
#
# This directive enables listening on IPv6 sockets. To listen on IPv4 and IPv6
# sockets, you must run two copies of vsftpd whith two configuration files.
# Make sure, that one of the listen options is commented !!
#listen_ipv6=YES

pam_service_name=vsftpd
userlist_enable=YES
tcp_wrappers=NO
check_shell=NO

I'm sorry for posting so much content, but I didn't want to waste anyone's time and make them ask me for something I should have posted in the first place.

Any help would be much appreciated.

Thanks...
 
Old 08-19-2009, 01:12 AM   #2
settntrenz
Member
 
Registered: Aug 2009
Location: Orlando, Florida
Distribution: RHEL, Ubuntu
Posts: 49

Rep: Reputation: 19
When specifying a port with the cli ftp client, use a space not a colon.

Code:
ftp localhost 2020
Also, to verify that the server is in fact listening on that port

Code:
# lsof -i tcp:2020
I've never tried running vsftpd on two ports. Multiple interfaces, yes. But not two ports at the same time. Not sure that it will work without running another instance. Is there any reason you want it to listen on both ports?

Last edited by settntrenz; 08-19-2009 at 01:16 AM.
 
Old 08-19-2009, 04:14 AM   #3
mufy
Member
 
Registered: Oct 2004
Location: Kuwait
Distribution: Currently - AIX | Previously - RHEL 4 ES, FC 10
Posts: 206
Blog Entries: 4

Rep: Reputation: 30
Don't you require an entry for 'vsftpd' in /etc/services file as well?
 
Old 08-19-2009, 09:13 PM   #4
dsartain
LQ Newbie
 
Registered: Feb 2007
Posts: 22

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by settntrenz View Post
When specifying a port with the cli ftp client, use a space not a colon.

Code:
ftp localhost 2020
Also, to verify that the server is in fact listening on that port

Code:
# lsof -i tcp:2020
I've never tried running vsftpd on two ports. Multiple interfaces, yes. But not two ports at the same time. Not sure that it will work without running another instance. Is there any reason you want it to listen on both ports?
Ok, I took out the listen_port=21 and left it as just 2020, and it let me connect, but when I tried to get the directory listing, it gave me an error

Quote:
226 Transfer done (but failed to open directory).
I then added the following lines to /etc/vsftpd/vsftpd.conf

Quote:
userlist_deny=NO
userlist_file=/etc/vsftpd/vsftpd.user_list
I also created the respective file with my username...Still the same error about not opening the directory...
 
Old 08-19-2009, 09:37 PM   #5
dsartain
LQ Newbie
 
Registered: Feb 2007
Posts: 22

Original Poster
Rep: Reputation: 0
FYI, I just disabled SELINUX, and it worked fine...can someone tell me how to configure SELINUX to allow FTP to access the directories??

Thanks
 
Old 08-19-2009, 10:02 PM   #6
dsartain
LQ Newbie
 
Registered: Feb 2007
Posts: 22

Original Poster
Rep: Reputation: 0
Found it...

I ran the following command as root and I'm up and running now.

Quote:
/usr/sbin/setsebool -P ftp_home_dir=1

THANKS!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd ls error: 500 Illegal port command ftp : bind : Adress allready in use shorun Linux - Server 3 11-17-2007 04:35 PM
Changing Access Port in Wu-Ftp shane25119 Linux - Server 0 03-18-2007 07:07 PM
ftp data port in proftpd and vsftpd fakie_flip Linux - Networking 8 08-22-2006 02:19 PM
vsFTPd - Changing folders and Port Connection Palula Linux - Software 0 09-12-2005 08:19 PM
changing the port on vsftpd nuzzy Linux - Software 8 05-05-2003 07:24 PM


All times are GMT -5. The time now is 09:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration